Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg11-7.* & powerbook-G3 - ATY Mach64: support ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Mon Feb 05, 2007 11:35 am    Post subject: Xorg11-7.* & powerbook-G3 - ATY Mach64: support ? Reply with quote

fb : atyfb - 3D RAGE LT PRO (Mach64 LI, PCI) [0x4c49 rev 0xdc]
fb0: ATY Mach64 frame buffer device on PCI
machine : {PowerBook Wallstreet, PowerBook Lombard}
pmac-generation : {OldWorld, NewWorld



i emerged x11-base/xorg-X11-6.8.2-r6 with 2005.1 portage.
X11 is perfectly running, color are great and the fb is fast


i clean the harddisk, i re-emerged all with portage 2006.1 and the new stage-3
i used -- USE="insecure-drivers" in /etc/make.conf
( +) Local flag: Builds insecure DRI stuff for via, mach64 and savage (x11-base/xorg-x11)

and i emerged x11-base/xorg-x11-7.1
then x11-drivers/xf86-video-ati-6.6.1


i get a X11 running in 8bit color mode, and slow

in /etc/X11/xorg.cong
Depth 16
or
Depth 24

is ignored and forced to 8, because i see 8bit color


any idea ?



driver=ati startx.log
Quote:

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN
Current Operating System: Linux elena 2.6.12-gentoo-woozy-numbat-apple-powerbook-g3-wallstreet #8 Mon Jan 22 07:02:42 GMT 2007 ppc
Build Date: 28 January 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 4 12:31:08 2007
(==) Using config file: "/etc/X11/xorg.conf"

(WW) ****INVALID IO ALLOCATION**** b: 0xfe000400 e: 0xfe0004ff correcting
(EE) end of block range 0xfdffffff < begin 0xfe000000
(!!) ATI(0): Invalid horizontal sync pulse timing detected in mode on server entry.
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc(pc101)+us" };
xkb_geometry { include "pc(pc101)" };


waiting for X server to shut down FreeFontPath: FPE "/usr/share/fonts/misc/" refcount is 2, should be 1; fixing.



/etc/X11/xorg.conf
Quote:

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "freetype"
# Load "xtt"
Load "extmod"
#Load "glx"
#Load "dri"
Load "dbe"
Load "record"
Load "xtrap"
Load "type1"
# Load "speedo"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/input/mice"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
### Comment all HorizSync and VertSync values to use DDC:
# HorizSync 31.5 - 31.5
# HorizSync 35.5 - 35.5
# VertRefresh 50.0 - 70.0
EndSection

Section "Device"
Identifier "Card0"
Driver "ati"
#Driver "fbdev"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
# DefaultDepth 8
SubSection "Display"
# Viewport 0 0
# Depth 16
# Depth 24
# #Modes "1152x864"
# Modes "1024x768"
EndSubSection
EndSection
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Feb 06, 2007 3:50 am    Post subject: Reply with quote

I think the DRM module isn't currently included in the kernel, but can you post your actual log? It can be found at: /var/log/Xorg.0.log

I'd have to check, but I don't think it's currently working and is waiting for a new DRM snapshot.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Sun Feb 18, 2007 11:29 pm    Post subject: Reply with quote

i'm surprised: i solved this problem using Xorgautoconfig: this program sets /etc/X11/xorg.cong with a magic special values enabling 16bit color &C
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum