Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
keyboard layout iBook G4 [part. solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
powerflo
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jan 2007
Posts: 99

PostPosted: Tue Feb 06, 2007 11:26 am    Post subject: keyboard layout iBook G4 [part. solved] Reply with quote

Hello,
i have an iBook G4 1.33. My problem is the keyboard. I want a German keyboard layout but there are so many Files with keyboard settings (/etc/X11/xorg.conf; /etc/locale.gen; /etc/conf.d/keymaps and the Gnome settings). I don't know what to write in each file to get a correct keyboard layout.
I hope that you can help me.

Thanks

powerflo


Last edited by powerflo on Tue Feb 06, 2007 9:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
Fugee47
Apprentice
Apprentice


Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Tue Feb 06, 2007 4:58 pm    Post subject: Reply with quote

try this in your xorg.conf:

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbOptions" "ctrl:nocaps, lv3:lwin_switch"
Option "LeftAlt" "Meta"
Option "RightAlt" "LWin"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection
Back to top
View user's profile Send private message
powerflo
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jan 2007
Posts: 99

PostPosted: Tue Feb 06, 2007 8:40 pm    Post subject: Reply with quote

thank you very much!

in the gnome terminal i can't write an ä, ö, ü but {[]} is possible. how can i get äöü also in the gnome terminal?
when i haven't started Gnome äöü and @{[]} don't work.

powerflo
Back to top
View user's profile Send private message
powerflo
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jan 2007
Posts: 99

PostPosted: Wed Feb 07, 2007 4:54 pm    Post subject: Reply with quote

nobody :?:
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Feb 07, 2007 5:02 pm    Post subject: Reply with quote

Have you looked at the localization guide yet?
http://www.gentoo.org/doc/en/guide-localization.xml
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
powerflo
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jan 2007
Posts: 99

PostPosted: Wed Feb 07, 2007 6:55 pm    Post subject: Reply with quote

Yes I've read this guide and i have a german qwertz layout. But this keys don't work: @{[]}\~

my /etc/conf.d/keymaps:

Code:
# /etc/conf.d/keymaps

# Use KEYMAP to specify the default console keymap.  There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.

KEYMAP="de-latin1-nodeadkeys"


# Should we first load the 'windowkeys' console keymap?  Most x86 users will
# say "yes" here.  Note that non-x86 users should leave it as "no".

SET_WINDOWKEYS="no"
   
   
# The maps to load for extended keyboards.  Most users will leave this as is.

EXTENDED_KEYMAPS=""
#EXTENDED_KEYMAPS="backspace keypad euro"
   
   
# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set UNICODE="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`

DUMPKEYS_CHARSET=""


and in the gnome-terminal {[]}@ ist possible. Only öäü doesn't work. I don't know why...
Back to top
View user's profile Send private message
powerflo
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jan 2007
Posts: 99

PostPosted: Sat Feb 10, 2007 8:58 pm    Post subject: Reply with quote

no solution to that problem?
Back to top
View user's profile Send private message
salmonix
Guru
Guru


Joined: 16 Jul 2006
Posts: 410

PostPosted: Mon Feb 12, 2007 10:05 am    Post subject: Reply with quote

You might try to adjust the xkbrules - that is a keymap layout.
If U google U can get a number of hints. (like "change keyboard layout linux", "xkbrules" etc.)
The problem is that i there is no really good documentation on it. For changing some keys thereis a shortcut-way, but I was playing with rewriting my keyboard without success.
Anyway, have a look at it... I am curious about your results...
_________________
Quis custodiet ipsos, custodes?
Back to top
View user's profile Send private message
srm
n00b
n00b


Joined: 14 Dec 2005
Posts: 71
Location: in da Heide. this globe

PostPosted: Sat Jun 23, 2007 5:24 pm    Post subject: Reply with quote

powerflo, conf.d/keymaps is only applicable for the tty's encoding, x uses the config from xorg.conf
here is my xorg.conf section (quite similar to Fugee47's one)
Code:
Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "keyboard"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "de"
        Option          "XkbOptions"    "ctrl:nocaps,lv3:lwin_switch,eurosign:e"
        Option          "LeftAlt"       "Meta"
        Option          "RightAlt"      "LWin"
        #Option         "XkbRules"      "xorg"
### Uncomment this if your layout uses nodeadkeys
        Option          "XkbVariant"    "nodeadkeys"
EndSection

additionaly, you might want to check the encoding-settings for the gnome-terminal. this could also be an issue.
For my kde-terminal i use either UTF-8 or Western-ISO-8859 -1
For the standard Terminal (the non-x tty), i had to alter some keymaps from /usr/share/keymaps/ ... maybe i can recover the changes to post them.
This all was done for my powerbook g4.
_________________
I'm no longer angry,for having to truncate my sig because it got to long with the following reminder:
Please check unanswered posts
co chaoid sounds
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum