Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-ruby/sqlite3-ruby-1.1.0 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jami
n00b
n00b


Joined: 11 Feb 2007
Posts: 15
Location: Stralsund/Germany

PostPosted: Sat Feb 17, 2007 1:50 am    Post subject: dev-ruby/sqlite3-ruby-1.1.0 failed Reply with quote

can't emerge rails

Code:

localhost localhost # cat /var/log/portage/dev-ruby\:sqlite3-ruby-1.1.0\:20070217-024705.log
>>> Unpacking source...
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/work ...
>>> Source compiled.
>>> Test phase [not enabled]: dev-ruby/sqlite3-ruby-1.1.0

>>> Install sqlite3-ruby-1.1.0 into /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image/ category dev-ruby
sqlite3_api_wrap.c: In function '_wrap_sqlite3_trace':
sqlite3_api_wrap.c:2336: warning: cast from pointer to integer of different size
make: /bin/install: Command not found
make: *** [/var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image/usr/lib64/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/lib/sqlite3_api.so] Error 127
ERROR:  Error installing gem /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/distdir/sqlite3-ruby-1.1.0[.gem]: ERROR: Failed to build gem native extension.
Gem files will remain installed in /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image/usr/lib64/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0 for inspection.
  ruby extconf.rb install /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/distdir/sqlite3-ruby-1.1.0 -v 1.1.0 --ri --rdoc -l -i /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image///usr/lib64/ruby/gems/1.8\nchecking for sqlite3.h... yes
checking for sqlite3_open() in -lsqlite3... yes
creating Makefile
\nmake\nx86_64-pc-linux-gnu-gcc -I. -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -DHAVE_SQLITE3_H -I/usr/local/include  -fPIC -march=athlon64 -O2 -pipe  -fPIC  -c sqlite3_api_wrap.c
x86_64-pc-linux-gnu-gcc -shared  -L'/usr/local/lib' -Wl,-R'/usr/local/lib' -L'/usr/lib64' -Wl,-R'/usr/lib64' -o sqlite3_api.so sqlite3_api_wrap.o  -Wl,-R -Wl,/usr/lib64 -L/usr/lib64 -L. -lruby18 -lsqlite3  -ldl -lcrypt -lm   -lc
\nmake install\n/bin/install -c -m 0755 sqlite3_api.so /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image/usr/lib64/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/lib


Results logged to /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image/usr/lib64/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/ext/sqlite3_api/gem_make.out
Building native extensions.  This could take a while...
ruby extconf.rb install /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/distdir/sqlite3-ruby-1.1.0 -v 1.1.0 --ri --rdoc -l -i /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image///usr/lib64/ruby/gems/1.8
checking for sqlite3.h... yes
checking for sqlite3_open() in -lsqlite3... yes
creating Makefile

make
x86_64-pc-linux-gnu-gcc -I. -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -DHAVE_SQLITE3_H -I/usr/local/include  -fPIC -march=athlon64 -O2 -pipe  -fPIC  -c sqlite3_api_wrap.c
x86_64-pc-linux-gnu-gcc -shared  -L'/usr/local/lib' -Wl,-R'/usr/local/lib' -L'/usr/lib64' -Wl,-R'/usr/lib64' -o sqlite3_api.so sqlite3_api_wrap.o  -Wl,-R -Wl,/usr/lib64 -L/usr/lib64 -L. -lruby18 -lsqlite3  -ldl -lcrypt -lm   -lc

make install
/bin/install -c -m 0755 sqlite3_api.so /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image/usr/lib64/ruby/gems/1.8/gems/sqlite3-ruby-1.1.0/lib

!!! ERROR: dev-ruby/sqlite3-ruby-1.1.0 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_install
  ebuild.sh, line 1060:   Called qa_call 'src_install'
  environment, line 3267:   Called src_install
  ebuild.sh, line 1304:   Called gems_src_install
  gems.eclass, line 78:   Called die

!!! gem install failed (spec file /var/tmp/portage/dev-ruby/sqlite3-ruby-1.1.0/image///usr/lib64/ruby/gems/1.8/specifications/sqlite3-ruby-1.1.0.gemspec missing)
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/log/portage/dev-ruby:sqlite3-ruby-1.1.0:20070217-024705.log'.

This ebuild used the following eclasses from overlays:

  /usr/portage/eclass/ruby.eclass
  /usr/portage/eclass/eutils.eclass
  /usr/portage/eclass/multilib.eclass
  /usr/portage/eclass/portability.eclass
  /usr/portage/eclass/toolchain-funcs.eclass
  /usr/portage/eclass/gems.eclass



Thanks for the help
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Sat Feb 17, 2007 1:52 am    Post subject: Reply with quote

Hi.

Update your ruby install and then try again. You should run revdep-rebuild to build all ruby packages. IIRC, this happened after a coreutils update.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
jami
n00b
n00b


Joined: 11 Feb 2007
Posts: 15
Location: Stralsund/Germany

PostPosted: Sat Feb 17, 2007 3:26 am    Post subject: Reply with quote

Ok now the ebuild runs. Thank u
Where did you get the informations in this error from. (Focused to the problem that my ruby is out of date)

Best regards
jami
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Sat Feb 17, 2007 3:42 am    Post subject: Reply with quote

I had the same issue because of an amarok dependency :wink:
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
jami
n00b
n00b


Joined: 11 Feb 2007
Posts: 15
Location: Stralsund/Germany

PostPosted: Sat Feb 17, 2007 3:51 am    Post subject: Reply with quote

That sounds reasonable :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum