Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X11 mising file for GLX direct rendering?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
VanFanel
Apprentice
Apprentice


Joined: 19 Feb 2007
Posts: 161

PostPosted: Thu Feb 22, 2007 8:11 pm    Post subject: X11 mising file for GLX direct rendering? Reply with quote

Hello there!

I have emerged the latest X11 and whenever I activathe the GLX extension, it says that IAGLX is missing the file r200_dri.so.
I am on a MAC MIN G4 as usual, and I have the USE flags for dri and radeon, and the VIDEO_CARDS variable set to "radeon", both things in /etc/make.conf.
It compiled with no problems, and I have both RADEON and DRI support enable in the kernel configuraton (gentoo-sources-2.6.19-r5).
Any ideas? I have re-emerged several times and I am not on a very fast machine...Thanks!!
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Feb 22, 2007 8:24 pm    Post subject: Reply with quote

r200_dri.so is part of media-libs/mesa it seems. Try reemerging mesa.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
VanFanel
Apprentice
Apprentice


Joined: 19 Feb 2007
Posts: 161

PostPosted: Thu Feb 22, 2007 11:58 pm    Post subject: Reply with quote

Wow! Thanks! I couldn't find the file anywere in the system..will try tonight...and will tell ya if it wored

Thanks a TON!!
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Feb 23, 2007 3:04 am    Post subject: Reply with quote

Most likely, you enabled the radeon video card after you compiled mesa. In the future, when doing something like this, using the --newuse flag with emerge will help to find packages with the changed USE flag so they can be recompiled with the proper settings.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
delancie
n00b
n00b


Joined: 15 Mar 2007
Posts: 2

PostPosted: Thu Mar 22, 2007 10:57 am    Post subject: Reply with quote

i had the same problem and

emerge mesa

helped :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum