Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dhcpcd not found [partialy SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Sat Feb 24, 2007 8:59 pm    Post subject: dhcpcd not found [partialy SOLVED] Reply with quote

Hi,
I have troubles with the dhcpcd. I have emerged it (3.0.13), re-emerged-it etc, but It cannot be launched with the /etc/init.d/net.eth0 start command. The message is :
Quote:

No DHCP client installed


So, I add this to my /etc/rc.d/net file :
Code:

modules=( "dhcpcd" )


And now the message is :
Quote:

we require dhcpcd-2.0.0 or newer


I can run dhcpcd eth0, sometimes it works...

Thx !
_________________
http://stan.openmod.org


Last edited by Frelon on Tue Feb 27, 2007 4:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Feb 24, 2007 9:36 pm    Post subject: Reply with quote

Can you post your /etc/conf.d/net plz ?
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Sun Feb 25, 2007 12:41 am    Post subject: Reply with quote

Of course, but not sure it is gonna help :-)

Code:

HOSTNAME="stanbook" ~ # more /etc/conf.d/net
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
modules=( "dhcpcd" )
config_eth0=( "dhcp" )


I have also tried with all blank.
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Feb 25, 2007 7:52 pm    Post subject: Reply with quote

I have the same config file as yours....

I don't know :oops:
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Sun Feb 25, 2007 8:27 pm    Post subject: Reply with quote

I personally don't have the "module" line.
I notice that the version of dhcpcd that you use is from ~ppc.
Can you try with the stable version (2.0.5-r1) or is it necessary
for other ~ppc ebuild that you have pulled?
If it works with the stable version that's probably an issue to report
before the version of dhcpcd you use can be deemed stable.
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Tue Feb 27, 2007 4:13 am    Post subject: Reply with quote

I rolled back to the stable version and it works fine now. Thanks !!
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum