Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] unable to emerge baselayout-lite: missing keyword
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
VanFanel
Apprentice
Apprentice


Joined: 19 Feb 2007
Posts: 161

PostPosted: Mon Mar 05, 2007 7:56 pm    Post subject: [SOLVED] unable to emerge baselayout-lite: missing keyword Reply with quote

That appears to be the problem; I encountered it while trying to follow these instruction to build a hightly optitized gentoo Power PC system to emulate Commodore Amiga enviroments:

I aded the line "sys-apps/baselayout-lite -*" to /etc/portage/package.keywords in order to avoid portage's complainig about the masked package, but no way to emerge it: MASKED PACKAGE error persists! Any ideas? Thanks!!

edit by nixnut: wrapped url in tags to prevent mile wide html page


Last edited by VanFanel on Thu Mar 08, 2007 5:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Mar 05, 2007 8:36 pm    Post subject: Reply with quote

Take a look at this:
http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml#masked

Baselayout-lite is not intended for regular use. You should familiarize yourself with emerge before you try using this, it has the potential to break a regular Gentoo install if not installed properly.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Mon Mar 05, 2007 8:39 pm    Post subject: Reply with quote

Please read the entire error output: it complains about a missing keyword, and if you would be looking at the ebuild itself, you would notice the following line
Code:
KEYWORDS=""


Copy the ebuild over to you local overlay, and add the wanted keyword (~ppc i presume), and update the digest. Then you should be able to emerge normally. Although a missing keyword means often some trouble. If it works fine file a bug, to get the respective keyword added.

Cheers
V.
Back to top
View user's profile Send private message
VanFanel
Apprentice
Apprentice


Joined: 19 Feb 2007
Posts: 161

PostPosted: Mon Mar 05, 2007 8:44 pm    Post subject: Reply with quote

I am not installing baselayout-lite on my own system, but on a embedded system I am building in a directory, by using ROOT=/target, so it's not that dangerousr, Jose; I know what I am doing; I am not interested in reverting my system to a minimal enviroment :D that's why I am doing it in a directory in order to eventually copy that directory to it's own partition.
Anyway, I think I am going to install baselayout-lite by hand since I haven't internet connection at home to emerge the packages...

Thanks!
Back to top
View user's profile Send private message
corsair
Retired Dev
Retired Dev


Joined: 06 Oct 2003
Posts: 451
Location: Aachen, Germany

PostPosted: Thu Mar 08, 2007 7:30 am    Post subject: Reply with quote

Code:

G5 ~ # emerge baselayout-lite -p

These are the packages that would be merged, in order:

Calculating dependencies /
!!! All ebuilds that could satisfy "baselayout-lite" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/baselayout-lite-1.0_pre1 (masked by: missing keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

G5 ~ # echo "sys-apps/baselayout-lite **" >> /etc/portage/package.keywords
G5 ~ # emerge baselayout-lite -p

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] sys-apps/baselayout-lite-1.0_pre1  USE="-bootstrap -build"
G5 ~ #
Back to top
View user's profile Send private message
VanFanel
Apprentice
Apprentice


Joined: 19 Feb 2007
Posts: 161

PostPosted: Thu Mar 08, 2007 5:10 pm    Post subject: Reply with quote

Hey thanks!! I installed it succesfully now (at lesst that package; I'll try th erest of the project for the minnimal AMIGA emulation enviroment when I have the time to do so).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum