Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] audacious cant play mp3s
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
lordcris
Apprentice
Apprentice


Joined: 09 Jul 2002
Posts: 248

PostPosted: Sun Mar 11, 2007 11:11 pm    Post subject: [solved] audacious cant play mp3s Reply with quote

hello,
i updated audacious recently (audacious-1.3.1) and i cant play mp3's anymore - waves are fine.
I hear only a random noise.
mplayer works fine.
I read somewhere i could be a libmad issue, but trying an old version didn't help.
i heve a powerbook 17''
and mu use flags are

Code:
emerge -pv audacious audacious-plugins

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-sound/audacious-1.3.1  USE="nls -chardet" 0 kB
[ebuild   R   ] media-plugins/audacious-plugins-1.3.1-r1  USE="aac alsa flac mad musepack nls opengl oss vorbis wma -adplug -arts -chardet -esd -jack -lirc -modplug -pulseaudio -sid -sndfile -timidity -tta -wavpack" 0 kB



any suggestions?


Last edited by lordcris on Mon Mar 12, 2007 2:36 am; edited 1 time in total
Back to top
View user's profile Send private message
nichocouk
Guru
Guru


Joined: 10 Mar 2005
Posts: 585
Location: Glasgow

PostPosted: Sun Mar 11, 2007 11:20 pm    Post subject: Reply with quote

Hello,
I'm no expert here, but 1st thing to try is:
- quit audacious
- move your .audacious/ to somewhere safe
- start audacious from the command line and try again, + post back here the output from the command line

Cheers
_________________
nichocouk

L'Etat, c'est moi.
Back to top
View user's profile Send private message
lordcris
Apprentice
Apprentice


Joined: 09 Jul 2002
Posts: 248

PostPosted: Mon Mar 12, 2007 12:05 am    Post subject: Reply with quote

hello,

Code:
audacious 055.Vera\ Matovic\ -\ Vladimire\,Vlado1984.mp3
Destroy Semaphore
Destroy Mutex
projectM plugin: Cleanup completed



i did what you said, but unfortunately it didn't help.
i got the same result and i didn't see any error.
Back to top
View user's profile Send private message
nenolod
Apprentice
Apprentice


Joined: 03 Mar 2006
Posts: 199
Location: Tulsa, OK

PostPosted: Mon Mar 12, 2007 12:10 am    Post subject: Reply with quote

Hi, can you e-mail the problematic MP3 to nenolod -at- sacredspiral.co.uk? That will be useful for debugging this problem.
Back to top
View user's profile Send private message
lordcris
Apprentice
Apprentice


Joined: 09 Jul 2002
Posts: 248

PostPosted: Mon Mar 12, 2007 12:13 am    Post subject: Reply with quote

hi,
i get this error with all my mp3s
i get the same error using madplay.
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Mon Mar 12, 2007 2:24 am    Post subject: Reply with quote

Then it is definitely a libmad problem. Can you be a bit more explicit
about your machine? Is it a G3 or a G4 processor?
The libmad problem we were discussing previously seemed to be
specific to G3 because of some improper optimization in the last
version of libmad. But reverting to an older version (0.15.1b) was
working for paoleela.
Now on the other hand you are using stuff from ~ppc so there may be
other breakages.
You should check bugzilla for audacious-plugins and libmad to see if
it is known.
Back to top
View user's profile Send private message
lordcris
Apprentice
Apprentice


Joined: 09 Jul 2002
Posts: 248

PostPosted: Mon Mar 12, 2007 2:35 am    Post subject: Reply with quote

hi,
i reverted to libmad-0.15.1b and recompiled audacious-plugins.
now it works.
thank you all!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum