Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Resolved] Cannot update ffmpeg to 0.4.9_p20070330
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Sat Mar 31, 2007 7:46 am    Post subject: [Resolved] Cannot update ffmpeg to 0.4.9_p20070330 Reply with quote

I updated the system with emerge -DNuv world, all went fine, except updating ffmpeg. The last messages are:
Code:
x86_64-pc-linux-gnu-gcc -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg" -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg" -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg"/libavutil -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg"/libavcodec -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg"/libavformat -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg"/libswscale -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg"/libswscale   -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg" -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg" -I"/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg"/libavutil -march=athlon64 -O2 -pipe -fomit-frame-pointer -Wdeclaration-after-statement -Wall -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -fPIC -DPIC -c -o ra144.o ra144.c
make[1]: *** [h264.o] Error 1
make[1]: *** ïÖÉÄÁÎÉÅ ÚÁ×ÅÒÛÅÎÉÑ ÚÁÄÁÎÉÊ...
In file included from ra144.c:22:
avcodec.h:2460: warning: ‘ImgReSampleContext’ is deprecated
avcodec.h:2463: warning: ‘ImgReSampleContext’ is deprecated
make[1]: Leaving directory `/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg/libavcodec'
make: *** [lib] Error 2

!!! ERROR: media-video/ffmpeg-0.4.9_p20070330 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_compile
  ebuild.sh, line 971:   Called qa_call 'src_compile'
  environment, line 3350:   Called src_compile
  ffmpeg-0.4.9_p20070330.ebuild, line 167:   Called die

!!! make failed


Does anybody else experience similar problem? What should I do to fix it?

There were many other warnings and errors reported before. The log seems too long to post it here. Just in case I've put it here: http://acheron.front.ru/ffmpeg-0.4.9_p20070330.build.log.txt (226594 bytes)


Last edited by acheron2 on Sat Apr 07, 2007 7:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat Mar 31, 2007 8:39 am    Post subject: Reply with quote

Please post your `emerge --info`
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Sat Mar 31, 2007 8:50 am    Post subject: Reply with quote

mark_alec wrote:
Please post your `emerge --info`

Sorry, forgot.
Code:

Portage 2.1.2.2 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 31 Mar 2007 06:00:01 +0000
ccache version 2.4 [disabled]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ ftp://cesium.di.uminho.pt/pub/gentoo/ http://ftp.gentoo.or.kr/ ftp://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp.isu.edu.tw/pub/Linux/Gentoo http://ftp.isu.edu.tw/pub/Linux/Gentoo http://mirror.gentoo.gr.jp http://gentoo.cites.uiuc.edu/pub/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ ftp://ftp.du.se/pub/os/gentoo"
LANG="ru_RU.UTF-8"
LC_ALL="ru_RU.UTF-8"
LINGUAS="ru en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X alsa amd64 berkdb bitmap-fonts cairo cli cracklib crypt cups curl doc dri flac fortran gdbm gif gpm iconv isdnlog jpeg kde libg++ midi mp3 ncurses nls nptl nptlonly ogg opengl pam pcre perl png ppds pppd python readline reflection sdl sdl-sound session slang spl ssl svg tcpd tiff timidity truetype truetype-fonts type1-fonts unicode userlocales vorbis xorg xpm zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="apm ark ati chips cirrus cyrix dummy fbdev glint i128 i810 mga neomagic nv rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat Mar 31, 2007 8:57 am    Post subject: Reply with quote

Report this at https://bugs.gentoo.org - as your system seems to be sane (no crazy CFLAGS).
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Sat Mar 31, 2007 9:12 am    Post subject: Reply with quote

mark_alec wrote:
Report this at https://bugs.gentoo.org - as your system seems to be sane (no crazy CFLAGS).

Checked again, it's already there: https://bugs.gentoo.org/show_bug.cgi?id=172845
Back to top
View user's profile Send private message
n3Cre0
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2007
Posts: 129

PostPosted: Sat Mar 31, 2007 10:44 am    Post subject: Reply with quote

Same problem here.

Glad I'm not the only one ;)

Will wait some time now.

Just for the record
Quote:
USE="X aac acpi alsa amarok apm avahi avi bash-completion berkdb bitmap-fonts branding cairo cdr cli cracklib crypt cups dbus directfb divx4linux dri dvd dvdr emboss encode esd fam ffmpeg firefox fortran gdbm gif gnome gpm gtk gtk2 hal iconv ipv6 isdnlog java jpeg junit ldap libg++ mad mikmod mozbranding mozilla mp3 mpeg msn ncurses nls nojoystick nptl nptlonly nsplugin ogg opengl oss pam pcre perl png ppds pppd python qt3 qt4 quicktime readline reflection samba sdl session sockets spell spl ssl tcpd tetex truetype truetype-fonts type1-fonts unicode vorbis wifi win32codecs x86 xine xml xorg xv xvid zlib" ALSA_CARDS="hda-intel"

_________________
OS: Linux 2.6.26 i686 Gentoo v2.0.0 Sound: HDA Intel
CPU: Intel(R) Pentium(R) M processor 1.73GHz (GenuineIntel)
Disk: 95.23GB Video: ATI Radeon Mobility X700 XL with Catalyst 8.08 RAM: 1011MB
Back to top
View user's profile Send private message
Autie
Guru
Guru


Joined: 25 Jul 2003
Posts: 309
Location: Ledegem - Belgium

PostPosted: Sat Mar 31, 2007 10:52 am    Post subject: Reply with quote

same problem here
also on arch=~amd64
_________________
The capacity to learn is a gift; The ability to learn is a skill; The willingness to learn is a choice.
Back to top
View user's profile Send private message
cfreak200
n00b
n00b


Joined: 18 Feb 2007
Posts: 69
Location: /europe/germany/hessen

PostPosted: Sat Mar 31, 2007 10:53 am    Post subject: Reply with quote

I have some Problems while emerging ffmpeg-0.4.0_pw20070330, too.
but i get a different error

Quote:
{standard input}: Assembler messages:
{standard input}:33: Error: junk `(%rip)' after expression
{standard input}:46: Error: junk `(%rip)' after expression
{standard input}:48: Error: junk `(%rip)+128' after expression
{standard input}:63: Error: junk `(%rip)' after expression
{standard input}:94: Error: junk `(%rip)' after expression
{standard input}:107: Error: junk `(%rip)' after expression
{standard input}:109: Error: junk `(%rip)+128' after expression
{standard input}:124: Error: junk `(%rip)' after expression
{standard input}:6557: Error: junk `(%rip)' after expression
{standard input}:6570: Error: junk `(%rip)' after expression
{standard input}:6572: Error: junk `(%rip)+128' after expression
{standard input}:6587: Error: junk `(%rip)' after expression
{standard input}:6598: Error: junk `(%rip)' after expression
{standard input}:6611: Error: junk `(%rip)' after expression
{standard input}:6613: Error: junk `(%rip)+128' after expression
{standard input}:6628: Error: junk `(%rip)' after expression
{standard input}:6709: Error: junk `(%rip)' after expression
{standard input}:6722: Error: junk `(%rip)' after expression
{standard input}:6724: Error: junk `(%rip)+128' after expression
{standard input}:6739: Error: junk `(%rip)' after expression
{standard input}:6748: Error: junk `(%rip)' after expression
{standard input}:6753: Error: junk `(%rip)' after expression
{standard input}:6766: Error: junk `(%rip)' after expression
{standard input}:6768: Error: junk `(%rip)+128' after expression
{standard input}:6783: Error: junk `(%rip)' after expression
make[1]: *** [h264.o] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg/libavcodec'
make: *** [lib] Fehler 2


My emerge --info

Quote:

$ emerge --info
Portage 2.1.2.3 (default-linux/amd64/2006.1, gcc-4.1.2, glibc-2.5-r1, 2.6.20-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r3 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 31 Mar 2007 08:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.31-r5
dev-lang/python: 2.4.4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox: 1.2.18.1
sys-devel/autoconf: 2.13, 2.61
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.17
sys-devel/gcc-config: 1.3.15-r1
sys-devel/libtool: 1.5.23b
virtual/os-headers: 2.6.20-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/php/apache1-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://pandemonium.tiscali.de/pub/gentoo/ http://pandemonium.tiscali.de/pub/gentoo/ http://85.25.128.62"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LINGUAS="de"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac administrator alsa amd64 ansi apache2 arts berkdb bitmap bitmap-fonts bluetooth bzip2 cli cracklib crypt cups dbus dri dvd dvdr dvdread firefox flac fortran ftp gd gdbm gif giff glitz gnome gpm gstreamer gtk gtk+ gtk2 hal iconv icq immqt ipv6 irmc isdnlog java jpeg kde lame libg++ logitech-mouse mad midi mozbranding mp3 mpeg msn mysql mysqli ncurses nls nptl nptlonly nsplugin ogg opengl oss pam pcre perl png ppds pppd python qt qt3 qt4 query-browser readline reflection session socks5 spl ssl tcpd threads truetype truetype-fonts type1-fonts unicode vorbis wma workbench xinerama xml xorg xvid zip zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
Thinkpad - T61 - 15,4"
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Sat Mar 31, 2007 12:39 pm    Post subject: Reply with quote

same here on ~x86, btw - transcode also failed to build due to libavcodec :/
Back to top
View user's profile Send private message
chrisfreet
n00b
n00b


Joined: 12 Nov 2004
Posts: 54
Location: Chicago, IL

PostPosted: Sat Mar 31, 2007 2:02 pm    Post subject: Reply with quote

Same problem:

Code:
h264.c: In function 'decode_mb_cavlc':
h264.c:5302: warning: unused variable 'ref_count'
h264.c: In function 'decode_cabac_residual':
h264.c:6115: warning: passing argument 4 of 'decode_significance_8x8_x86' discards qualifiers from pointer target type
h264.c:6042: warning: unused variable 'last'
h264.c: In function 'filter_mb_fast':
h264.c:7067: warning: dereferencing type-punned pointer will break strict-aliasing rules
h264.c: At top level:
cabac.h:109: warning: 'put_cabac_static' defined but not used
cabac.h:155: warning: 'put_cabac_terminate' defined but not used
cabac.h:183: warning: 'put_cabac_u' defined but not used
cabac.h:218: warning: 'put_cabac_ueg' defined but not used
cabac.h:270: warning: 'refill2' defined but not used
cabac.h:808: warning: 'get_cabac_u' defined but not used
cabac.h:824: warning: 'get_cabac_ueg' defined but not used
cabac.h: In function 'get_cabac_noinline':
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h: In function 'get_cabac':
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
make[1]: *** [h264.o] Error 1
make[1]: *** Waiting for unfinished jobs....
In file included from imc.c:40:
avcodec.h:2460: warning: 'ImgReSampleContext' is deprecated
avcodec.h:2463: warning: 'ImgReSampleContext' is deprecated
make[1]: Leaving directory `/tmp/32bit/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg/libavcodec'
make: *** [lib] Error 2

!!! ERROR: media-video/ffmpeg-0.4.9_p20070330 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_compile
  ebuild.sh, line 971:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  ffmpeg-0.4.9_p20070330.ebuild, line 167:   Called die


emerge --info:

Code:
Portage 2.1.2.3 (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.5-r1, 2.6.20-200207 i686)
=================================================================
System uname: 2.6.20-200207 i686 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 31 Mar 2007 01:30:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31-r5
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.15-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.20-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -ffast-math -funroll-all-loops -funit-at-a-time -fpeel-loops -ftracer -funswitch-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -ffast-math -funroll-all-loops -funit-at-a-time -fpeel-loops -ftracer -funswitch-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LC_ALL="en_US"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/home/backup-pkgs"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/tmp/32bit"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/xeffects/trunk /usr/local/portage/xeffects/experimental"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acpi alsa amr apm artworkextra avi beagle berkdb bitmap-fonts branding bzip2 cairo cddb cdr cli cracklib crypt cups dbus directfb divx4linux djvu dri dts dvd dvdr dxr3 esd expat ffmpeg filepicker firefox flac flash fortran gdbm glitz gnome gpm graphviz gstreamer gtk guile hal iconv ieee1394 imagemagick imlib ipv6 isdnlog java jbig jpeg jpeg2k libg++ libnotify mad midi mmap mmx mozbranding mozdevelop mpeg ncurses network networking nls nptl nptlonly nsplugin ogg opengl oss pam pango pcre pdf perl png ppds pppd python qt3 qt4 quicktime readline real reflection ruby sdl seamonkey session spl sse ssl svg tcpd theora tiff tools truetype truetype-fonts type1-fonts unicode vcd vidix vorbis wavpack win32codecs wmf wmv x86 xine xinerama xml xmldoclet xorg xpm xprint xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
Regards....
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat Mar 31, 2007 2:05 pm    Post subject: Reply with quote

chrisfreet wrote:
CFLAGS="-march=athlon64 -O2 -ffast-math -funroll-all-loops -funit-at-a-time -fpeel-loops -ftracer -funswitch-loops"
You need to seriously tone done your CFLAGS, otherwise stuff will be broken sooner or later. Try making it just "-march=athlon64 -O2 -pipe".

That being said, just waiting for the developers to fix this is probably all that is needed, in the meantime just mask this version of ffmpeg or ignore it.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
a.forlorn
Guru
Guru


Joined: 12 Aug 2005
Posts: 412
Location: Ulm, Germany

PostPosted: Sat Mar 31, 2007 2:38 pm    Post subject: Reply with quote

mark_alec wrote:
chrisfreet wrote:
CFLAGS="-march=athlon64 -O2 -ffast-math -funroll-all-loops -funit-at-a-time -fpeel-loops -ftracer -funswitch-loops"
You need to seriously tone done your CFLAGS, otherwise stuff will be broken sooner or later. Try making it just "-march=athlon64 -O2 -pipe".

That being said, just waiting for the developers to fix this is probably all that is needed, in the meantime just mask this version of ffmpeg or ignore it.


Well -O2 or -O3 (which I prefer): same issue.
_________________
Gentoo update is sometimes harder than it should.
Back to top
View user's profile Send private message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 676

PostPosted: Sat Mar 31, 2007 2:50 pm    Post subject: I'm getting a similar error Reply with quote

Quote:
cabac.h:522: error: PIC register `%ebx' clobbered in `asm'
h264.c: At top level:
cabac.h:109: warning: 'put_cabac_static' defined but not used
cabac.h:155: warning: 'put_cabac_terminate' defined but not used
cabac.h:183: warning: 'put_cabac_u' defined but not used
cabac.h:218: warning: 'put_cabac_ueg' defined but not used
cabac.h:270: warning: 'refill2' defined but not used
cabac.h:808: warning: 'get_cabac_u' defined but not used
cabac.h:824: warning: 'get_cabac_ueg' defined but not used
make[1]: *** [h264.o] Error 1
make[1]: *** Waiting for unfinished jobs....
In file included from idcinvideo.c:54:
avcodec.h:2460: warning: `ImgReSampleContext' is deprecated (declared at avcodec.h:2447)
avcodec.h:2463: warning: `ImgReSampleContext' is deprecated (declared at avcodec.h:2447)
idcinvideo.c: In function `idcin_decode_frame':
idcinvideo.c:221: warning: `AVPaletteControl' is deprecated (declared at avcodec.h:2155)
make[1]: Leaving directory `/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg/libavcodec'
make: *** [lib] Error 2
Back to top
View user's profile Send private message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Sat Mar 31, 2007 3:00 pm    Post subject: Reply with quote

mark_alec wrote:
That being said, just waiting for the developers to fix this is probably all that is needed, in the meantime just mask this version of ffmpeg or ignore it.


emerge /usr/portage/media-video/ffmpeg/ffmpeg-0.4.9_p20070325.ebuild seems to have worked for me (before that I was using 20070129).
Back to top
View user's profile Send private message
chrisfreet
n00b
n00b


Joined: 12 Nov 2004
Posts: 54
Location: Chicago, IL

PostPosted: Sat Mar 31, 2007 3:44 pm    Post subject: Reply with quote

mark_alec wrote:
chrisfreet wrote:
CFLAGS="-march=athlon64 -O2 -ffast-math -funroll-all-loops -funit-at-a-time -fpeel-loops -ftracer -funswitch-loops"
You need to seriously tone done your CFLAGS, otherwise stuff will be broken sooner or later. Try making it just "-march=athlon64 -O2 -pipe".


I understand this; when I have issues, I have a secondary set of conservative CFLAGS. Have attempted to compile ffmpeg with both sets, to no avail.

Quote:
That being said, just waiting for the developers to fix this is probably all that is needed, in the meantime just mask this version of ffmpeg or ignore it.


Already done.
_________________
Regards....
Back to top
View user's profile Send private message
lo-jay
l33t
l33t


Joined: 27 Feb 2005
Posts: 862

PostPosted: Sat Mar 31, 2007 5:53 pm    Post subject: Reply with quote

same error as acheron2 here, my system looks like this

Code:
# emerge --info
Portage 2.1.2.3 (default-linux/amd64/2006.0, gcc-4.1.1, glibc-2.5-r0, 2.6.20-gentoo x86_64)
=================================================================
System uname: 2.6.20-gentoo x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4800+
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 31 Mar 2007 17:30:01 +0000
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -pipe -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -pipe -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LINGUAS="en de zh_CN"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acpi alsa amd64 berkdb bitmap-fonts cdr cjk cli cracklib crypt cups divx4linux dri dvd eds emboss encode foomaticcdb foomaticdb fortran gif gimpprint gnome gpm gstreamer gtk gtk2 iconv imlib immpt-bc ipv6 isdnlog jpeg kde lzw lzw-tiff mad midi mikmod mp3 mpeg ncurses nls nptl nptlonly ntlp opengl pam pcre perl png ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl ssl symlink tcpd tiff truetype-fonts type1-fonts unicode usb xinerama xorg xpm xv xvi zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de zh_CN" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
lo-jay

The mechanic "One of 'em Dodge Chargers - let him go by."
The driver "Not today!"

taken from "Two Lane Blacktop"
Back to top
View user's profile Send private message
DavidMCS
n00b
n00b


Joined: 08 Feb 2004
Posts: 39
Location: Halifax, NS Canada

PostPosted: Sat Mar 31, 2007 9:48 pm    Post subject: Reply with quote

I too was getting...
Code:
cabac.h:522: error: PIC register `%ebx' clobbered in `asm'

I switched the compiler from gcc 4.1.2 to 3.4.6 and it compiled fine for me.

--
David-
Back to top
View user's profile Send private message
bernd_b
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2003
Posts: 148

PostPosted: Sun Apr 01, 2007 3:39 pm    Post subject: Reply with quote

I did an emerge --sync today and it selected ffmpeg-0.4.9-p20070129, which compiled with many warnings, but without errors.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Apr 01, 2007 3:47 pm    Post subject: Reply with quote

bernd_b wrote:
I did an emerge --sync today and it selected ffmpeg-0.4.9-p20070129, which compiled with many warnings, but without errors.
That would be because...
Comment #19 From Alexis Ballier wrote:
p.masked, no need to have this version spread over every user :

# Alexis Ballier <aballier@gentoo.org> (1 Apr 2007)
# Broken with PIC on x86{,64}
=media-video/ffmpeg-0.4.9_p20070330

_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 676

PostPosted: Mon Apr 02, 2007 9:24 am    Post subject: Reply with quote

DavidMCS wrote:
I too was getting...
Code:
cabac.h:522: error: PIC register `%ebx' clobbered in `asm'

I switched the compiler from gcc 4.1.2 to 3.4.6 and it compiled fine for me.

--
David-

That is odd; I am using this to compile it:
Code:
# gcc --version
gcc (GCC) 3.4.6 (Gentoo 3.4.6-r2, ssp-3.4.6-1.0, pie-8.7.10)

I will select a different compiler and check.

Code:
# gcc --version
gcc (GCC) 4.1.1 (Gentoo 4.1.1-r3)


That made it worse.

Quote:
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h: In function 'decode_cabac_mb_intra4x4_pred_mode':
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h: In function 'decode_cabac_residual':
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h: In function 'decode_cabac_mb_mvd':
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
cabac.h: In function 'decode_cabac_mb_ref':
cabac.h:522: error: PIC register '%ebx' clobbered in 'asm'
make[1]: *** [h264.o] Error 1
make[1]: *** Waiting for unfinished jobs....
In file included from imc.c:40:
avcodec.h:2460: warning: 'ImgReSampleContext' is deprecated
avcodec.h:2463: warning: 'ImgReSampleContext' is deprecated
make[1]: Leaving directory `/var/tmp/portage/media-video/ffmpeg-0.4.9_p20070330/work/ffmpeg/libavcodec'
make: *** [lib] Error 2

!!! ERROR: media-video/ffmpeg-0.4.9_p20070330 failed.
Back to top
View user's profile Send private message
cd_rom
n00b
n00b


Joined: 03 May 2006
Posts: 23

PostPosted: Mon Apr 02, 2007 9:37 am    Post subject: Reply with quote

I had the same problem too. But i didn't want to emerge different version of gcc so i think the simplest solution is to mask that ffmpeg-0.4.9_p20070330 and use the older version. It works fine for me, no warning, nothing!

Hope it helps!
Back to top
View user's profile Send private message
acheron2
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2007
Posts: 106

PostPosted: Sat Apr 07, 2007 7:05 pm    Post subject: Re: [Resolved] Cannot update ffmpeg to 0.4.9_p20070330 Reply with quote

Since it has been fixed, I've added "[Resolved]"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum