Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA doesn't work
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Sep 16, 2007 8:01 am    Post subject: Reply with quote

Daytona wrote:
yeah... did that. Several times. Still nothing.
WARNING: /lib/modules/2.6.21-gentoo-r4/alsa-driver/ppc/snd-powermac.ko needs unknown symbol of_get_property

No, you did not read the article. You're using "alsa-driver", rather than the in-kernel modules.
Back to top
View user's profile Send private message
Daytona
n00b
n00b


Joined: 01 Aug 2005
Posts: 46
Location: EN51vt

PostPosted: Sun Sep 16, 2007 6:29 pm    Post subject: Reply with quote

This IS the in-kernel modules. Originally, I tried alsa-driver, as I prefer that method. It fails to compile at all, so I switched to in-kernel modules instead, where I began getting these errors. Since neither are working, that is why I am compiling alsa-driver again, and reporting the output. Since the in-kernel modules originate from the official alsa-driver sources (in-kernel usually a little older than what is currently available), perhaps snd-powermac got broke at some point and noone has noticed yet. (appears most people running PPC are on newer hardware that uses aoa)


Code:
me@g3 ~ $ emerge -s alsa-driver
Searching...
[ Results for search key : alsa-driver ]
[ Applications found : 1 ]

*  media-sound/alsa-driver
      Latest version available: 1.0.14_rc2-r1
      Latest version installed: [ Not Installed ]
      Size of files: 2,466 kB
      Homepage:      http://www.alsa-project.org/
      Description:   Advanced Linux Sound Architecture kernel modules
      License:       GPL-2 LGPL-2.1

me@g3 ~ $ emerge -s alsa-headers
Searching...
[ Results for search key : alsa-headers ]
[ Applications found : 1 ]

*  media-sound/alsa-headers
      Latest version available: 1.0.14_rc2
      Latest version installed: [ Not Installed ]
      Size of files: 2,466 kB
      Homepage:      http://www.alsa-project.org/
      Description:   Header files for Advanced Linux Sound Architecture kernel modules
      License:       GPL-2 LGPL-2.1


me@g3 ~ $


You might notice this from my first post in the thread:
Quote:
I've tried external drivers (media-sound/alsa-driver) and right now am using in-kernel drivers as modules.


And as much as I hate posting configs....
Code:
me@g3 /usr/src/linux $ grep SND .config
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_SEQUENCER=m
# CONFIG_SND_SEQ_DUMMY is not set
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
# CONFIG_SND_VERBOSE_PRINTK is not set
# CONFIG_SND_DEBUG is not set
# CONFIG_SND_DUMMY is not set
# CONFIG_SND_VIRMIDI is not set
# CONFIG_SND_MTPAV is not set
# CONFIG_SND_SERIAL_U16550 is not set
# CONFIG_SND_MPU401 is not set
# CONFIG_SND_AD1889 is not set
# CONFIG_SND_ALS300 is not set
# CONFIG_SND_ALS4000 is not set
# CONFIG_SND_ALI5451 is not set
# CONFIG_SND_ATIIXP is not set
# CONFIG_SND_ATIIXP_MODEM is not set
# CONFIG_SND_AU8810 is not set
# CONFIG_SND_AU8820 is not set
# CONFIG_SND_AU8830 is not set
# CONFIG_SND_AZT3328 is not set
# CONFIG_SND_BT87X is not set
# CONFIG_SND_CA0106 is not set
# CONFIG_SND_CMIPCI is not set
# CONFIG_SND_CS4281 is not set
# CONFIG_SND_CS46XX is not set
# CONFIG_SND_DARLA20 is not set
# CONFIG_SND_GINA20 is not set
# CONFIG_SND_LAYLA20 is not set
# CONFIG_SND_DARLA24 is not set
# CONFIG_SND_GINA24 is not set
# CONFIG_SND_LAYLA24 is not set
# CONFIG_SND_MONA is not set
# CONFIG_SND_MIA is not set
# CONFIG_SND_ECHO3G is not set
# CONFIG_SND_INDIGO is not set
# CONFIG_SND_INDIGOIO is not set
# CONFIG_SND_INDIGODJ is not set
# CONFIG_SND_EMU10K1 is not set
# CONFIG_SND_EMU10K1X is not set
# CONFIG_SND_ENS1370 is not set
# CONFIG_SND_ENS1371 is not set
# CONFIG_SND_ES1938 is not set
# CONFIG_SND_ES1968 is not set
# CONFIG_SND_FM801 is not set
# CONFIG_SND_HDA_INTEL is not set
# CONFIG_SND_HDSP is not set
# CONFIG_SND_HDSPM is not set
# CONFIG_SND_ICE1712 is not set
# CONFIG_SND_ICE1724 is not set
# CONFIG_SND_INTEL8X0 is not set
# CONFIG_SND_INTEL8X0M is not set
# CONFIG_SND_KORG1212 is not set
# CONFIG_SND_MAESTRO3 is not set
# CONFIG_SND_MIXART is not set
# CONFIG_SND_NM256 is not set
# CONFIG_SND_PCXHR is not set
# CONFIG_SND_RIPTIDE is not set
# CONFIG_SND_RME32 is not set
# CONFIG_SND_RME96 is not set
# CONFIG_SND_RME9652 is not set
# CONFIG_SND_SONICVIBES is not set
# CONFIG_SND_TRIDENT is not set
# CONFIG_SND_VIA82XX is not set
# CONFIG_SND_VIA82XX_MODEM is not set
# CONFIG_SND_VX222 is not set
# CONFIG_SND_YMFPCI is not set
CONFIG_SND_POWERMAC=m
CONFIG_SND_POWERMAC_AUTO_DRC=y
# CONFIG_SND_AOA is not set
# CONFIG_SND_AOA_SOUNDBUS is not set
# CONFIG_SND_USB_AUDIO is not set
# CONFIG_SND_USB_USX2Y is not set
# CONFIG_SND_VXPOCKET is not set
# CONFIG_SND_PDAUDIOCF is not set
# CONFIG_SND_SOC is not set
me@g3 /usr/src/linux $
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Sep 16, 2007 6:40 pm    Post subject: Reply with quote

Daytona wrote:
where I began getting these errors.

Well, you will get those errors, if you think you're using the in-kernel modules but haven't removed the alsa-driver modules, because guess what, the alsa-driver modules are used in preference. That's why the article says... oh just read the article properly. Also what it says about posting useful diagnostic info.
Back to top
View user's profile Send private message
Daytona
n00b
n00b


Joined: 01 Aug 2005
Posts: 46
Location: EN51vt

PostPosted: Sun Sep 16, 2007 11:05 pm    Post subject: Reply with quote

If the alsa-driver package never compiled, there can't be any leftover modules from it still there, can there?

edit:for clarification-

I did go through and clean out /lib, and make clean anyways.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Sep 17, 2007 5:22 am    Post subject: Reply with quote

Daytona wrote:
there can't be any leftover modules

Given that we're staring at one, then yes, there are.
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Mon Sep 17, 2007 9:48 pm    Post subject: Reply with quote

my powerbook alluminium 1.6Ghz is not able to use the sound card recompiling the kernel 2.6.20
Quote:
#
# ALSA PowerMac devices
#
CONFIG_SND_POWERMAC=m
# CONFIG_SND_POWERMAC_AUTO_DRC is not set

#
# Apple Onboard Audio driver
#
CONFIG_SND_AOA=y
CONFIG_SND_AOA_FABRIC_LAYOUT=y
CONFIG_SND_AOA_ONYX=y
CONFIG_SND_AOA_TAS=y
CONFIG_SND_AOA_TOONIE=m
CONFIG_SND_AOA_SOUNDBUS=y
CONFIG_SND_AOA_SOUNDBUS_I2S=y
#
# Open Sound System
#
# CONFIG_SOUND_PRIME is not set


the ubuntu kernel is able, is there a solution ?
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue Sep 18, 2007 4:57 am    Post subject: Reply with quote

ddc wrote:
the ubuntu kernel is able

So use the Ubuntu kernel. Exactly which version works?
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue Sep 18, 2007 11:59 am    Post subject: Reply with quote

ubuntu is working on powerbook alluminium 1.6Ghz with the linux kernel 2.6.20-15
(it should be the last one ubuntu ppc burnup iso)

but i can't use this kernel cause i need to recompile it ...
so i need to recompile the gentoo-sources-2.6.x
where x=16,17,19,20

none of them is working using snd_aoa & snd_powermac + the i2c support
on the 2.6.20 i can see the sound board enabled without errors in dmesg and in /proc/asound/*
i can see the /dev/dsp, but alsamixer is reporting no ctrl

i will post the error message as soon as i will access the powerbook ...
BBL


p.s.
in the ubuntu install i see /usr/src/linux-headers-2.6.20-15 ... in where there a lot of pathing
(the make menuconfig reports a lot of diff from the gentoo-sources-2.6.20-15)
so may be ubuntu has been deep-patched ?
unfortunately ubuntu /usr/src is not populated with the linux sources, only headers ...
so i can't recompile or investigate ...
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Tue Sep 18, 2007 3:12 pm    Post subject: Reply with quote

Quote:
CONFIG_SND_POWERMAC=m


disable that and rebuild the kernel. Also, grep for powermac in /etc and you´ll find several aliasas to snd-card-0 that have to be deleted to get the driver to load/work properly.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue Sep 18, 2007 5:46 pm    Post subject: Reply with quote

2.6.21-nocturnal-monster-puppy-apple-powerbook-G4-alluminium
1.66Ghz machine, still doesn't sound



Quote:
(*) dmesg
Advanced Linux Sound Architecture Driver Version 1.0.14rc3 (Wed Mar 14 07:25:50 2007 UTC).
snd-aoa-fabric-layout: found bus with layout 82
snd-aoa-fabric-layout: Using PMF GPIOs
snd-aoa-codec-onyx: found pcm3052
snd-aoa-fabric-layout: can use this codec
snd-aoa-codec-onyx: attached to onyx codec via i2c
snd-aoa-codec-onyx: created and attached onyx instance
snd-aoa: fabric didn't like codec toonie
ALSA device list:
#0: SoundByLayout

(*) config
CONFIG_SND=y
CONFIG_SND_TIMER=y
CONFIG_SND_PCM=y
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_DEBUG=y
CONFIG_SND_DEBUG_DETECT=y
CONFIG_SND_PCM_XRUN_DEBUG=y

CONFIG_SND_AOA=y
CONFIG_SND_AOA_FABRIC_LAYOUT=y
CONFIG_SND_AOA_ONYX=y
CONFIG_SND_AOA_TAS=y
CONFIG_SND_AOA_TOONIE=y
CONFIG_SND_AOA_SOUNDBUS=y
CONFIG_SND_AOA_SOUNDBUS_I2S=y

(*) proc/asound/cards
0 [SoundByLayout ]: AppleOnbdAudio - SoundByLayout
SoundByLayout
(*) alsamixer
alsamixer: function snd_ctl_open failed for default: No such device
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
version 0.65; written and copyright by Michael Hipp and others
free software (LGPL/GPL) without any warranty but with best wishes
ALSA lib confmisc.c:769:(parse_card) cannot find card ''
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
audio_open(): cannot open device default
audio: No such file or directory

Directory: mp3/
Playing MPEG stream 1 of 1: robbie-williams--kids.mp3 ...
[id3.c:182] warning: ID3v2: Won't parse the ID3v2 tag with major version 2 and flags 0x0u - some extra code may be needed
MPEG 1.0 layer III, 320 kbits/s, 44100 Hz stereo
[audio.c:264] error: No supported rate found!



also, the source 2.6.22 ubuntu pathed, is not working with this settings


Last edited by ddc on Tue Sep 18, 2007 5:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue Sep 18, 2007 5:48 pm    Post subject: Reply with quote

Code:
(*) dmesg
ALSA device list:
#0: SoundByLayout

(*) proc/asound/cards
0 [SoundByLayout ]: AppleOnbdAudio - SoundByLayout
SoundByLayout



also

Code:
(*) test
aplay -l
device_list:204: no soundcards found...


what could be worng with it ?


Last edited by ddc on Tue Sep 18, 2007 9:02 pm; edited 3 times in total
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue Sep 18, 2007 7:15 pm    Post subject: Reply with quote

gringo wrote:
Quote:
CONFIG_SND_POWERMAC=m


disable that and rebuild the kernel. Also, grep for powermac in /etc and you´ll find several aliasas to snd-card-0 that have to be deleted to get the driver to load/work properly.

cheers


i did, i recompile with alsa & drivers static inside the kernel
also i removed aliases from /etc/modules.conf /etc/modprobe.conf
(i'm recompiling with alsa & drivers as modules)

it doesn't work, gosh .. have you got a powerbook G4 1.6Ghz ?
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue Sep 18, 2007 8:34 pm    Post subject: Reply with quote

ddc wrote:
but i can't use this kernel cause i need to recompile it

What? Grab Ubuntu kernel 2.6.20 and unpack it to /usr/src/linux/, or edit my Ubuntu ebuild to use it, and compile it. Simple :wink:
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue Sep 18, 2007 9:01 pm    Post subject: Reply with quote

PaulBredbury wrote:
ddc wrote:
but i can't use this kernel cause i need to recompile it

What? Grab Ubuntu kernel 2.6.20 and unpack it to /usr/src/linux/, or edit my Ubuntu ebuild to use it, and compile it. Simple :wink:


i donwloaded and recompiled the .22 ubuntu pathed kernel
http://packages.ubuntu.com/gutsy/devel/linux-source-2.6.22

it is not working

dmesg and proc are reporting the audio card
aplay and alsamixer are reporting error


Last edited by ddc on Tue Sep 18, 2007 10:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue Sep 18, 2007 9:26 pm    Post subject: Reply with quote

So use the Ubuntu kernel-2.6.20 - how obvious do I need to make this?
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Sep 19, 2007 7:40 am    Post subject: Reply with quote

Quote:
it doesn't work, gosh .. have you got a powerbook G4 1.6Ghz ?


mine is a 1.33 G4 alubook and the stock kernel covers all i need, no need to play with patched sources to get sound to work imo.

Maybe you have broken userspace apps, what version of alsa-lib do you have installed f.ex. ? Keep in mind that kernel & userpace have to match in case you don´t use the in-kernel driver. If you are using the latest kernels, ~arch version of alsa-* packages will be needed.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed Sep 19, 2007 9:09 am    Post subject: Reply with quote

it is a new fresh gentoo install: 2007.0
all emerged from the last portage available

i think 1.3Ghz powerbook are different from 1.6Ghz .... it's an uncommon problem this
how to investigate ?
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Sep 19, 2007 9:48 am    Post subject: Reply with quote

Quote:
i think 1.3Ghz powerbook are different from 1.6Ghz


not much apart from cpu speed, sound chip is the same for sure afaik.

Quote:
how to investigate ?


triple-check you have the right software, read again my previous post.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed Sep 19, 2007 10:37 am    Post subject: Reply with quote

gringo wrote:

Maybe you have broken userspace apps, what version of alsa-lib do you have installed f.ex. ?


umm i'm using the kernel-in alsa driver, the one in the gentoo-sources-2.6.21
(one of the kernels i compiled: also .16, .19, all using the in-kernel driver)


Quote:

Keep in mind that kernel & userpace have to match in case you don´t use the in-kernel driver. If you are using the latest kernels, ~arch version of alsa-* packages will be needed.


i cdbooted the machine
i mac-fdisk part the hd
i set the networkframe to the router, and i downloaded: stage3-g4-2007.0 and the last portage-2007.0
i untared then to a fresh volume
i chroot to it and i setted the /etc/conf.d &C
i emerge --sync it
i emerge --update world (as emerge -p --update world shows there is a lot to be update)
i emerge the gentoo-sources-2.6.21
i compiled and instaled it ( .config-ured it as described previously)
i yabooted the OF
i reboot: all is ok
so i emerged alsa-utils and alsa-tools
and the soundcard is not working (as reported)

what have i to do ? or better, do find something wrong in this (handbook) procedure ?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Sep 19, 2007 12:51 pm    Post subject: Reply with quote

ddc:
Are you sure your user has permission to use the card? Does it work as root? Your dmesg looks like it's set up properly. If it works as root, make sure to add your user to the "audio" group.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed Sep 19, 2007 1:11 pm    Post subject: Reply with quote

JoseJX wrote:
ddc:
Are you sure your user has permission to use the card? Does it work as root? Your dmesg looks like it's set up properly. If it works as root, make sure to add your user to the "audio" group.


i'm the root: i only work as root on this machine
and it doesn't work at all, as you can see in aplay -l: no sound card
dmesg is reporting sound card found, proc/asound/cards is reporting it
alsamixer is reporting errors (function snd_ctrl_open failed for default: no such device)

also, the portage 2007.0 has a lot of errors in emerge --update world
errors from sys-apps/net-tools-1.60-r14, sys-apps/util-linux-2.12r-r7, etc etc ...
(errors while loading shared libraries lebexpat.so.9 cannot open shared object file, so such file or directory)

i only untarballed the last portage
adding
LANGUAS="en"
VIDEO_CARDS=radeon
in the /etc/make.conf (there is no USE flasgs)
then run emerge --update world

everything is from the original fresh install
i think there is something wrong with this portage, and it is a new fresh one

is it a : ( bug ?

i had no problems with the 2005.0, 2 years ago ..
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Sep 19, 2007 2:37 pm    Post subject: Reply with quote

Okay, first things first, fix your library issue. You're not following the directions portage tells you! The new version of expat breaks binary compatibility with older versions (including the ones in the stage tarball). You have to run revdep-rebuild (part of gentoolkit) to rebuild any application that was built against expat. This is a necessary operation for fixing binary incompatibility between library revisions and has been this way for years. :p

As for the sound issue, what are the contents of ~/asound after running this command?
Code:

alsactl store 0 -f ~/asound

_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed Sep 19, 2007 3:36 pm    Post subject: Reply with quote

will this portage issue be corrected in v. 2007.1 ?
i don't exactly know what to do, now
(if to switch to this 2007.0 or if to restore my 2005.0 from backup waiting for 2007.1)
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Sep 19, 2007 5:24 pm    Post subject: Reply with quote

It's absolutely *not* a portage issue.

You've upgraded expat, it's binary incompatible with previous versions. Portage tells you this from the ebuild:
Code:

    ewarn "Please note that the soname of the library changed!
    ewarn "If you are upgrading from a previous version you need"
    ewarn "to fix dynamic linking inconsistencies by executing:"
    ewarn "revdep-rebuild -X --library libexpat.so.0"


Just perform the library rebuild and the problem will be fixed.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2527
Location: Canada

PostPosted: Wed Sep 19, 2007 5:42 pm    Post subject: Reply with quote

JoseJX wrote:
It's absolutely *not* a portage issue.

You've upgraded expat, it's binary incompatible with previous versions. Portage tells you this from the ebuild:
Code:

    ewarn "Please note that the soname of the library changed!
    ewarn "If you are upgrading from a previous version you need"
    ewarn "to fix dynamic linking inconsistencies by executing:"
    ewarn "revdep-rebuild -X --library libexpat.so.0"


Just perform the library rebuild and the problem will be fixed.


There is one issue with libexpat.so.0 (or similar porblem) that could have been addressed specifically by portage - stop subsequent emerges after libexpat is upgraded with sharp warning to run revdep-rebuild right now.
Typical scenario that i hit several times (already fully familiar with expat issue) is to run
Code:

emerge -uD world

expat is updated somewhere in the beginning, but then down the list pango or gtk+ emerge fail, because they
rely on test programs that are still linked against libexpat.so.0. In reality, you need to recompile fontconfig and friends
before you can proceed, but at least fontconfig is not in update list.

Portage level solution will be either to bump fontconfig and friends version so that their upgrade is forced after expat is recompiled (and that they are upgraded right after expat), or at least stop subsequent emerge after libexpat with big letter warning. Or at least something similar to what happen when new portage appears - big warning suggesting to update protage before proceeding with any other emerges
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum