Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
plantronics dsp-500, lost in setup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
juls
n00b
n00b


Joined: 14 Feb 2003
Posts: 5

PostPosted: Fri Feb 14, 2003 4:34 am    Post subject: plantronics dsp-500, lost in setup Reply with quote

i have a plantronics dsp-500 headset and mic, im not sure how to go about setting up this audio hardware, its a usb device and i have no idea how to set it up, i would appreciate any help i could get
thanks
Back to top
View user's profile Send private message
gunman
n00b
n00b


Joined: 16 Jun 2002
Posts: 20
Location: Germany

PostPosted: Fri Jun 20, 2003 9:35 pm    Post subject: Re: plantronics dsp-500, lost in setup Reply with quote

juls wrote:
i have a plantronics dsp-500 headset and mic, im not sure how to go about setting up this audio hardware, its a usb device and i have no idea how to set it up, i would appreciate any help i could get
thanks


same problem here. I cant setup my Plantronics dsp-500 headset...
Back to top
View user's profile Send private message
twk-b
n00b
n00b


Joined: 26 Jun 2003
Posts: 2
Location: calgary

PostPosted: Thu Jun 26, 2003 7:39 am    Post subject: Reply with quote

i have had it working in redhat and as a usb device on a previous install of gentoo, but ive switched to ASLA and cant get it working.
_________________
twk-b
Back to top
View user's profile Send private message
taz
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2003
Posts: 87

PostPosted: Sat Jun 05, 2004 9:28 am    Post subject: Reply with quote

Has anyone gotten their DSP 500 working? I've tried configuring my /etc/modules.d/alsa file to get it to work, but no luck. I have USB and USB audio included in the kernel, not as modules, and two other sound cards which use emu10k1 and intel8x0 drivers, both of which work.

Thanks.
Back to top
View user's profile Send private message
crocodille
n00b
n00b


Joined: 18 Dec 2003
Posts: 52
Location: Germany, Mettmann

PostPosted: Sat Jul 17, 2004 1:38 pm    Post subject: Reply with quote

YES I GOT MINE WORKING!!!!

Will post what I actually did in a little bit. (I have to figure out how I did it first ;-) )

Sound is pretty poor right now, but it's working!

Kernel is gentoo-dev-sources 2.6.7-r11 with UDEV enabled (devices are located in /dev/sound/*)

Got it working with XMMS. Had to take the OSS plugin because I could actually tell it to use /dev/sound/dsp. I was not able to get actually to work with alsa, eventhough I have no OSS enabled in my Kernel (only the emulation part, that's probably why)
Back to top
View user's profile Send private message
yank
n00b
n00b


Joined: 30 Oct 2004
Posts: 16

PostPosted: Fri Feb 25, 2005 5:59 pm    Post subject: Reply with quote

has anybody got this working with ALSA yet? I too have a dsp-500.
Back to top
View user's profile Send private message
crocodille
n00b
n00b


Joined: 18 Dec 2003
Posts: 52
Location: Germany, Mettmann

PostPosted: Fri Feb 25, 2005 7:47 pm    Post subject: Reply with quote

I have mine working with alsa exclusively.

Here is what I did
- removed everything with OSS from the kernel
- add usb sound support
- modify /etc/modules.d/alsa

here is mine
Code:

alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-emu10k1  // you have to put your soundcard here
alias snd-card-1 snd-usb-audio
options snd cards_limit=2


reboot or restart the apropriate deamons. Try alsamxier -c1 to check if it is working.
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Fri Apr 01, 2005 7:33 am    Post subject: Reply with quote

crocodille wrote:
I have mine working with alsa exclusively.

Here is what I did
- removed everything with OSS from the kernel
- add usb sound support
- modify /etc/modules.d/alsa

here is mine
Code:

alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-emu10k1  // you have to put your soundcard here
alias snd-card-1 snd-usb-audio
options snd cards_limit=2


reboot or restart the apropriate deamons. Try alsamxier -c1 to check if it is working.


Anyone else get it working like this? I'm not dropping 50 bucks on a damn headset before i'm not reasonably sure I can get the damn thing running...
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Wed Apr 19, 2006 10:55 pm    Post subject: Reply with quote

i cant get this thing to work, i have all the usb-audio stuff loaded but for some reason the thing dont show up in lsusb. Probably a usb problem.
Back to top
View user's profile Send private message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Thu Apr 20, 2006 7:44 pm    Post subject: [solved] !!! Reply with quote

OK i finally got this thing working and it sounds better than it does on windows!

Here is what i did.

/etc/make.conf
Code:
ALSA_CARDS="atiixp usb-audio"


Kernel Config
Code:
Drivers -> sound -> Sound Card Support (*)
Drivers -> sound -> Alsa ( )
Drivers -> sound -> oss ( )

Drivers -> usb -> Host-side usb (*)
Drivers -> usb -> ehci hcd usb 2.0 (*)
Drivers -> usb -> ohci hcd (*)
Drivers -> usb -> uhci hcd (*)
Drivers -> usb -> usb human interface device (*)

*recompile

Alsa Drivers
Code:
emerge alsa-drivers


Alsa Setup
Code:
cat /etc/modules.d/alsa
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.

# OPTIONS
options snd major=116 cards_limit=2
options snd-atiixp index=0
options snd-usb-audio index=1

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-atiixp
alias snd-card-1 snd-usb-audio
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

##  OSS/Free portion - card #2
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss


Configure using
Code:
alsamixer -c 0
alsamixer -c 1


One last thing, make sure you switch the alsa source in your application to use audio device hw:1,0 or what ever your headset is.

Some one please make this as solved.
Back to top
View user's profile Send private message
Ariem
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 296
Location: reykjavik

PostPosted: Mon Mar 12, 2007 1:00 pm    Post subject: Reply with quote

Hi

i've been trying to follow your instructions, but i get
Code:
$ alsamixer -c 1
wrong -c argument '1'


It works fine with card 0 (my actual card) but not for the usb headset..

any idea?

thanks
Back to top
View user's profile Send private message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Tue Mar 13, 2007 3:01 am    Post subject: Reply with quote

Yah more than likely your usb-sound driver didnt get loaded. Plug the usb headset in and then modprobe the drivers ("modprobe snd-usb-audio" as root). Also make sure you recompiled ALSA after you updated your make.conf file with usb-audio.
Back to top
View user's profile Send private message
Ariem
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 296
Location: reykjavik

PostPosted: Fri Mar 16, 2007 9:10 am    Post subject: Reply with quote

KWhat wrote:
Yah more than likely your usb-sound driver didnt get loaded. Plug the usb headset in and then modprobe the drivers ("modprobe snd-usb-audio" as root). Also make sure you recompiled ALSA after you updated your make.conf file with usb-audio.

Yes, you are right.
The usb-sound driver does not get loaded.
I get
Code:
# modprobe snd-usb-audio
FATAL: Module snd_usb_audio not found.

I have the kernel configuration as you suggest, but with one difference: I'm using alsa from the kernel and not the kernel-drivers.
Does that make a difference?

When you say to recompile ALSA after updating make.conf, does that mean (for me) to recompile the kernel, or the alsa-related libs that i have
Code:
# equery l alsa
[ Searching for package 'alsa' in all categories among: ]
 * installed packages
[I--] [  ] media-libs/alsa-lib-1.0.14_rc1 (0)
[I--] [  ] media-sound/alsa-headers-1.0.14_rc1 (0)
[I--] [  ] media-sound/alsa-utils-1.0.14_rc1 (0.9)


Thanks for the help.
Back to top
View user's profile Send private message
Bill Thompson
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2005
Posts: 139

PostPosted: Fri Mar 16, 2007 8:39 pm    Post subject: Reply with quote

If you look at the message: "Can't set up properly a USB headset" on Jan. 11,2006, you will find a complete rundown of the steps I took to get my Plantronics 400 working. The udev rules need changing to reflect the use of ==. I won't guarantee success but mine headset works perfectly.
Back to top
View user's profile Send private message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Sat Mar 17, 2007 2:57 am    Post subject: Reply with quote

Looks like the specific issue you are having is you dont have usb-audio in your alsa_cards variable in the make.conf file. Please review http://gentoo-wiki.com/HOWTO_ALSA_Complete_%28includes_dmix%29 for how to correctly setup alsa in the make.conf file. Then do a emerge -av --update --newuse world and make sure alsa-driver gets recompiled. If you are using the kernel dirvers just add the usb-audio driver in as a module and recompile the kernel. modprobe it again and you should be good.
Back to top
View user's profile Send private message
Ariem
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 296
Location: reykjavik

PostPosted: Wed Mar 21, 2007 3:38 pm    Post subject: Reply with quote

i have managed to get the module loaded, and able to access the alsamixer for card 1.
However, I cannot make use of the headset.
It always plays through the speakers, or through a jack headset if that is connected.
The USB is never used.
Code:
usbcore: registered new interface driver usb-storage
input: USB HID v1.10 Keyboard [DELL DELL USB Keyboard] on usb-0000:00:1d.7-8.1
input: USB HID v1.10 Mouse [Logitech Optical USB Mouse] on usb-0000:00:1d.7-8.2
input: USB HID v1.00 Device [HID 047f:c001] on usb-0000:00:1d.7-8.4


Something i could me missing?
Back to top
View user's profile Send private message
Ariem
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 296
Location: reykjavik

PostPosted: Fri Mar 23, 2007 1:13 pm    Post subject: Reply with quote

okay, so the headset is working!

i know that because in Skype i can choose the Audio In and Audio Out, and it works!
So my problem now is how to make the normal audio Out be directed to the headset?
Besides Skype, all audio is played by the speakers.

And, if I direct the sound to the headset, will I then loose all audio if I don't have the headset plugged-in?
Or it falls-back to the default speakers?

Thanks
Back to top
View user's profile Send private message
double_c
n00b
n00b


Joined: 12 Mar 2006
Posts: 9

PostPosted: Thu Apr 26, 2007 12:23 pm    Post subject: Reply with quote

Hallo.
Thank you for this HowTo.
The headset works, but only with software, where i can choose the Headset.

Aint there a possibility to switch the devices?

Greetings
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum