Joined: 12 May 2004
|Posted: Sat May 26, 2007 8:26 pm Post subject: [ GLSA 200705-19 ] PHP: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: PHP: Multiple vulnerabilities (GLSA 200705-19)
Date: May 26, 2007
Updated: March 29, 2008
PHP contains several vulnerabilities including buffer and integer overflows which could under certain conditions lead to the remote execution of arbitrary code.
PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.
Vulnerable: < 5.2.2
Unaffected: >= 4.4.7 < 4.4.8
Unaffected: >= 4.4.8_pre20070816 < 4.4.9
Unaffected: >= 5.2.2
Architectures: All supported architectures
Several vulnerabilities were found in PHP, most of them during the Month Of PHP Bugs (MOPB) by Stefan Esser. The most severe of these vulnerabilities are integer overflows in wbmp.c from the GD library (CVE-2007-1001) and in the substr_compare() PHP 5 function (CVE-2007-1375). Ilia Alshanetsky also reported a buffer overflow in the make_http_soap_request() and in the user_filter_factory_create() functions (CVE-2007-2510, CVE-2007-2511), and Stanislav Malyshev discovered another buffer overflow in the bundled XMLRPC library (CVE-2007-1864). Additionally, the session_regenerate_id() and the array_user_key_compare() functions contain a double-free vulnerability (CVE-2007-1484, CVE-2007-1521). Finally, there exist implementation errors in the Zend engine, in the mb_parse_str(), the unserialize() and the mail() functions and other elements.
Remote attackers might be able to exploit these issues in PHP applications making use of the affected functions, potentially resulting in the execution of arbitrary code, Denial of Service, execution of scripted contents in the context of the affected site, security bypass or information leak.
There is no known workaround at this time.
All PHP 5 users should upgrade to the latest version:
All PHP 4 users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.2.2"
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.7"
Last edited by GLSA on Sat Mar 29, 2008 4:18 am; edited 1 time in total