Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge wants java jdk 5.0-4.0, not 5.0-5.0 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
techqbert
n00b
n00b


Joined: 23 May 2007
Posts: 14

PostPosted: Sun Jun 10, 2007 4:40 am    Post subject: emerge wants java jdk 5.0-4.0, not 5.0-5.0 [SOLVED] Reply with quote

I want to install Java JDK.

Code:
emerge --resume
Calculating dependencies... done!
[ebuild  N F  ] dev-java/ibm-jdk-bin-1.5.0.4-r1  USE="X alsa -doc -examples -javacomm -nsplugin" 69,151 kB
[ebuild  N    ] virtual/jdk-1.5.0  0 kB

Total: 2 packages (2 new), Size of downloads: 69,151 kB
Fetch Restriction: 1 package (1 unsatisfied)

*** Resuming merge...
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 2) dev-java/ibm-jdk-bin-1.5.0.4-r1 to /

!!! dev-java/ibm-jdk-bin-1.5.0.4-r1 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually.  See the comments in the ebuild for more information.

 * Due to license restrictions, we cannot redistribute or fetch the distfiles
 * Please visit: http://www.ibm.com/developerworks/java/jdk/linux/download.html
 * Under J2SE 5.0, download SR4 for your arch:
 * (note that we switched to tgz format because it's now versioned)
 * ibm-java2-sdk-5.0-4.0-linux-ppc.tgz
 * You can use direct link to your arch download page:
 * https://www14.software.ibm.com/webapp/iwm/web/preLogin.do?source=sdk5&S_PKG=ipseries325sr4&S_TACT=105AGX05&S_CMP=JDK
 * Place the file(s) in: /usr/portage/distfiles
 * Then restart emerge: 'emerge --resume'
 * Note: if SR4 is not available at http://www.ibm.com/developerworks/java/jdk/linux/download.html
 * it may have been moved to http://www.ibm.com/developerworks/java/jdk/linux/older_download.html. Lately that page
 * isn't updated, but the files should still available through the
 * direct link to arch download page. If it doesn't work, file a bug.


I downloaded ibm-java2-sdk-5.0-5.0-linux-ppc.tgz and it's positioned
inside /usr/portage/distfiles... I guess i need 5.0-4.0 but IBM's dodgy
site doesn't have it. talk to me here or at #gentoo-ppc on irc.freenode.net
my nick is techjimbo on IRC, btw.


Last edited by techqbert on Sun Jun 10, 2007 3:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Sun Jun 10, 2007 5:42 am    Post subject: Reply with quote

Well, you must've unmasked the ibm-jdk, so ibm-jdk-bin-1.5.0.5 should be unmasked as well. The question begged is: why is portage trying to install 1.5.0.4-r1 instead? Given that 1.5.0.5 just got added, I imagine a portage sync should fix things.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
corsair
Retired Dev
Retired Dev


Joined: 06 Oct 2003
Posts: 451
Location: Aachen, Germany

PostPosted: Sun Jun 10, 2007 7:36 am    Post subject: Reply with quote

if I follow exactly the link given by the error message (this), then I'm getting to ibm-java2-sdk-5.0-4.0-linux-ppc.tgz. So please try again..
Back to top
View user's profile Send private message
techqbert
n00b
n00b


Joined: 23 May 2007
Posts: 14

PostPosted: Sun Jun 10, 2007 3:05 pm    Post subject: Reply with quote

corsair wrote:
if I follow exactly the link given by the error message (this), then I'm getting to ibm-java2-sdk-5.0-4.0-linux-ppc.tgz. So please try again..


:roll: Thanks.

For some reason, I thought I tried all three links. Hrm, it was late. Thanks guys.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum