Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Email System For The Home Network - Version 2.1
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 25, 26, 27  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
davidl
n00b
n00b


Joined: 31 Mar 2003
Posts: 16
Location: Newcastle, England

PostPosted: Thu Jun 03, 2004 8:37 pm    Post subject: Reply with quote

Well it's official. Ths guide is absolutely fantastic!

I set this up with very little effort at all. The only problem I had was getting saslauthd to start because I had to comment the last four lines of /etc/conf.d/saslauthd, but it is all there and working now. For looking at the various options for procmail, I looked at this guide:

http://www.spambouncer.org/proctut.shtml

Editing of .myemail etc. is very useful for filtering.

Cyrus-sasl wouldn't compile without kerberos support, but since I'm using kerberos for various things and everything works regardless I don't care.

If you just want pop3 support as I did, basically do everything in the guide for courier-imapd-ssl, but replace imapd with pop3d. That easy! Generate your certificates, start the server everything the same, except replce imapd with pop3d.

Couldn't really believe how easy this was.
Back to top
View user's profile Send private message
geforce
l33t
l33t


Joined: 29 Dec 2003
Posts: 653
Location: Canada

PostPosted: Fri Jun 04, 2004 3:02 am    Post subject: Reply with quote

There is something I don't understand:


1) I can't connect with other users than ROOT: if I connect , with squirrelmail, with user geforce I get:
Quote:

ERROR:
ERROR : Connection dropped by imap-server.


2) I can't send E-mails:

Quote:

Warning: fsockopen(): unable to connect to localhost:25 in /var/www/localhost/htdocs/squirrelmail/class/deliver/Deliver_SMTP.class.php on line 59
ERROR:
Connection refused
Server replied: 111
Back to top
View user's profile Send private message
vlack
n00b
n00b


Joined: 01 Apr 2003
Posts: 59
Location: Austin, TX

PostPosted: Sat Jun 05, 2004 6:41 pm    Post subject: Reply with quote

ignore me.
Back to top
View user's profile Send private message
geforce
l33t
l33t


Joined: 29 Dec 2003
Posts: 653
Location: Canada

PostPosted: Sat Jun 05, 2004 9:04 pm    Post subject: Reply with quote

I do as you said, but i get:

Quote:
Transaction failed
Server replied: 554 <root@geforce.no-ip.org>: Relay access denied
Back to top
View user's profile Send private message
Hagar
Guru
Guru


Joined: 11 Feb 2003
Posts: 445

PostPosted: Sun Jun 06, 2004 6:32 pm    Post subject: Reply with quote

I'm a little confused about what %T is replaced with in the crontab.
I have the same problem BlinkEye has but I also recieve delivery errors when I remove the -m flag from the crontab.

/usr/bin/fetchmail -a -v -m "/usr/bin/procmail -d \%T"
Code:
...
#*sh: -c: line 1: unexpected EOF while looking for matching `''
sh: -c: line 2: syntax error: unexpected end of file
fetchmail: SIGPIPE thrown from an MDA or a stream socket error
fetchmail: socket error while fetching from mail.home.nl
fetchmail: 6.2.5 querying mail.home.nl (protocol POP3) at Sun Jun  6 19:40:03 2004: poll completed
fetchmail: Query status=2 (SOCKET)
...

In the console /usr/bin/fetchmail -a -v -m "/usr/bin/procmail -d %T" works fine (without the slash)
With the slash I get the same error as with the crontab.
I'm using vixie-cron and /bin/sh as cron shell, is a different escape method needed ?

/usr/bin/fetchmail -a -v
Code:
...
fetchmail: SMTP< 250 Ok
fetchmail: SMTP> RCPT TO:<harm@localhost>
fetchmail: SMTP< 554 <localhost[127.0.0.1]>: Client host rejected: Access denied
fetchmail: SMTP error: 554 <localhost[127.0.0.1]>: Client host rejected: Access denied
fetchmail: SMTP listener doesn't like recipient address `harm@localhost'
...

That last one is even more confusing as I am able to send mail locally from the console with "mailx -s Subject harm" without any problems.
Back to top
View user's profile Send private message
oopstu
n00b
n00b


Joined: 22 Jun 2003
Posts: 20
Location: VA

PostPosted: Mon Jun 07, 2004 4:28 pm    Post subject: Bad Certificates Reply with quote

Hi,

Great guide. Things are mostly working. I'm having the same 'bad certificate' Thunderbird problem that many other folks are having or had. I read through all 19 pages of the topic looking for a succint answer or explanation of the problem and a resolution but couldn't find one.

Could someone explain to me how to generate a new certificate for the server such that Thunderbird and the server can negotiate the TLS transaction and send mail?

thanks, stu
Back to top
View user's profile Send private message
Tuinslak
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 129
Location: Belgium

PostPosted: Fri Jun 18, 2004 11:51 am    Post subject: Reply with quote

Code:
Kryptonite courier-imap # /etc/init.d/courier-imapd-ssl start
 * Starting authdaemond.plain...                                                                                                  [ ok ]
 * Starting courier-imapd over SSL...
bind: Address already in use
ll_daemon_start: Resource temporarily unavailable                                                                                 [ !! ]


any idea what's wrong ?

Code:
Kryptonite courier-imap # grep imaps /etc/services
imaps           993/tcp                         # IMAP over SSL
imaps           993/udp                         # IMAP over SSL
Kryptonite courier-imap # ps ax | grep imap
32363 pts/85   S      0:00 grep imap
Kryptonite courier-imap # netstat -A inet -lp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 *:imaps                 *:*                     LISTEN      10494/stunnel   

_________________
Tuinslak
Back to top
View user's profile Send private message
BlinkEye
Veteran
Veteran


Joined: 21 Oct 2003
Posts: 1046
Location: Gentoo Forums

PostPosted: Fri Jun 18, 2004 12:31 pm    Post subject: Reply with quote

gnah. i had that too and forgot how i solved it. i've googled for it and probably found an answer. i'll do an updatedb on my memory and hopefully i remember what the cause was :wink:.
_________________
Easily backup up your system? klick
Get rid of SSH Brute Force Attempts / Script Kiddies klick
Back to top
View user's profile Send private message
Tuinslak
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 129
Location: Belgium

PostPosted: Fri Jun 18, 2004 12:39 pm    Post subject: Reply with quote

hehe, ok, i'm searching google... but ..
_________________
Tuinslak
Back to top
View user's profile Send private message
BlinkEye
Veteran
Veteran


Joined: 21 Oct 2003
Posts: 1046
Location: Gentoo Forums

PostPosted: Fri Jun 18, 2004 12:49 pm    Post subject: Reply with quote

you could post your configs and i'll compare them to mine or you could pm me and i'd send mine to you or ...
_________________
Easily backup up your system? klick
Get rid of SSH Brute Force Attempts / Script Kiddies klick
Back to top
View user's profile Send private message
Tuinslak
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 129
Location: Belgium

PostPosted: Fri Jun 18, 2004 1:59 pm    Post subject: Reply with quote

this should be the configs:
http://tuinslak.oom-killer.org/config/authdaemonrc
http://tuinslak.oom-killer.org/config/authdaemond.conf
(only imap stuff?!)


and it's possible in this howto, not to enable all authentication for smtp and so on (don't need it at home)?
_________________
Tuinslak
Back to top
View user's profile Send private message
BlinkEye
Veteran
Veteran


Joined: 21 Oct 2003
Posts: 1046
Location: Gentoo Forums

PostPosted: Fri Jun 18, 2004 2:38 pm    Post subject: Reply with quote

looks good to me. i think i remember what the problem was: the certificates - have you created and placed them in /etc/postfix/ ?
here's a really good guid to postfix and smtp authentication. it takes some time but if you do it the way they suggest it works afterwards:
http://postfix.state-of-mind.de/patrick.koetter/smtpauth/postfix_configuration.html
_________________
Easily backup up your system? klick
Get rid of SSH Brute Force Attempts / Script Kiddies klick
Back to top
View user's profile Send private message
Tuinslak
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 129
Location: Belgium

PostPosted: Fri Jun 18, 2004 3:04 pm    Post subject: Reply with quote

ok, thanks, i'll try that
_________________
Tuinslak


Last edited by Tuinslak on Sat Jun 26, 2004 10:50 am; edited 1 time in total
Back to top
View user's profile Send private message
Magnetron
n00b
n00b


Joined: 22 May 2004
Posts: 12
Location: USSR

PostPosted: Sat Jun 26, 2004 10:02 am    Post subject: Reply with quote

Quote:

6.2 Automating and Finalizing:

Since we're using Fetchmail in non-daemon mode, we'll use cron to emulate it. Here's the correct cron line, however I have found vcron tends to choke on it.

Code:

*/10 * * * * /usr/bin/fetchmail -a -s -m "/usr/bin/procmail -d \%T"


The above code block adds a cron job that will run every 10 minutes and fetch email and then passes it directly to procmail. Thanks to requiem for the correct crontab line.


Where I put this code line?!?!?!?!?!?! :oops: :oops: :oops:
Back to top
View user's profile Send private message
BlinkEye
Veteran
Veteran


Joined: 21 Oct 2003
Posts: 1046
Location: Gentoo Forums

PostPosted: Sat Jun 26, 2004 11:11 am    Post subject: Reply with quote

in your user's crontab file which you open with
Code:
crontab -e

this won't probably work, which means your user isn't in the cron group. so, do the following (as root):
Code:
vi /etc/group

or
Code:
nano /etc/group

and add your user to the cron line so the cron line looks like this:
Code:
cron:x:16:cron,*your_user_name*

after that you may add user specific crontab entries with the above mentioned command
_________________
Easily backup up your system? klick
Get rid of SSH Brute Force Attempts / Script Kiddies klick
Back to top
View user's profile Send private message
Magnetron
n00b
n00b


Joined: 22 May 2004
Posts: 12
Location: USSR

PostPosted: Sat Jun 26, 2004 12:02 pm    Post subject: Reply with quote

Thanks, but I have another problem.
Code:

 /usr/bin/fetchmail -a -s -m "/usr/bin/procmail -d \%T"
sh: -c: line 1: unexpected EOF while looking for matching `''
sh: -c: line 2: syntax error: unexpected end of file
fetchmail: SIGPIPE thrown from an MDA or a stream socket error
fetchmail: socket error while fetching from *nameofmypopmailserver*
fetchmail: Query status=2 (SOCKET)


Any ideas?
Back to top
View user's profile Send private message
BlinkEye
Veteran
Veteran


Joined: 21 Oct 2003
Posts: 1046
Location: Gentoo Forums

PostPosted: Sat Jun 26, 2004 12:08 pm    Post subject: Reply with quote

Code:
 /usr/bin/fetchmail -a -s -m "/usr/bin/procmail -d \%T"
sh: -c: line 1: unexpected EOF while looking for matching `''
sh: -c: line 2: syntax error: unexpected end of file

i get the same errors with your crontabe entry. i just use
Code:
*/2 * * * * /usr/bin/fetchmail -s

wich works fine (my setup: fetchmail, procmail, amavisd-new, postfix and spamassassin).
about
Code:
fetchmail: SIGPIPE thrown from an MDA or a stream socket error
fetchmail: socket error while fetching from *nameofmypopmailserver*
fetchmail: Query status=2 (SOCKET)

could it be that you're already logged in - some accounts won't let you login twice so check if that's the problem
_________________
Easily backup up your system? klick
Get rid of SSH Brute Force Attempts / Script Kiddies klick
Back to top
View user's profile Send private message
Magnetron
n00b
n00b


Joined: 22 May 2004
Posts: 12
Location: USSR

PostPosted: Sat Jun 26, 2004 1:05 pm    Post subject: Reply with quote

Your code
Code:

*/2 * * * * /usr/bin/fetchmail -s

good for me, it's work.
Thanks.
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Fri Jul 02, 2004 12:05 pm    Post subject: Reply with quote

I followed the HowTo and now I'm not sure about the IMAP thing because I've never used it before but I like the idea of it. So I want to make sure, that I didn't miss something: I fetch my emails with fetchmail and procmail passes them on in my maildir directory in the /new subfolder or whatever I specified in .procmailrc? I use KMail, so I grab the new emails and filter them into the created IMAP directories?
Where are the emails in my IMAP folder stored physically on the server? So I could make a backup of them? I noticed that there is one fixed folder "Incoming" and I can only create subfolders in this one on the IMAP server, right?

Thanks in advance for all your help.
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Sat Jul 03, 2004 6:43 am    Post subject: Reply with quote

Sorry for the previous message, I already found the solutions for my questions. I didn't have the default folder ~/.maildir for my emails, and since IMAP looks there... So I moved all my Mails to ~/.maildir and now it's working.

Thanks for the excellent tutorial.
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
Tazok
Guru
Guru


Joined: 25 Oct 2003
Posts: 310

PostPosted: Sat Jul 03, 2004 9:27 am    Post subject: Reply with quote

I followed this guide to build an home email system, but now I'm stuck.
If I try to login with mutt or thunderbird, I am getting this error:
Code:
Unable to open this mailbox.

If I try to login in with squirrelmail, I am getting this:
Code:
Error connecting to IMAP server: localhost.
111 : Connection refused


This is my main.cf : [...]

Any Ideas?

EDIT: I took another attempt to follow the guide, copied and pasted all settings, but I'm still having the same problem ...
What else can I try?
Back to top
View user's profile Send private message
lurid
Guru
Guru


Joined: 12 Mar 2003
Posts: 595
Location: Florida

PostPosted: Mon Jul 05, 2004 11:15 pm    Post subject: Reply with quote

I hate MTA's. I really do. The people who came up with this concept should be drug out into the street and shot. Yes, I understand the UNIX philosophy is to have one program do one thing and have it do it well, but good god, how many programs do you need just to get your frickin email?!

After *hours* of editing text file after text file, I've given up. I'm way too burnt out to even try this guide, though maybe the next time I feel like stabbing myself in the eye I'll try to set up an MTA instead, and use this guide. I almost, *almost*, at this point, understand what Windows users mean when they say UNIX/Linux is needlessly complex.

I just wanted SpamAssasin. Instead I got a migrane. Sometimes UNIX is teh sux. :cry:
_________________
Go find a cheerleader and saw her legs off. - Nny
Back to top
View user's profile Send private message
iljohnson
n00b
n00b


Joined: 03 Jun 2004
Posts: 24
Location: Barossa Valley, Australia

PostPosted: Tue Jul 06, 2004 11:52 am    Post subject: Unexpected SSL conection shutdown Reply with quote

Hi,

not having much luck here, doc seems very good though.

I have a single server at this stage and a dialup connection with a fixed Ip, in the future I want to use NAT to extend my network behind the server.

My internal eth0 address is 172.0.0.2, external ppp0 203.102.191.24 and localhost 127.0.0.1

Hots name tux, domain name thejohnsonsplace.org

I am just trying to send mail at the moment from the server (127.0.0.1) but I keep getting the following SSL error.

: 0020 85 08 84 01 cf bf a9 2a|3b a2 37 .......* ;.7
Jul 6 20:51:39 tux postfix/smtpd[11631]: SSL_accept:SSLv3 flush data
Jul 6 20:51:39 tux postfix/smtpd[11631]: TLS connection established from localhost[127.0.0.1]: TLSv1 with cipher RC4-MD5 (128/128 bits)
Jul 6 20:51:39 tux postfix/smtpd[11631]: disconnect from localhost[127.0.0.1]
Jul 6 20:52:00 tux CRON[11635]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Jul 6 20:52:14 tux imapd-ssl: Connection, ip=[127.0.0.1]
Jul 6 20:52:14 tux imapd-ssl: Unexpected SSL connection shutdown.
Jul 6 20:52:35 tux imapd-ssl: Connection, ip=[127.0.0.1]
Jul 6 20:52:35 tux imapd-ssl: LOGIN, user=iljohnson, ip=[127.0.0.1], protocol=IMAP
Jul 6 20:52:39 tux imapd-ssl: Unexpected SSL connection shutdown.
Jul 6 20:52:39 tux imapd-ssl: DISCONNECTED, user=iljohnson, ip=[127.0.0.1], headers=0, body=0
Jul 6 20:52:46 tux imapd-ssl: Connection, ip=[127.0.0.1]
Jul 6 20:52:46 tux imapd-ssl: LOGIN, user=iljohnson, ip=[127.0.0.1], protocol=IMAP
Jul 6 20:52:49 tux imapd-ssl: Unexpected SSL connection shutdown.
Jul 6 20:52:49 tux imapd-ssl: DISCONNECTED, user=iljohnson, ip=[127.0.0.1], headers=0, body=0
Jul 6 20:52:55 tux imapd-ssl: Connection, ip=[127.0.0.1]
Jul 6 20:52:55 tux imapd-ssl: LOGIN, user=iljohnson, ip=[127.0.0.1], protoc

I have been looking for an answer, checked my config twice and found a few problems but nothing to fix this.

I have a second problem in relation to the setup with Kmail in that it fails to open the inbox of the IMAP box, I get a server error.

any help appreciated

Ian
Back to top
View user's profile Send private message
robertnn
n00b
n00b


Joined: 27 Oct 2003
Posts: 50
Location: Vienna

PostPosted: Thu Jul 08, 2004 11:22 am    Post subject: procmail seems not to be touched Reply with quote

I like the guide, though there is one problem left.

Procmail does not seem to even get started, when using via postfix.

It works fine with

/usr/bin/fetchmail -v -m /usr/bin/procmail

all mail gets sorted into the correct folder.

But the local delivery, when I send an email to myname@localhost doesn't seem to have any contact with procmail at all.

Shouldn't
mailbox_command = /usr/bin/procmail
do exactly that?

tips appreciated

btw,
needed to switch to suse at work, but it should be the same, or not?
Back to top
View user's profile Send private message
robertnn
n00b
n00b


Joined: 27 Oct 2003
Posts: 50
Location: Vienna

PostPosted: Thu Jul 08, 2004 12:27 pm    Post subject: Reply with quote

Just if anyone is interested: I finally got it.

The config contains a lot of commented stuff at the beginning. That's where i just uncommented the mailbox command.

Then, at the end of the file there are all of the config options again, not commented, so this always overwrote my settings.

Took me some hours, but next time I will know ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 25, 26, 27  Next
Page 19 of 27

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum