Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Email System For The Home Network - Version 2.1
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 25, 26, 27  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
bdemore
n00b
n00b


Joined: 22 Oct 2002
Posts: 67

PostPosted: Fri Jul 09, 2004 3:56 pm    Post subject: ISP Problem Reply with quote

Great Guide, one problem. I tried to configure my server as a full blown mta but I guess Cox Communications blocks port 25 so my mail wouldn't send. I then implemented the alternative method of trying to send mail through their smtp server but I have a problem with the configuration of /etc/postfix/saslpass. I configured it per the guide as noted below with no success. Apparently cox uses no authentication for their outgoing (smtp) servers.

smtp.isp.com beo739:rsmtp-pass

I also tried the following configurations with no success:

smtp.isp.com beo739
smtp.isp.com

Has anyone encountered this before? Is there a way to circumvent the port 25 blocking so that I can run an mta? Thanks in advance.
Back to top
View user's profile Send private message
jhboricua
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2002
Posts: 113

PostPosted: Fri Jul 09, 2004 8:04 pm    Post subject: Finnaly got it to work... Reply with quote

After having difficulties with qmail's handling of unauthorized incomming connections and obscure logs I decided to go back to postfix, specially now that the guide was using smtp-auth against shadow and also was adjusted for fully fledge email server setups.

I got pretty much all of the problems described here one way or another on my initial attempt. SSL certificate errors, not able to authenticate, etc, etc, etc. After several hours I got it to work flawlessly. My solution? I wiped EVERYTHING POSTFIX, COURIER, SASL and OPENSSL related off my hard drive. Than means I unmerged the programs, then went to /etc and other related directories and deleted every single file/dir that ever had config settings for these programs.

Once I did that I remerged OpenSSL and everything else according to this guide. I also made my own Postfix certificates using the instructions on the Gentoo Postfix/Virtual Mailserver document on Gentoo's Document section. Setup everything and was finally able to see smtp-auth work over TLS. The only problem I got was that when I tried to email myself from work the msg was getting bounced!!!. Indeed, as pointed out on this thread, the setting on postfix's main.cf file shown on the first page that reads,
Code:

smtpd_client_restrictions = permit_sasl_authenticated, reject

will result in all incomming mail to your box to be rejected because the outside mail server trying to relay the message to your box user account cannot authenticate thru SASL. I'm surprised that has not been updated on the first page yet. After figuring that out and making the appropriate changes, I now have a fully working mail setup.

Here's my Postfix main.cf file:
Code:

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mail_owner = postfix
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain $mydomain
unknown_local_recipient_reject_code = 450
mynetworks_style = subnet
mynetworks = 192.168.4.0/24 127.0.0.0/8
mailbox_command = /usr/bin/procmail
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = postdrop
manpage_directory = /usr/share/man
readme_directory = /usr/share/doc/postfix-2.1.3/readme
default_destination_concurrency_limit = 2
alias_database = hash:/etc/mail/aliases
local_destination_concurrency_limit = 2
alias_maps = hash:/etc/mail/aliases
home_mailbox = .maildir/
smtpd_sasl_auth_enable = yes
smtpd_sasl2_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
#smtpd_client_restrictions = permit_sasl_authenticated, reject (causes valid incoming mail to be rejected)
smtpd_recipient_restrictions = permit_sasl_authenticated,reject_unauth_destination
smtpd_client_restrictions = permit_sasl_authenticated,reject_unauth_destination
smtpd_use_tls=yes
smtpd_tls_auth_only = yes
smtpd_tls_key_file = /etc/ssl/postfix/newreq.pem # (New custom self-signed certificate with server's fqdn instead of localhost)
smtpd_tls_cert_file = /etc/ssl/postfix/newcert.pem # (ditto)
smtpd_tls_CAfile = /etc/ssl/postfix/cacert.pem # (ditto)
smtpd_tls_loglevel = 3
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom


Now that I got that out of the way I'm ready to implement virus scanning and spam-filtering capabilities. Thx for the guide.
Back to top
View user's profile Send private message
iljohnson
n00b
n00b


Joined: 03 Jun 2004
Posts: 24
Location: Barossa Valley, Australia

PostPosted: Sun Jul 11, 2004 11:18 pm    Post subject: SASL and SASL2 enties in Main.cf Reply with quote

Hi,

going through the same problems about time I started with a clean sheet of paper now that I have learned alot about this setup.

In your main.cf you have
Quote:


smtpd_sasl_auth_enable = yes
smtpd_sasl2_auth_enable = yes




Why the two entries, is smtpd_sasl for early version of postfix and sasl2 for versions 2.XX and above?

I would like to see some testings stages added so you can check each area to confirm function before going forward.

Anyway its an interesting experiance. :roll:

Ian


Quote:


Up and working now after a complete fresh start. Kmail still failed to send mail until it had received one email. Don't know what this is about. After sending an email via Mutt up she came.



Last edited by iljohnson on Mon Jul 12, 2004 10:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
CiscoSid
n00b
n00b


Joined: 14 Jun 2004
Posts: 6

PostPosted: Mon Jul 12, 2004 10:21 pm    Post subject: Reply with quote

Hello,

Hopefully a few gurus are still reading this :P I have a few questions/issues I hope you can help with.

A few points about my setup (and what works):
I'm not using SSL/IMAP - just standard IMAP - port 143.
I want to send mail via my ISPs SMTP server (most of the time). This server doesn't require authentication, though I *assume* it only allows mail from users within the IP ranges which it owns.

What doesn't work:
No TLS authentication - any ideas?

I couldn't send mail unless I commented out this:
Code:

#smtpd_client_restrictions = permit_sasl_authenticated, reject


I want to make sure all sent mail is sent to my ISP. I commented out this from main.cf:
Code:

#smtp_sasl_auth_enable = yes
#smtp_sasl_password_maps = hash:/etc/postfix/saslpass
#smtp_sasl_security_options = noanonymous


However, when my ISP SMTP server is down (it happens quite a bit) I'd like to revert to sending my own mail. Any thoughts on the best way to do this?

What was I doing wrong? I've decided not to use SSL IMAP as I'm happy with standard IMAP, but I'd like to force authentication for my SMTP server.

When sending from mutt (on server) to user@localhost, mail arrives fine. When trying to send to user@192.168.1.2 from a client, the mail gets sent to my ISPs SMTP and obviously doesn't get delivered, I just get the failure message. How can I set it up so that any mail for outside my local subnet is routed to the ISP SMTP but local mail is delivered direct - is this even possible?

Here is my full main.cf for completeness:
Code:

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mail_owner = postfix
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain $mydomain
unknown_local_recipient_reject_code = 450
mynetworks_style = subnet
mynetworks = 127.0.0.0/8 192.168.1.0/24
mailbox_command = /usr/bin/procmail
debug_peer_level = 2
debugger_command =
        PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin:
        xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = postdrop
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.0.16-r1/sample
readme_directory = /usr/share/doc/postfix-2.0.16-r1/readme
default_destination_concurrency_limit = 2
alias_database = hash:/etc/mail/aliases
local_destination_concurrency_limit = 2
alias_maps = hash:/etc/mail/aliases
home_mailbox = .maildir/

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
#smtpd_client_restrictions = permit_sasl_authenticated, reject

smtpd_use_tls=yes
smtpd_tls_auth_only = yes
smtpd_tls_key_file = /etc/ssl/postfix/server.key
smtpd_tls_cert_file = /etc/ssl/postfix/server.crt
smtpd_tls_CAfile = /etc/ssl/postfix/server.pem
smtpd_tls_loglevel = 3
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

#smtp_sasl_auth_enable = yes
#smtp_sasl_password_maps = hash:/etc/postfix/saslpass
#smtp_sasl_security_options = noanonymous

_________________
Asus A7N8X Deluxe 2.0 | AMD XP 2400 | ATI 9600XT
Back to top
View user's profile Send private message
snowpatch
n00b
n00b


Joined: 09 Mar 2003
Posts: 38
Location: Philadelphia

PostPosted: Wed Jul 21, 2004 2:51 am    Post subject: Reply with quote

CiscoSid:

To use a smart host you need to add the following parameter to main.cf
Code:
relayhost = smtp.isp.com


When you tried to send mail from another machine on your LAN, did you try telnet or just use a MUA such as Evolution? Try
Code:
telnet <servername> 25
.

http://postfix.state-of-mind.de/patrick.koetter/smtpauth/index.html helped me alot.
Back to top
View user's profile Send private message
snowpatch
n00b
n00b


Joined: 09 Mar 2003
Posts: 38
Location: Philadelphia

PostPosted: Wed Jul 21, 2004 3:03 am    Post subject: SSL/TLS log messages Reply with quote

This guide has been great. One thing about TLS has come up though. I noticed in my logs recently that the 'TLS connection established from' lines have changed slightly:

The messages that I have sent using Mozilla-mail a few weeks ago mention TLSv1
Quote:
Jul 7 12:57:52 marmolata postfix/smtpd[25994]: SSL_accept:SSLv3 flush data
Jul 7 12:57:52 marmolata postfix/smtpd[25994]: TLS connection established from
unknown[10.0.1.125]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)

and now with the same MUA it has changed to SSLv3
Quote:
Jul 19 21:12:46 marmolata postfix/smtpd[15793]: SSL_accept:SSLv3 flush data
Jul 19 21:12:46 marmolata postfix/smtpd[15793]: TLS connection established from
unknown[10.0.1.125]: SSLv3 with cipher DHE-RSA-AES256-SHA (256/256 bits)

I gather from reading the ssl and postfix newsgroups that TLSv1 and SSLv3 are basically the same thing. I am using openssl-0.9.7d-r1 and postfix-2.0.19. Any one know why this would change?
Back to top
View user's profile Send private message
simon pants
n00b
n00b


Joined: 30 Apr 2004
Posts: 47

PostPosted: Fri Jul 23, 2004 4:58 pm    Post subject: postfix won't send to ISP SMTP Reply with quote

sorry if this is a basic question. i scanned the forum and couldn't find a straight answer:

i get the following error when Postfix attempts to relay mail to my ISP SMTP:
Quote:

Name service error for name=purpleant.net type=MX: Host not found, try again


i have tried setting relayhost in /etc/postfix/main.cf. this only changes the error message to include the www in front of the domain name :cry:

there is no chrooting in master.cf either.

i have also tried removing authentication for smtp. still fails.

my main.cf is as follows:
Code:

# Global Postfix configuration file. This file lists only a subset
# of all 300+ parameters. See the sample-xxx.cf files for a full list.
#
# The general format is lines with parameter = value pairs. Lines
# that begin with whitespace continue the previous line. A value can
# contain references to other $names or ${name}s.
#
# NOTE - CHANGE NO MORE THAN 2-3 PARAMETERS AT A TIME, AND TEST IF
# POSTFIX STILL WORKS AFTER EVERY CHANGE.

# SOFT BOUNCE
#
# The soft_bounce parameter provides a limited safety net for
# testing.  When soft_bounce is enabled, mail will remain queued that
# would otherwise bounce. This parameter disables locally-generated
# bounces, and prevents the SMTP server from rejecting mail permanently
# (by changing 5xx replies into 4xx replies). However, soft_bounce
# is no cure for address rewriting mistakes or mail routing mistakes.
#
#soft_bounce = no

# LOCAL PATHNAME INFORMATION
#
# The queue_directory specifies the location of the Postfix queue.
# This is also the root directory of Postfix daemons that run chrooted.
# See the files in examples/chroot-setup for setting up Postfix chroot
# environments on different UNIX systems.
#
queue_directory = /var/spool/postfix

# The command_directory parameter specifies the location of all
# postXXX commands.
#
command_directory = /usr/sbin

# The daemon_directory parameter specifies the location of all Postfix
# daemon programs (i.e. programs listed in the master.cf file). This
# directory must be owned by root.
#
daemon_directory = /usr/lib/postfix

# QUEUE AND PROCESS OWNERSHIP
#
# The mail_owner parameter specifies the owner of the Postfix queue
# and of most Postfix daemon processes.  Specify the name of a user
# account THAT DOES NOT SHARE ITS USER OR GROUP ID WITH OTHER ACCOUNTS
# AND THAT OWNS NO OTHER FILES OR PROCESSES ON THE SYSTEM.  In
# particular, don't specify nobody or daemon. PLEASE USE A DEDICATED
# USER.
#
mail_owner = postfix

# The default_privs parameter specifies the default rights used by
# the local delivery agent for delivery to external file or command.
# These rights are used in the absence of a recipient user context.
# DO NOT SPECIFY A PRIVILEGED USER OR THE POSTFIX OWNER.
#
#default_privs = nobody

# INTERNET HOST AND DOMAIN NAMES
#
# The myhostname parameter specifies the internet hostname of this
# mail system. The default is to use the fully-qualified domain name
# from gethostname(). $myhostname is used as a default value for many
# other configuration parameters.
#
#myhostname = host.domain.tld
#myhostname = virtual.domain.tld

# The mydomain parameter specifies the local internet domain name.
# The default is to use $myhostname minus the first component.
# $mydomain is used as a default value for many other configuration
# parameters.
#
#mydomain = domain.tld

# SENDING MAIL
#
# The myorigin parameter specifies the domain that locally-posted
# mail appears to come from. The default is to append $myhostname,
# which is fine for small sites.  If you run a domain with multiple
# machines, you should (1) change this to $mydomain and (2) set up
# a domain-wide alias database that aliases each user to
# user@that.users.mailhost.
#
# For the sake of consistency between sender and recipient addresses,
# myorigin also specifies the default domain name that is appended
# to recipient addresses that have no @domain part.
#
myorigin = $myhostname
#myorigin = $mydomain

# RECEIVING MAIL

# The inet_interfaces parameter specifies the network interface
# addresses that this mail system receives mail on.  By default,
# the software claims all active interfaces on the machine. The
# parameter also controls delivery of mail to user@[ip.address].
#
# See also the proxy_interfaces parameter, for network addresses that
# are forwarded to us via a proxy or network address translator.
#
# Note: you need to stop/start Postfix when this parameter changes.
#
#inet_interfaces = all
#inet_interfaces = $myhostname
#inet_interfaces = $myhostname, localhost

# The proxy_interfaces parameter specifies the network interface
# addresses that this mail system receives mail on by way of a
# proxy or network address translation unit. This setting extends
# the address list specified with the inet_interfaces parameter.
#
# You must specify your proxy/NAT addresses when your system is a
# backup MX host for other domains, otherwise mail delivery loops
# will happen when the primary MX host is down.
#
#proxy_interfaces =
#proxy_interfaces = 1.2.3.4

# The mydestination parameter specifies the list of domains that this
# machine considers itself the final destination for.
#
# These domains are routed to the delivery agent specified with the
# local_transport parameter setting. By default, that is the UNIX
# compatible delivery agent that lookups all recipients in /etc/passwd
# and /etc/aliases or their equivalent.
#
# The default is $myhostname + localhost.$mydomain.  On a mail domain
# gateway, you should also include $mydomain.
#
# Do not specify the names of virtual domains - those domains are
# specified elsewhere (see sample-virtual.cf).
#
# Do not specify the names of domains that this machine is backup MX
# host for. Specify those names via the relay_domains settings for
# the SMTP server, or use permit_mx_backup if you are lazy (see
# sample-smtpd.cf).
#
# The local machine is always the final destination for mail addressed
# to user@[the.net.work.address] of an interface that the mail system
# receives mail on (see the inet_interfaces parameter).
#
# Specify a list of host or domain names, /file/name or type:table
# patterns, separated by commas and/or whitespace. A /file/name
# pattern is replaced by its contents; a type:table is matched when
# a name matches a lookup key (the right-hand side is ignored).
# Continue long lines by starting the next line with whitespace.
#
# DO NOT LIST RELAY DESTINATIONS IN MYDESTINATION.
# SPECIFY RELAY DESTINATIONS IN RELAY_DOMAINS.
#
# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
#
#mydestination = $myhostname, localhost.$mydomain
mydestination = $myhostname, localhost.$mydomain $mydomain
#mydestination = $myhostname, localhost.$mydomain, $mydomain,
#       mail.$mydomain, www.$mydomain, ftp.$mydomain

# REJECTING MAIL FOR UNKNOWN LOCAL USERS
#
# The local_recipient_maps parameter specifies optional lookup tables
# with all names or addresses of users that are local with respect
# to $mydestination and $inet_interfaces.
#
# If this parameter is defined, then the SMTP server will reject
# mail for unknown local users. This parameter is defined by default.
#
# To turn off local recipient checking in the SMTP server, specify
# local_recipient_maps = (i.e. empty).
#
# The default setting assumes that you use the default Postfix local
# delivery agent for local delivery. You need to update the
# local_recipient_maps setting if:
#
# - You define $mydestination domain recipients in files other than
#   /etc/passwd, /etc/aliases, or the $virtual_alias_maps files.


#   For example, you define $mydestination domain recipients in
#   the $virtual_mailbox_maps files.
#
# - You redefine the local delivery agent in master.cf.
#
# - You redefine the "local_transport" setting in main.cf.
#
# - You use the "luser_relay", "mailbox_transport", or "fallback_transport"
#   feature of the Postfix local delivery agent (see sample-local.cf).
#
# Details are described in the LOCAL_RECIPIENT_README file.
#
# Beware: if the Postfix SMTP server runs chrooted, you probably have
# to access the passwd file via the proxymap service, in order to
# overcome chroot restrictions. The alternative, having a copy of
# the system passwd file in the chroot jail is just not practical.
#
# The right-hand side of the lookup tables is conveniently ignored.
# In the left-hand side, specify a bare username, an @domain.tld
# wild-card, or specify a user@domain.tld address.
#
#local_recipient_maps = unix:passwd.byname $alias_maps
#local_recipient_maps = proxy:unix:passwd.byname $alias_maps
#local_recipient_maps =

# The unknown_local_recipient_reject_code specifies the SMTP server
# response code when a recipient domain matches $mydestination or
# $inet_interfaces, while $local_recipient_maps is non-empty and the
# recipient address or address local-part is not found.
#
# The default setting is 550 (reject mail) but it is safer to start
# with 450 (try again later) until you are certain that your
# local_recipient_maps settings are OK.
#
#unknown_local_recipient_reject_code = 550
unknown_local_recipient_reject_code = 450

# TRUST AND RELAY CONTROL

# The mynetworks parameter specifies the list of "trusted" SMTP
# clients that have more privileges than "strangers".
#
# In particular, "trusted" SMTP clients are allowed to relay mail
# through Postfix.  See the smtpd_recipient_restrictions parameter
# in file sample-smtpd.cf.
#
# You can specify the list of "trusted" network addresses by hand
# or you can let Postfix do it for you (which is the default).
#
# By default (mynetworks_style = subnet), Postfix "trusts" SMTP
# clients in the same IP subnetworks as the local machine.
# On Linux, this does works correctly only with interfaces specified
# with the "ifconfig" command.
#
# Specify "mynetworks_style = class" when Postfix should "trust" SMTP
# clients in the same IP class A/B/C networks as the local machine.
# Don't do this with a dialup site - it would cause Postfix to "trust"
# your entire provider's network.  Instead, specify an explicit
# mynetworks list by hand, as described below.
#
# Specify "mynetworks_style = host" when Postfix should "trust"
# only the local machine.
#
#mynetworks_style = class
mynetworks_style = subnet
#mynetworks_style = host

# Alternatively, you can specify the mynetworks list by hand, in
# which case Postfix ignores the mynetworks_style setting.
#
# Specify an explicit list of network/netmask patterns, where the
# mask specifies the number of bits in the network part of a host
# address.
#
# You can also specify the absolute pathname of a pattern file instead
# of listing the patterns here. Specify type:table for table-based lookups
# (the value on the table right-hand side is not used).
#
#mynetworks = 168.100.189.0/28, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table
mynetworks = 198.168.0.1/254, 127.0.0.0/8

# The relay_domains parameter restricts what destinations this system will
# relay mail to.  See the smtpd_recipient_restrictions restriction in the
# file sample-smtpd.cf for detailed information.
#
# By default, Postfix relays mail
# - from "trusted" clients (IP address matches $mynetworks) to any destination,
# - from "untrusted" clients to destinations that match $relay_domains or
#   subdomains thereof, except addresses with sender-specified routing.
# The default relay_domains value is $mydestination.
#
# In addition to the above, the Postfix SMTP server by default accepts mail
# that Postfix is final destination for:
# - destinations that match $inet_interfaces,
# - destinations that match $mydestination
# - destinations that match $virtual_alias_domains,
# - destinations that match $virtual_mailbox_domains.
# These destinations do not need to be listed in $relay_domains.
#
# Specify a list of hosts or domains, /file/name patterns or type:name
# lookup tables, separated by commas and/or whitespace.  Continue
# long lines by starting the next line with whitespace. A file name
# is replaced by its contents; a type:name table is matched when a
# (parent) domain appears as lookup key.
#
# NOTE: Postfix will not automatically forward mail for domains that
# list this system as their primary or backup MX host. See the
# permit_mx_backup restriction in the file sample-smtpd.cf.
#
#relay_domains = $mydestination

# INTERNET OR INTRANET

# The relayhost parameter specifies the default host to send mail to
# when no entry is matched in the optional transport(5) table. When
# no relayhost is given, mail is routed directly to the destination.
#
# On an intranet, specify the organizational domain name. If your
# internal DNS uses no MX records, specify the name of the intranet
# gateway host instead.
#
# In the case of SMTP, specify a domain, host, host:port, [host]:port,
# [address] or [address]:port; the form [host] turns off MX lookups.
#
# If you're connected via UUCP, see also the default_transport parameter.
#
#relayhost = $mydomain
#relayhost = gateway.my.domain
#relayhost = uucphost
#relayhost = [an.ip.add.ress]
#relayhost=www.purpleant.net

# REJECTING UNKNOWN RELAY USERS
#
# The relay_recipient_maps parameter specifies optional lookup tables
# with all addresses in the domains that match $relay_domains.
#
# If this parameter is defined, then the SMTP server will reject
# mail for unknown relay users. This feature is off by default.
#
# The right-hand side of the lookup tables is conveniently ignored.
# In the left-hand side, specify an @domain.tld wild-card, or specify
# a user@domain.tld address.
#
#relay_recipient_maps = hash:/etc/postfix/relay_recipients

# INPUT RATE CONTROL
#
# The in_flow_delay configuration parameter implements mail input
# flow control. This feature is turned on by default, although it
# still needs further development (it's disabled on SCO UNIX due
# to an SCO bug).
#
# A Postfix process will pause for $in_flow_delay seconds before
# accepting a new message, when the message arrival rate exceeds the
# message delivery rate. With the default 100 SMTP server process
# limit, this limits the mail inflow to 100 messages a second more
# than the number of messages delivered per second.
#
# Specify 0 to disable the feature. Valid delays are 0..10.
#
#in_flow_delay = 1s

# ADDRESS REWRITING
#
# Insert text from sample-rewrite.cf if you need to do address
# masquerading.
#
# Insert text from sample-canonical.cf if you need to do address
# rewriting, or if you need username->Firstname.Lastname mapping.

# ADDRESS REDIRECTION (VIRTUAL DOMAIN)
#
# Insert text from sample-virtual.cf if you need virtual domain support.

# "USER HAS MOVED" BOUNCE MESSAGES
#
# Insert text from sample-relocated.cf if you need "user has moved"
# style bounce messages. Alternatively, you can bounce recipients
# with an SMTP server access table. See sample-smtpd.cf.

# TRANSPORT MAP
#
# Insert text from sample-transport.cf if you need explicit routing.

# ALIAS DATABASE
#
# The alias_maps parameter specifies the list of alias databases used
# by the local delivery agent. The default list is system dependent.
#
# On systems with NIS, the default is to search the local alias
# database, then the NIS alias database. See aliases(5) for syntax
# details.
#
# If you change the alias database, run "postalias /etc/aliases" (or
# wherever your system stores the mail alias file), or simply run
# "newaliases" to build the necessary DBM or DB file.
#
# It will take a minute or so before changes become visible.  Use
# "postfix reload" to eliminate the delay.
#
#alias_maps = dbm:/etc/aliases
#alias_maps = hash:/etc/aliases
#alias_maps = hash:/etc/aliases, nis:mail.aliases
#alias_maps = netinfo:/aliases

# The alias_database parameter specifies the alias database(s) that
# are built with "newaliases" or "sendmail -bi".  This is a separate
# configuration parameter, because alias_maps (see above) may specify
# tables that are not necessarily all under control by Postfix.
#
#alias_database = dbm:/etc/aliases
#alias_database = dbm:/etc/mail/aliases
#alias_database = hash:/etc/aliases
#alias_database = hash:/etc/aliases, hash:/opt/majordomo/aliases

# ADDRESS EXTENSIONS (e.g., user+foo)
#
# The recipient_delimiter parameter specifies the separator between
# user names and address extensions (user+foo). See canonical(5),
# local(8), relocated(5) and virtual(5) for the effects this has on
# aliases, canonical, virtual, relocated and .forward file lookups.
# Basically, the software tries user+foo and .forward+foo before
# trying user and .forward.
#
#recipient_delimiter = +

# DELIVERY TO MAILBOX
#
# The home_mailbox parameter specifies the optional pathname of a
# mailbox file relative to a user's home directory. The default
# mailbox file is /var/spool/mail/user or /var/mail/user.  Specify
# "Maildir/" for qmail-style delivery (the / is required).
#
#home_mailbox = Mailbox
#home_mailbox = Maildir/

# The mail_spool_directory parameter specifies the directory where
# UNIX-style mailboxes are kept. The default setting depends on the
# system type.
#
#mail_spool_directory = /var/mail
#mail_spool_directory = /var/spool/mail

# The mailbox_command parameter specifies the optional external
# command to use instead of mailbox delivery. The command is run as
# the recipient with proper HOME, SHELL and LOGNAME environment settings.
# Exception:  delivery for root is done as $default_user.
#
# Other environment variables of interest: USER (recipient username),
# EXTENSION (address extension), DOMAIN (domain part of address),
# and LOCAL (the address localpart).
#
# Unlike other Postfix configuration parameters, the mailbox_command
# parameter is not subjected to $parameter substitutions. This is to
# make it easier to specify shell syntax (see example below).
#
# Avoid shell meta characters because they will force Postfix to run
# an expensive shell process. Procmail alone is expensive enough.
#
# IF YOU USE THIS TO DELIVER MAIL SYSTEM-WIDE, YOU MUST SET UP AN
# ALIAS THAT FORWARDS MAIL FOR ROOT TO A REAL USER.
#
mailbox_command = /some/where/procmail
#mailbox_command = /some/where/procmail -a "$EXTENSION"

# The mailbox_transport specifies the optional transport in master.cf
# to use after processing aliases and .forward files. This parameter
# has precedence over the mailbox_command, fallback_transport and
# luser_relay parameters.
#
# Specify a string of the form transport:nexthop, where transport is
# the name of a mail delivery transport defined in master.cf.  The
# :nexthop part is optional. For more details see the sample transport
# configuration file.
#
# NOTE: if you use this feature for accounts not in the UNIX password
# file, then you must update the "local_recipient_maps" setting in
# the main.cf file, otherwise the SMTP server will reject mail for
# non-UNIX accounts with "User unknown in local recipient table".
#
#mailbox_transport = lmtp:unix:/file/name
#mailbox_transport = cyrus

# The fallback_transport specifies the optional transport in master.cf
# to use for recipients that are not found in the UNIX passwd database.
# This parameter has precedence over the luser_relay parameter.
#
# Specify a string of the form transport:nexthop, where transport is
# the name of a mail delivery transport defined in master.cf.  The
# :nexthop part is optional. For more details see the sample transport
# configuration file.
#
# NOTE: if you use this feature for accounts not in the UNIX password
# file, then you must update the "local_recipient_maps" setting in
# the main.cf file, otherwise the SMTP server will reject mail for
# non-UNIX accounts with "User unknown in local recipient table".
#
#fallback_transport = lmtp:unix:/file/name
#fallback_transport = cyrus
#fallback_transport =

# The luser_relay parameter specifies an optional destination address
# for unknown recipients.  By default, mail for unknown@$mydestination
# and unknown@[$inet_interfaces] is returned as undeliverable.
#
# The following expansions are done on luser_relay: $user (recipient
# username), $shell (recipient shell), $home (recipient home directory),
# $recipient (full recipient address), $extension (recipient address
# extension), $domain (recipient domain), $local (entire recipient
# localpart), $recipient_delimiter. Specify ${name?value} or
# ${name:value} to expand value only when $name does (does not) exist.
#
# luser_relay works only for the default Postfix local delivery agent.
#
# NOTE: if you use this feature for accounts not in the UNIX password
# file, then you must specify "local_recipient_maps =" (i.e. empty) in
# the main.cf file, otherwise the SMTP server will reject mail for
# non-UNIX accounts with "User unknown in local recipient table".
#
#luser_relay = $user@other.host
#luser_relay = $local@other.host
#luser_relay = admin+$local

# JUNK MAIL CONTROLS
#
# The controls listed here are only a very small subset. See the file
# sample-smtpd.cf for an elaborate list of anti-UCE controls.

# The header_checks parameter specifies an optional table with patterns
# that each logical message header is matched against, including
# headers that span multiple physical lines.
#
# By default, these patterns also apply to MIME headers and to the
# headers of attached messages. With older Postfix versions, MIME and
# attached message headers were treated as body text.
#
# For details, see the sample-filter.cf file.
#
#header_checks = regexp:/etc/postfix/header_checks

# FAST ETRN SERVICE
#
# Postfix maintains per-destination logfiles with information about
# deferred mail, so that mail can be flushed quickly with the SMTP
# "ETRN domain.tld" command, or by executing "sendmail -qRdomain.tld".
#
# By default, Postfix maintains deferred mail logfile information
# only for destinations that Postfix is willing to relay to (as
# specified in the relay_domains parameter). For other destinations,
# Postfix attempts to deliver ALL queued mail after receiving the
# SMTP "ETRN domain.tld" command, or after execution of "sendmail
# -qRdomain.tld". This can be slow when a lot of mail is queued.
#
# The fast_flush_domains parameter controls what destinations are
# eligible for this "fast ETRN/sendmail -qR" service.
#
#fast_flush_domains = $relay_domains
#fast_flush_domains =

# SHOW SOFTWARE VERSION OR NOT
#
# The smtpd_banner parameter specifies the text that follows the 220
# code in the SMTP server's greeting banner. Some people like to see
# the mail version advertised. By default, Postfix shows no version.
#
# You MUST specify $myhostname at the start of the text. That is an
# RFC requirement. Postfix itself does not care.
#
#smtpd_banner = $myhostname ESMTP $mail_name
#smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)

# PARALLEL DELIVERY TO THE SAME DESTINATION
#
# How many parallel deliveries to the same user or domain? With local
# delivery, it does not make sense to do massively parallel delivery
# to the same user, because mailbox updates must happen sequentially,
# and expensive pipelines in .forward files can cause disasters when
# too many are run at the same time. With SMTP deliveries, 10
# simultaneous connections to the same domain could be sufficient to
# raise eyebrows.
#
# Each message delivery transport has its XXX_destination_concurrency_limit
# parameter.  The default is $default_destination_concurrency_limit for
# most delivery transports. For the local delivery agent the default is 2.

#local_destination_concurrency_limit = 2
#default_destination_concurrency_limit = 20

# DEBUGGING CONTROL
#
# The debug_peer_level parameter specifies the increment in verbose
# logging level when an SMTP client or server host name or address
# matches a pattern in the debug_peer_list parameter.
#
debug_peer_level = 2

# The debug_peer_list parameter specifies an optional list of domain
# or network patterns, /file/name patterns or type:name tables. When
# an SMTP client or server host name or address matches a pattern,
# increase the verbose logging level by the amount specified in the
# debug_peer_level parameter.
#
#debug_peer_list = 127.0.0.1
#debug_peer_list = some.domain

# The debugger_command specifies the external command that is executed
# when a Postfix daemon program is run with the -D option.
#
# Use "command .. & sleep 5" so that the debugger can attach before
# the process marches on. If you use an X-based debugger, be sure to
# set up your XAUTHORITY environment variable before starting Postfix.
#
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5

# If you don't have X installed on the Postfix machine, try:
# debugger_command =
#       PATH=/bin:/usr/bin:/usr/local/bin; export PATH; (echo cont;
#       echo where) | gdb $daemon_directory/$process_name $process_id 2>&1
#       >$config_directory/$process_name.$process_id.log & sleep 5

# INSTALL-TIME CONFIGURATION INFORMATION
#
# The following parameters are used when installing a new Postfix version.
#
# sendmail_path: The full pathname of the Postfix sendmail command.
# This is the Sendmail-compatible mail posting interface.
#
sendmail_path = /usr/sbin/sendmail

# newaliases_path: The full pathname of the Postfix newaliases command.
# This is the Sendmail-compatible command to build alias databases.
#
newaliases_path = /usr/bin/newaliases

# mailq_path: The full pathname of the Postfix mailq command.  This
# is the Sendmail-compatible mail queue listing command.
#
mailq_path = /usr/bin/mailq

# setgid_group: The group for mail submission and queue management
# commands.  This must be a group name with a numerical group ID that
# is not shared with other accounts, not even with the Postfix account.
#
setgid_group = postdrop

# manpage_directory: The location of the Postfix on-line manual pages.
#
manpage_directory = /usr/share/man

# sample_directory: The location of the Postfix sample configuration files.
#
sample_directory = /usr/share/doc/postfix-2.0.19/sample

# readme_directory: The location of the Postfix README files.
#
readme_directory = /usr/share/doc/postfix-2.0.19/readme
default_destination_concurrency_limit = 2
alias_database = hash:/etc/mail/aliases
local_destination_concurrency_limit = 2
alias_maps = hash:/etc/mail/aliases
home_mailbox = .maildir/

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
smtpd_client_restrictions = permit_sasl_authenticated, reject_uauth_destination

smtpd_use_tls=yes
smtpd_tls_auth_only = yes
smtpd_tls_key_file = /etc/ssl/postfix/server.key
smtpd_tls_cert_file = /etc/ssl/postfix/server.crt
smtpd_tls_CAfile = /etc/ssl/postfix/server.pem
smtpd_tls_loglevel = 3
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/saslpass
smtp_sasl_security_options = noanonymous


any ideas :?: :( :(
Back to top
View user's profile Send private message
McManus
Apprentice
Apprentice


Joined: 10 Apr 2002
Posts: 176
Location: Austin, TX

PostPosted: Thu Jul 29, 2004 8:50 am    Post subject: Reply with quote

Thanks for the guide! It works almost flawlessly!

The one thing that I can't get to work (and it's pretty trivial), is that I can't get sasl to pass mail to my ISPs smtp server. I did everything you said but it just doesn't work (I think... my only way of testing is viewing the headers, so I'm not 100% sure). Is anyone else having this problem, or are there any steps that might be missing? It just sends directly from postfix everytime, bypassing my ISPs SMTP server. :-/
_________________
McManus
----
Linux user #267375 - http://counter.li.org
Back to top
View user's profile Send private message
Laetos
n00b
n00b


Joined: 18 Jan 2003
Posts: 27
Location: utopia

PostPosted: Thu Jul 29, 2004 3:42 pm    Post subject: Reply with quote

Recheck from :

3.4 Making Postfix a Relay to our ISP:
Back to top
View user's profile Send private message
wmartino
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2004
Posts: 140

PostPosted: Sun Aug 08, 2004 12:33 pm    Post subject: Reply with quote

Hello all. I finally made to jump and put Gentoo on my server. I have now compltede the email tutorial (great job Beowulf). But I am haveing just a few issues. Here is the code:

Code:
Aug  8 06:25:11 server postfix/qmgr[26718]: warning: connect to transport smtpd-amavis: No such file or directory
Aug  8 06:25:12 server postfix/smtpd[26859]: 5A65937A4E6: client=mtiwmhc11.worldnet.att.net[204.127.131.115]
Aug  8 06:25:12 server postfix/smtpd[26859]: 5A65937A4E6: reject: RCPT from mtiwmhc11.worldnet.att.net[204.127.131.115]: 450 <suestrl@jebus.dyndns.org>: User unknown in local recipient table; from=<dizzydevil282@att.net> to=<suestrl@jebus.dyndns.org> proto=ESMTP helo=<mtiwmhc11.worldnet.att.net>
Aug  8 06:25:14 server postfix/smtpd[26859]: disconnect from mtiwmhc11.worldnet.att.net[204.127.131.115]


I first had avamis install, but my amil server was not working. I plan on putting it back on so the first line might not be anything to worry about. I would like to know why this message wont get delivered. I am stumped on the one any help would be great.

William
_________________
Intell C2D Q6600 @ 3.0Ghz -- ASUS P5W DH
Zalman 9700 LED -- 8g OCZ Gold Memory -- GECUBE 1950xtx
250g Gentoo64 -- 200g Windows Vista Ultimate -- 200g Mac OSX
250g Windows XP PRO -- Liteon DVD, Pioneer DVR-111D DVD-D/L-RW
Back to top
View user's profile Send private message
sushyad
n00b
n00b


Joined: 29 Jul 2003
Posts: 22

PostPosted: Thu Aug 19, 2004 6:09 pm    Post subject: Reply with quote

Great guide! I setup my home email system using this guide about a year ago and it has been great. I am having problem with retrieving yahoo emails with latin characters (ÁéíóúÁÉÍÓÚ). My setup is:
Courier IMAP
Fetchmail
Postfix
Squirrelmail
MrPostman (mail retriever)

In SquirrelMail, Yahoo emails with latin charaters end up with ??? even though Hotmail emails are fine. Both use MrPostman to fetch the emails. If I connect to MrPostman using an email client like ThunderBird, the Yahoo emails appear fine. So the problem is somewhere in the way Yahoo emails are being delivered by Postfix, Courier, Fetchmail. Hotmail works fine.

Has anyone faced this problem?

Thanks.
Back to top
View user's profile Send private message
Boworr
n00b
n00b


Joined: 30 Jul 2004
Posts: 45
Location: England. Where the history comes from.

PostPosted: Fri Aug 20, 2004 11:08 am    Post subject: Postfix rejects incoming mails Reply with quote

Hi, this is a great guide and I've got most of it working pretty well. However, I have a problem with fetchmail and postfix. When I run fetchmail manually I can see it connecting to my various pop3 mail accounts and downloading mail, so that part works OK. When fetchmail gives the mail to postfix for delivery, I see these messages in the log file:
Code:
Aug 20 11:57:59 [postfix/smtpd] connect from localhost[127.0.0.1]
Aug 20 11:57:59 [postfix/smtpd] NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 <localhost[127.0.0.1]>: Client host rejected: Access denied; from=<dave@myhostname.com> to=<dave@localhost> proto=ESMTP helo=<localhost>
Aug 20 11:57:59 [postfix/smtpd] starting TLS engine
Aug 20 11:57:59 [postfix/smtpd] connect from localhost[127.0.0.1]
Aug 20 11:57:59 [postfix/smtpd] NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 <localhost[127.0.0.1]>: Client host rejected: Access denied; from=<FETCHMAIL-DAEMON@localhost> to=<dave@myhostname.com> proto=SMTP helo=<localhost>
Aug 20 11:57:59 [postfix/smtpd] NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 <localhost[127.0.0.1]>: Client host rejected: Access denied; from=<dave@myhostname.com> to=<dave@localhost> proto=ESMTP helo=<localhost>
Aug 20 11:57:59 [postfix/smtpd] disconnect from localhost[127.0.0.1]

NB: I changed myhostname.com in the above text.
Back to top
View user's profile Send private message
Boworr
n00b
n00b


Joined: 30 Jul 2004
Posts: 45
Location: England. Where the history comes from.

PostPosted: Fri Aug 20, 2004 1:32 pm    Post subject: Problem solved.. Reply with quote

I had two problems it seems, the first was easy and I wasn't passing the -m parameter to fetchmail during my tests.. so it was defaulting to use smtp instead of procmail.

After that I found that I was missing a trailing / on my MAILDIR from my .procmailrc, e.g. MAILDIR=$HOME/.maildir/ If you don't add that, all the mail ends up in ~/.maildir instead of ~/.maildir/new :D
Back to top
View user's profile Send private message
mrjackson2k
n00b
n00b


Joined: 10 Aug 2003
Posts: 38

PostPosted: Tue Aug 31, 2004 2:39 pm    Post subject: Reply with quote

i'm having a problem getting bogofilter to work properly
Code:
OSError: [Errno 2] No such file or directory: '/home/xxx/.maildir/courierimapkeywords/cur'


if i create that dir it works fine, but deletes the dir when finished. creating the dir each time does work but is a pita
is there something i have done wrong? or has something changed in a new version?
_________________
emerge -s girlfriend
Searching...
[ Results For Search Key : girlfriend ]
[ Applications Found : 0 ]
Back to top
View user's profile Send private message
banjomark78
n00b
n00b


Joined: 23 Mar 2004
Posts: 4
Location: Austin,TX

PostPosted: Mon Sep 06, 2004 3:21 am    Post subject: Several problems Reply with quote

Hi all - fantastic guide, first off. This is the first I've attempted to set up a home email system, and I'd never have gotten this far without the gentoo way of things.

Anyway, here's my system. I have a dyndns record that I want to be my email address for all folks in the outside world to write to. At the moment I'm leaving squirrellmail out of the mix and just trying to get a basic sasl/imap/postfix combo going.

So, the list of problems I've got is:
1) The default keys from postfix give clients bad SSL errors. I'm still working on issuing my own cert, but I'll peg at that a bit more before I post for help.

2) Outside mail can't write me. For example, if I send myself mail from hotmail, I get the following:
Code:

Sep  5 21:43:43 [postfix/smtpd] connect from bay24-f38.bay24.hotmail.com[64.4.18.88]
Sep  5 21:43:43 [postfix/smtpd] CB180AC0CD: client=bay24-f38.bay24.hotmail.com[64.4.18.88]
Sep  5 21:43:43 [postfix/smtpd] CB180AC0CD: reject: RCPT from bay24-f38.bay24.hotmail.com[64.4.18.88]: 554 <bay24-f38.bay24.hotmail.com[64.4.18.88]>: Client host rejected: Access denied; from=<NOSPAM@hotmail.com> to=<NOSPAM@NOSPAM.homeip.net> proto=ESMTP helo=<hotmail.com>
Sep  5 21:43:45 [postfix/smtpd] disconnect from bay24-f38.bay24.hotmail.com[64.4.18.88]


Note that I can send myself messages as long as I authenticate to the smtp server.

Anyhow, here's my main.cf:
Code:

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_ath_clients = yes
smtpd_client_restrictions = permit_sasl_authenticated, reject


queue_directory = /var/spool/postfix
command_directory = /usr/sbin

daemon_directory = /usr/lib/postfix
mail_owner = postfix
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
myhostname = nittany.tahoka.homeip.net
mydomain = tahoka.homeip.net
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain $mydomain
unknown_local_recipient_reject_code = 450
mynetworks_style = subnet
mynetworks = 127.0.0.0/8 192.168.1.0/24
mailbox_command = /usr/bin/procmail
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq

setgid_group = postdrop
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.0.19/sample
readme_directory = /usr/share/doc/postfix-2.0.19/readme
default_destination_concurrency_limit = 2
alias_database = hash:/etc/mail/aliases
local_destination_concurrency_limit = 2
alias_maps = hash:/etc/mail/aliases
home_mailbox = .maildir/


Before I head to sleep tonight I'm going to kick off an emerge sync and emerge -u world to bring all of this up to current, hopefully that will help.

Any thoughts on the external mails getting rejected?
Back to top
View user's profile Send private message
Solution_9
Guru
Guru


Joined: 22 Jun 2003
Posts: 311

PostPosted: Mon Sep 13, 2004 10:48 pm    Post subject: Reply with quote

Do you need to use fetchmail if you use an email client? Like is fetchmail just used for a console based mail retriever?
_________________
"The X server has to be the biggest program I've ever seen that doesn't do anything for you."
- Ken Thompson
Back to top
View user's profile Send private message
Solution_9
Guru
Guru


Joined: 22 Jun 2003
Posts: 311

PostPosted: Tue Sep 14, 2004 10:12 am    Post subject: Reply with quote

This should be a simple question. Do i need to start courier-imapd for courier imapd-ssl to work? Im using Evolution, and i cannot connect to IMAP unless courier-imapd is running. Should this be happening? I have tried using domainname.com:993 for host also, but this does not work. When i telnet into localhost under port 143, i can see a bunch of information on IMAP. Now when i telnet into localhost under port 993, i get in, but i do not see any info on IMAP.

Also, I cannot *succesfully* send or recieve any email. When i try to send something, it shows it going through, but never actually reaches its destination.

Leave the second problem to be fixed at a later time. hehe.
_________________
"The X server has to be the biggest program I've ever seen that doesn't do anything for you."
- Ken Thompson
Back to top
View user's profile Send private message
Wilhelm
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 149

PostPosted: Tue Sep 14, 2004 1:22 pm    Post subject: Reply with quote

Maybe this is already known but here is a small tip:

When using sasl in combination courier-imap you can do the follwoing to store the passwords in the database in encrypted form.

Change MYSQL_CLEAR_PWFIELD to MYSQL_CRYPT_PWFIELD in /etc/courier-imap/authmysqlrc

You can now use ENCRYPT('(yourpasswordgoeshere)') in your mysql database to keep passwords in encrypted state. e.g. UPDATE user SET clear=ENCRYPT('mypassword') where clear=mypassword;


BTW I don't see what PAM is doing in the virtual mail system on the IMAP, POP3 and SMTP connections when SASL is authenticating it already.
Back to top
View user's profile Send private message
Adamal
Apprentice
Apprentice


Joined: 05 Dec 2003
Posts: 264
Location: California

PostPosted: Fri Sep 17, 2004 12:16 am    Post subject: Reply with quote

Solution_9 wrote:
This should be a simple question. Do i need to start courier-imapd for courier imapd-ssl to work? Im using Evolution, and i cannot connect to IMAP unless courier-imapd is running. Should this be happening? I have tried using domainname.com:993 for host also, but this does not work. When i telnet into localhost under port 143, i can see a bunch of information on IMAP. Now when i telnet into localhost under port 993, i get in, but i do not see any info on IMAP.

Also, I cannot *succesfully* send or recieve any email. When i try to send something, it shows it going through, but never actually reaches its destination.

Leave the second problem to be fixed at a later time. hehe.


For your first question yes you need to have courier-imapd running its the imap server. For the second one you'll need to play with your postfix configuration. I havn't given enough info to know what might be causing it.
_________________
Cry Havoc and Let Slip the dogs of War!
Back to top
View user's profile Send private message
Adamal
Apprentice
Apprentice


Joined: 05 Dec 2003
Posts: 264
Location: California

PostPosted: Fri Sep 17, 2004 12:20 am    Post subject: Reply with quote

Solution_9 wrote:
Do you need to use fetchmail if you use an email client? Like is fetchmail just used for a console based mail retriever?


Fetchmail downloads mail from other pop3 servers into your local mail account. You then use imap to host those files. If that is correct then yes you will need fetchmail. Now if your using your mail client to talk directly to the pop3 servers then no and then what is the point of running imapd.
_________________
Cry Havoc and Let Slip the dogs of War!
Back to top
View user's profile Send private message
Solution_9
Guru
Guru


Joined: 22 Jun 2003
Posts: 311

PostPosted: Fri Sep 17, 2004 12:25 am    Post subject: Reply with quote

Well there is more reason to run IMAP then what you said. But im not using it for saving pop3 email. Im using it so my email isn't stored locally.
_________________
"The X server has to be the biggest program I've ever seen that doesn't do anything for you."
- Ken Thompson
Back to top
View user's profile Send private message
tms
n00b
n00b


Joined: 26 Mar 2004
Posts: 31

PostPosted: Fri Sep 17, 2004 1:56 am    Post subject: Reply with quote

How can you use IMAP to store emails from pop3 in a SQL database? I would prefer if the users were virtual too
Back to top
View user's profile Send private message
Solution_9
Guru
Guru


Joined: 22 Jun 2003
Posts: 311

PostPosted: Fri Sep 17, 2004 2:55 am    Post subject: Reply with quote

From my knowledge
You can setup fetchmail to recieve the pop3 emails, and put them in the maildir folder. So everything is on the server. Every email message is accessible from anywhere, providing you have a method for loging into you account.
_________________
"The X server has to be the biggest program I've ever seen that doesn't do anything for you."
- Ken Thompson
Back to top
View user's profile Send private message
tms
n00b
n00b


Joined: 26 Mar 2004
Posts: 31

PostPosted: Fri Sep 17, 2004 10:09 am    Post subject: Reply with quote

Solution_9: My previous setup was local accounts storing mail in each users home directory, providing IMAP access.

To be honest, this is a very clumsy setup when the user shouldnt have shell access :P hence why I wish to create virtual users and preferably store the emails in a database.
Too bad there are no howto's on the subject (virtual mailhosting guide is pretty close though)
Back to top
View user's profile Send private message
newbie_gentoo
Apprentice
Apprentice


Joined: 04 Jul 2004
Posts: 189

PostPosted: Sat Sep 18, 2004 1:17 am    Post subject: Reply with quote

Just finished your HowTo, and got it to work! Thanks for this great document!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 25, 26, 27  Next
Page 20 of 27

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum