Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Email System For The Home Network - Version 2.1
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 22, 23, 24, 25, 26, 27  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
tkhobbes
Guru
Guru


Joined: 12 Nov 2004
Posts: 367
Location: Switzerland

PostPosted: Tue Mar 01, 2005 3:01 pm    Post subject: Reply with quote

Hi all

rpmohn wrote:

Deleting the email accounts, closing evolution, then creating the email accounts all over again solved the problem. I'll never hear the end of this from my wife. :( :x :(
-RPM


OK - could you give me the exact steps you performed?
I mean: You created a new certificate - how did you do that (I mean, basically I know how to do this, but apparently, it did not work...)
And: what settings do you use with Evolution now?

Thanks a lot!
_________________
My systems and some screenshots: http://www.hobbes.ch/techie/
My Gentoo client installation page: http://www.hobbes.ch/techie/gentoo-client/
My Gentoo Server installation: http://www.hobbes.ch/category/server
Back to top
View user's profile Send private message
rpmohn
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2003
Posts: 116
Location: Vermont

PostPosted: Tue Mar 01, 2005 10:38 pm    Post subject: Reply with quote

tkhobbes wrote:
OK - could you give me the exact steps you performed?
I mean: You created a new certificate - how did you do that (I mean, basically I know how to do this, but apparently, it did not work...)
And: what settings do you use with Evolution now?

Sure thing. I did several things that did not solve the problem, but you may want to try them as necessary. First was to unmerge / emerge evolution. Then I tried creating a new certificate by verifying my entries in the [req_dn] section of /etc/courier-imap/imapd.cnf and then running mkimapdcert while in the /etc/courier-imap directory. Neither of those fixed the problem.

What fixed the problem was to
1. Startup evolution and go to Tools/Settings...
2. From there, you highlight your email account and press Remove
3. Then you close evolution down
4. When you start it up again, enter your email account settings exactly as before
5. The key points are to choose the IMAP Server type for receiving mail, and to use SSL

Let me know if it works! -RPM
Back to top
View user's profile Send private message
tkhobbes
Guru
Guru


Joined: 12 Nov 2004
Posts: 367
Location: Switzerland

PostPosted: Fri Mar 04, 2005 9:51 am    Post subject: Reply with quote

Funny - I re-created the account, it works now... :)

Well, don't bother WHY - main thing is, it DOES work... :)

thanks
_________________
My systems and some screenshots: http://www.hobbes.ch/techie/
My Gentoo client installation page: http://www.hobbes.ch/techie/gentoo-client/
My Gentoo Server installation: http://www.hobbes.ch/category/server
Back to top
View user's profile Send private message
bubbas
n00b
n00b


Joined: 29 Dec 2003
Posts: 36
Location: Germany

PostPosted: Sun Mar 06, 2005 6:48 pm    Post subject: update bogotrainer-2.1.0 Reply with quote

Updated the bogotrainer2 script to Version 2.1.0

06-03-2005
Version 2.1 released
* moved md_bgt.py to md_output.py
* added more tests for checking if all needed directories exists
* moved directory tests to md_dirtest.py, for more clarity
* added support for imap directories containing whitespaces
* fixed broken specific Hamfolder (.Ham) support
* fixed missing import sys in md_output.py

Read my posting here

Thx to Merlin-TC for pointing out the problem with whitespaces!

bye

vale[/url]
Back to top
View user's profile Send private message
slestak
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jun 2003
Posts: 115

PostPosted: Mon Mar 07, 2005 8:21 pm    Post subject: Reply with quote

for anyone having troubles with the courier-authlib conversion, just try rebooting. I spent most of the afternoon trying this, looking at that, rebooted and it worked fine.
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Sat Mar 19, 2005 8:00 pm    Post subject: Re: update bogotrainer-2.1.0 Reply with quote

bubbas wrote:
Updated the bogotrainer2 script to Version 2.1.0

06-03-2005
Version 2.1 released
...
* added support for imap directories containing whitespaces


Single quotes in imap directory names cause problems :(

MarkG

PS I like the scripts output :)
Back to top
View user's profile Send private message
bubbas
n00b
n00b


Joined: 29 Dec 2003
Posts: 36
Location: Germany

PostPosted: Sat Mar 19, 2005 8:46 pm    Post subject: Reply with quote

hi MarkG,

can you post an example of such an foldername please?

thank you for contributing

bye

vale
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Sat Mar 19, 2005 10:25 pm    Post subject: Reply with quote

bubbas wrote:
hi MarkG,
can you post an example of such an foldername please?

Code:
Sarah's Notes

I've just discovered '&' characters are a problem, as in:
Code:
Sue & Dean

the actual directory name in .maildir for this one turns out to be
Code:
.Sue &- Deean


MarkG
Back to top
View user's profile Send private message
bubbas
n00b
n00b


Joined: 29 Dec 2003
Posts: 36
Location: Germany

PostPosted: Sat Mar 19, 2005 11:01 pm    Post subject: Reply with quote

thank you!

You are right this doesnt work. I will look at it after tuesday!

cu

bubbas
Back to top
View user's profile Send private message
bubbas
n00b
n00b


Joined: 29 Dec 2003
Posts: 36
Location: Germany

PostPosted: Tue Mar 22, 2005 6:32 pm    Post subject: Reply with quote

Updated the bogotrainer2 script to Version 2.1.1

22-03-2005
Version 2.1.1
* fix for special characters in imap folder names

Read my posting here

Thx to MarkG for pointing out this problem!

bye

vale
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Tue Mar 22, 2005 10:26 pm    Post subject: Reply with quote

Ok, the fix for special characters in folder names seems to work.

I'm not using the script at the moment for a few reasons:

    i) For Historic reasons I have Multiple Spam Folders, the script only allows for one Spam folder. I guess I need to throw out some spam.

    ii) The script doesn't seem to like running as a cron job. I think its something to do with the TERM Environment variable. I have a hacked version of the original scrip that has no output when there is nothing to do so I only get an cron email when something happens. It would be nice if the script had a quiet option to turn off that lovely output when used in a cron job.

    iii) The script is very slow to generate the initial wordlist.db. I have a years worth of Spam ~20,000 emails and a similar amount of ham mails, which I used to rebuild the wordlist.db. As yet I have not had the patients to let the script run to completion (I run it in a 1.2GHz VIA C3 MiniITX board). To rebuild my wordlist.db I used bogofilter -B (bluk mode) which is a lot quicker than classifying mails individually. The script should probably be updated to use this technique.

I hope these suggestions are useful

MarkG
Back to top
View user's profile Send private message
rpmohn
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2003
Posts: 116
Location: Vermont

PostPosted: Wed Mar 23, 2005 4:28 am    Post subject: Reply with quote

I've been using this setup for over a year now and it's great! But I still have one problem. I can't seem to get a simple perl script using either Net::SMTP or Net::SMTP_auth to relay email outside my network! I've tried many things, but I always get the same error:
Code:
Mar 22 23:04:08 porcupine postfix/smtpd[3760]: NOQUEUE: reject: RCPT from porcupine.adelphia.net[192.168.1.2]: 554 <porcupine.adelphia.net[192.168.1.2]>: Client host rejected: Access denied; from=<tenshi> to=<rpmohn> proto=ESMTP helo=<localhost.localdomain>

Here is the Net::SMTP code I'm testing:
Code:
#!/usr/bin/perl -w

use Net::SMTP;

$smtp = Net::SMTP->new(192.168.1.2);

if (!$smtp->auth('rpmohn, 'passwd')) {print "auth failed";}

$smtp->mail(tenshi);
$smtp->to(rpmohn@external.com);

$smtp->data();
$smtp->datasend("To: Me\n");
$smtp->datasend("\n");
$smtp->datasend("A simple test message\n");
$smtp->dataend();

$smtp->quit;

And here's the Net::SMTP_auth code I'm testing:
Code:
#!/usr/bin/perl -w

use Net::SMTP_auth;
#$method="LOGIN";
$method="PLAIN";
#$method="CRAM-MD5";

$smtp = Net::SMTP_auth->new(192.168.1.2);

if (!$smtp->auth("$method", 'rpmohn, 'passwd')) {print "auth failed";}

$smtp->mail(tenshi);
$smtp->to(rpmohn@external.com);

$smtp->data();
$smtp->datasend("To: Me\n");
$smtp->datasend("\n");
$smtp->datasend("A simple test message\n");
$smtp->dataend();

$smtp->quit;

No matter what I try, I get auth failed printed out and the above error in messages. Note that the scripts DO work if it is an internal email address even though auth failed still prints out.

Any advise appreciated!
Thanks! -RPM
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Wed Mar 23, 2005 6:18 am    Post subject: Reply with quote

rpmohn wrote:
I've tried many things, but I always get the same error:
Code:
Mar 22 23:04:08 porcupine postfix/smtpd[3760]: NOQUEUE: reject: RCPT from porcupine.adelphia.net[192.168.1.2]: 554 <porcupine.adelphia.net[192.168.1.2]>: Client host rejected: Access denied; from=<tenshi> to=<rpmohn> proto=ESMTP helo=<localhost.localdomain>




What are your smtpd_client_restrictions settings in the postfix/main.cf



MarkG
Back to top
View user's profile Send private message
DrWilken
Apprentice
Apprentice


Joined: 12 Dec 2003
Posts: 219
Location: Oelsted ("BeerPlace"), Denmark

PostPosted: Wed Mar 23, 2005 10:29 am    Post subject: smtpd_client_restrictions Reply with quote

I've had a few problems with the smtpd_client_restrictions line in postfix main.cf (/etc/postfix/main.cf).

When I comment it out it all works, but then I guess it's not authenticated through SASL??

If I leave as the guide suggests:
Code:

stmpd_client_restrictions = permit_sasl_authenticated, reject

I can't receive mails from outside. I get "... Client host rejected: Access denied ..."

If I edit it to:
Code:

smtpd_client_restrictions  = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination

it works perfectly fine.... BUT:

What have I actually done? In the guide You use reject NOT reject_unauth_destination.

BTW my smtpd_recipient_restrictions line is the same as the smtpd_client_restrictions above...
_________________
-=[DrWilken]=-
ASUS AT5IONT-I (64bit Dual Core Atom D525 processor with Nvidia ION(2) GPU) running Gentoo Linux... Latest and Greatest... :)
tux-power.dk
Back to top
View user's profile Send private message
rpmohn
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2003
Posts: 116
Location: Vermont

PostPosted: Wed Mar 23, 2005 1:30 pm    Post subject: Reply with quote

MarkG wrote:
rpmohn wrote:
I've tried many things, but I always get the same error:
Code:
Mar 22 23:04:08 porcupine postfix/smtpd[3760]: NOQUEUE: reject: RCPT from porcupine.adelphia.net[192.168.1.2]: 554 <porcupine.adelphia.net[192.168.1.2]>: Client host rejected: Access denied; from=<tenshi> to=<rpmohn> proto=ESMTP helo=<localhost.localdomain>




What are your smtpd_client_restrictions settings in the postfix/main.cf


Just as in the guide:
Code:
smtpd_client_restrictions = permit_sasl_authenticated, reject

But I must admit that I don't fully understand this line...

Any insight? -RPM
Back to top
View user's profile Send private message
bubbas
n00b
n00b


Joined: 29 Dec 2003
Posts: 36
Location: Germany

PostPosted: Wed Mar 23, 2005 1:34 pm    Post subject: Reply with quote

@MarkG,

thx for the suggestions. Here it works with a cronjob, just like i wrote in the howto. But sure its a nice idea to disable output. I will try to implement some of your sugestions. But this will take some time cause i am a little busy at the moment.

but i really apreciate that you post your experience and all this suggestions!

cu

vale
Back to top
View user's profile Send private message
rpmohn
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2003
Posts: 116
Location: Vermont

PostPosted: Wed Mar 23, 2005 1:55 pm    Post subject: Re: smtpd_client_restrictions Reply with quote

DrWilken wrote:
If I edit it to:
Code:

smtpd_client_restrictions  = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination

it works perfectly fine.... BUT:

What have I actually done? In the guide You use reject NOT reject_unauth_destination.

BTW my smtpd_recipient_restrictions line is the same as the smtpd_client_restrictions above...

This sounds promising. I'll give it a try, but I would have the same question: What have I actually done?
EDIT: This seems to have worked. I made the change to my smtpd_client_restrictions only and now I can sent out emails from the commandline to external sites. Why is this change necessary?
Thanks! -RPM
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Wed Mar 23, 2005 5:24 pm    Post subject: Re: smtpd_client_restrictions Reply with quote

DrWilken wrote:

If I edit it to:
Code:

smtpd_client_restrictions  = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination

I would have thought
Code:

smtpd_client_restrictions  = permit_sasl_authenticated, permit_mynetworks, reject

would have been correct, I don't see reject_unauth_destination documented in documentation on smtpd_client_restrictions documentation.

This dosnt answer why rpmohn perl scripts require the permit_my_networks setting. I guess that the the perl script is failing to authenticate via sasl correctly and being allowed as it passes the my_networks check. Anyone understand the Perl script?

MarkG
Back to top
View user's profile Send private message
rpmohn
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2003
Posts: 116
Location: Vermont

PostPosted: Wed Mar 23, 2005 6:59 pm    Post subject: Re: smtpd_client_restrictions Reply with quote

MarkG wrote:
I would have thought
Code:

smtpd_client_restrictions  = permit_sasl_authenticated, permit_mynetworks, reject

would have been correct, I don't see reject_unauth_destination documented in documentation on smtpd_client_restrictions documentation.

You are correct! The reject_unauth_destination restriction is only documented for smtpd_recipient_restrictions, which, BTW, I don't have set at all.
Quote:
This dosnt answer why rpmohn perl scripts require the permit_my_networks setting. I guess that the the perl script is failing to authenticate via sasl correctly and being allowed as it passes the my_networks check. Anyone understand the Perl script?

I understand the Perl script well enough, but don't know why Postfix is rejecting my authorization attempts. Is there a debug mode for Postfix that would show more info?
-RPM
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Thu Mar 24, 2005 10:44 am    Post subject: Slightly Off Topic, Net::SMTP_auth Reply with quote

rpmohn wrote:

Code:
#!/usr/bin/perl -w

use Net::SMTP_auth;

Is Net::SMTP_auth in an ebuild? If it is I cant find it.

I've go a quite couple of days so I thought I'd brush up on my perl...

MarkG


Last edited by MarkG on Thu Mar 24, 2005 10:45 am; edited 1 time in total
Back to top
View user's profile Send private message
rpmohn
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2003
Posts: 116
Location: Vermont

PostPosted: Thu Mar 24, 2005 2:10 pm    Post subject: Re: Slightly Off Topic, Net::SMTP_auth Reply with quote

MarkG wrote:
rpmohn wrote:

Code:
#!/usr/bin/perl -w

use Net::SMTP_auth;

Is Net::SMTP_auth in an ebuild? If it is I cant find it.

Nope. Run the cpan command and then from the cpan prompt type in install Net::SMTP_auth. Let me know if you find anything. I won't have a chance to play with this again until after this weekend. :(
Thanks! -RPM
Back to top
View user's profile Send private message
MarkG
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2002
Posts: 90
Location: Dorset, UK

PostPosted: Fri Mar 25, 2005 1:47 pm    Post subject: Reply with quote

rpmohn wrote:
I always get the same error:
Code:
Mar 22 23:04:08 porcupine postfix/smtpd[3760]: NOQUEUE: reject: RCPT from porcupine.adelphia.net[192.168.1.2]: 554 <porcupine.adelphia.net[192.168.1.2]>: Client host rejected: Access denied; from=<tenshi> to=<rpmohn> proto=ESMTP helo=<localhost.localdomain>


I've had a play with the perl scripts and it all seems to work for me. I had to modify them as there was a missing quote on the user name as originaly posted (thats not the problem I hope!). I have tried running the scripts both locally on the mail server and on another client machine on my network. Both give the same results except of the 'connect from unknown[192.168.99.4]' problem see below.

My smtpd_client_restrictions are
Code:
smtpd_client_restrictions = permit_sasl_authenticated, permit_auth_destination, reject
which should give the same result default setting in this guide as I'm not sending to an authorised destination.

The plane Net::SMTP script:
Code:
#!/usr/bin/perl -w

use Net::SMTP;

$smtp = Net::SMTP->new("mail.homedomain");

$smtp->mail("markg\@porthos.homedomain");
$smtp->to("markg\@someware.co.uk");
$smtp->data();
$smtp->datasend("To: Me\n");
$smtp->datasend("\n");
$smtp->datasend("A simple test message\n");
$smtp->datasend("With no auth\n");
$smtp->dataend();

$smtp->quit;

I get the expected Access denied, as there is no authorisation
Code:
Mar 25 13:09:44 porthos postfix/smtpd[29117]: connect from unknown[192.168.99.4]
Mar 25 13:09:44 porthos postfix/smtpd[29117]: NOQUEUE: reject: RCPT from unknown[192.168.99.4]: 554 <unknown[192.168.99.4]>: Client host rejected: Access denied; from=<markg@porthos.homedomain> to=<markg@someware.co.uk> proto=ESMTP helo=<localhost.localdomain>
Mar 25 13:09:44 porthos postfix/smtpd[29117]: disconnect from unknown[192.168.99.4]

The Net::SMTP_auth script:
Code:
#!/usr/bin/perl -w

use Net::SMTP_auth;

$method="PLAIN";

$smtp = Net::SMTP_auth->new("mail.homedomain");

#print ($smtp->auth_types());

if (!$smtp->auth("$method", 'markg', 'passwd')) {print "auth failed";}

$smtp->mail("markg\@porthos.homedomain");
$smtp->to("markg\@someware.co.uk");
$smtp->data();
$smtp->datasend("To: Me\n");
$smtp->datasend("\n");
$smtp->datasend("A simple test message\n");
$smtp->datasend("With Auth PLAIN\n");
$smtp->dataend();

$smtp->quit;

Works with no errors:
Code:
Mar 25 13:16:56 porthos postfix/smtpd[29158]: connect from unknown[192.168.99.4]
Mar 25 13:16:56 porthos postfix/smtpd[29158]: 204E57E7: client=unknown[192.168.99.4], sasl_method=PLAIN, sasl_username=markg
Mar 25 13:16:56 porthos postfix/cleanup[29159]: 204E57E7: message-id=<20050325131656.204E57E7@porthos.homedomain>
Mar 25 13:16:56 porthos postfix/qmgr[29027]: 204E57E7: from=<markg@porthos.homedomain>, size=394, nrcpt=1 (queue active)
Mar 25 13:16:56 porthos postfix/smtpd[29158]: disconnect from unknown[192.168.99.4]


The only strange thin is this:
Code:
Mar 25 13:16:56 porthos postfix/smtpd[29158]: warning: smtpd_peer_init: 192.168.99.4: address not listed for hostname porthos.homedomain
Mar 25 13:16:56 porthos postfix/smtpd[29158]: connect from unknown[192.168.99.4]
as I'm running the script on porthos [192.168.99.4] which is the mail server running postfix and dns, which normally has no problem resolving its own name! I think this is unrelated though.

I guess this doesn't help, as it all points to a problem with your server configuration, but you know that :?

MarkG
Back to top
View user's profile Send private message
Strowi
l33t
l33t


Joined: 19 Aug 2003
Posts: 655
Location: Bonn

PostPosted: Sat Mar 26, 2005 1:14 pm    Post subject: Reply with quote

hi,

this guide is really great! After struggling with qmail for a long time, this worked fine after like 1 hour.;)

But i have a question left: Is it somehow possible to make fetchmail/sa-learn run globally? I would like to make fetchmail run for every user, without the need of user-interaction (well, users only specify .fetchmailrc, but not the cronjob).

Another question that came to my mind: Is there a mail-client who can manage server-side filtering rules (i suppose no, but please correct me;))?
_________________
--
Linux & such ...
http://blog.hasnoname.de
Back to top
View user's profile Send private message
jack_mort
Apprentice
Apprentice


Joined: 30 Jan 2003
Posts: 167

PostPosted: Mon Mar 28, 2005 1:41 pm    Post subject: Reply with quote

Hi,

I followed this guide to install a mail server and everything is OK, except pop access !
With IMAP, I get my mails in thunderbird without any problem, but with pop3, I don't get anything... I verified the courier-pop daemon is up and running, and everything seems OK. Anyone with an idea ?
Back to top
View user's profile Send private message
MasterC
Apprentice
Apprentice


Joined: 25 May 2003
Posts: 150
Location: Woods Cross, UT

PostPosted: Mon Mar 28, 2005 1:58 pm    Post subject: Reply with quote

Port related?

Any logs you can post with ANY error message?

COol
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 22, 23, 24, 25, 26, 27  Next
Page 23 of 27

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum