Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
MOL SyncRead: error [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
NumaSan
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2003
Posts: 100
Location: Copenhagen

PostPosted: Mon Jun 25, 2007 10:38 pm    Post subject: MOL SyncRead: error [SOLVED] Reply with quote

Hola all,

I've just bought an iBook G4 12" (1GHz, 768MB RAM, Radeon Mobility 9200), and promptly installed Gentoo on it. Everything has been a positive experience so far, with no compile errors, and a nice E17 on top. Of course, running MOL is a given on this iBook, and I followed the instructions from here:
http://mac-on-linux.sourceforge.net/wiki/index.php/InstallingMacOSX

Since I installed Gentoo first on a clean disk, I made an 8GB disk image with 'mol-img' at /var/lib/mol/osx.img, and added this path as a blkdev in /etc/mol/molrc.osx (with the '-rw -boot' flags). Installation went fine, when running 'startmol -X' with the OSX 10.4.9 DVD, the 8GB image was found with Disk Utility, and it completed the install without errors (had to cut the startmol command, since it stalled at "reboot now", though).

Problem is, when I run 'startmol -X' now (as root) without the DVD, I get this:
Code:
Mac-on-Linux 0.9.72 [Jun 22 2007 17:28]
Copyright (C) 1997-2004 Samuel Rydh
Starting MOL session 1
Running in PowerPC 7400 mode, 512 MB RAM
Timebase: 18.43 MHz, Bus: 73.72 MHz, Clock: 1066 MHz
Using USB mouse on /dev/input/mice
OHCI USB controller registered
Could not connect to X server
Fullscreen video on VT 8.
Could not open '/var/lib/mol/console.kbd'
Video driver(s): [console_video]

     640* 480, depth 8,15,32   { 72.1 } Hz
     800* 600, depth 8,15,32   { 60.3, 70.0, 72.1, 74.9 } Hz
    1024* 768, depth 8,15,32   { 60.0, 70.0, 75.0 } Hz

Autoswitching to console
DHCP nameserver exported: 89.150.129.4
Ethernet Interface 'tun-<tun1>' @ 00:00:0D:EA:DB:EE

    ip/mask: 192.168.41.2/255.255.255.0  gw: 192.168.41.1
    broadcast: 192.168.41.255  nameserver: 192.168.41.1

ALSA sound driver (device 'default')

    CD    /dev/cdrom       CD/DVD         <read-only>   ------
    Disk  /var/lib/mol/o.. - Partioned -  <rw> 8192 MB BOOT

SCSI devices:

    SCSI  /dev/cdrom       [CDROM/DVD driver]


>> ==================================================
>> MacOS X Boot Loader 0.9.72
>> SyncRead: error
>> SyncRead: error
>> SyncRead: error
>> SyncRead: error


I've googled a lot after it, but only found people having an output with 2 "SyncRead: error" and ending with "--> Boot loader failure: No bootable disk found", but I only get those 4 "SyncRead: error"..?

Starting with the DVD, the output looks like this:
Code:
..SNIP...
>> ==================================================
>> MacOS X Boot Loader 0.9.72
>> SyncRead: error
>> SyncRead: error
>> SyncRead: error
>> SyncRead: error
>> Candidate boot volume: /mol-scsi/disk@0:2
>> /mol-scsi/disk@0:2,\mach_kernel (4313028 bytes)
>> /mol-scsi/disk@0:2,\System\Library\Extensions.mkext
>> ==================================================

<*> SCSI driver v1.03
<*> IRQ vectorCanBeShared 3
<*> IRQ vectorCanBeShared 4
<*> IRQ vectorCanBeShared 2
<*> IRQ vectorCanBeShared 6
<*> Block Driver v1.1
<*> IRQ vectorCanBeShared 24


Why can't MOL see my disk image as a "Candidate boot volume"?

Here is the (relevant) part of dmesg:
Code:
MOL 0.9.72 kernel module loaded
PM: Adding info for No Bus:mol
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
PM: Adding info for No Bus:tun
PM: Adding info for No Bus:vcs8
PM: Adding info for No Bus:vcsa8
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (6144 buckets, 49152 max)

I'm running Linux 2.6.20-gentoo-r5

Any help is much appreciated!
_________________
--- checking for native Win32 platform... no


Last edited by NumaSan on Tue Jun 26, 2007 11:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Jun 26, 2007 10:51 am    Post subject: Reply with quote

Hmm, that's odd. Can I see the output of emerge --info?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
NumaSan
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2003
Posts: 100
Location: Copenhagen

PostPosted: Tue Jun 26, 2007 4:44 pm    Post subject: Reply with quote

Hey JoseJX,

This is the output:
Code:
Portage 2.1.2.7 (default-linux/ppc/ppc32/2007.0, gcc-4.1.2, glibc-2.5-r3, 2.6.20-gentoo-r5 ppc)
=================================================================
System uname: 2.6.20-gentoo-r5 ppc 7447A, altivec supported
Gentoo Base System release 1.12.9
Timestamp of tree: Mon, 25 Jun 2007 22:50:01 +0000
ccache version 2.4 [enabled]
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="ppc"
ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ARCH="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CCACHE_DIR="/var/tmp/ccache/"
CCACHE_SIZE="1G"
CFLAGS="-O2 -mcpu=powerpc -mtune=powerpc -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
CHOST="powerpc-unknown-linux-gnu"
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-O2 -mcpu=powerpc -mtune=powerpc -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_WARNING_DELAY="10"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -P ${DISTDIR} ${URI}"
GCC_PATH="/usr/powerpc-unknown-linux-gnu/gcc-bin/4.1.2"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
G_BROKEN_FILENAMES="1"
G_FILENAME_ENCODING="UTF-8"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/binutils-data/powerpc-unknown-linux-gnu/2.17/
info:/usr/share/gcc-data/powerpc-unknown-linux-gnu/4.1.2/info"
INPUT_DEVICES="keyboard mouse evdev"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;
41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;
31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;
31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;
31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;
35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;
35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;
35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;
35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;
32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;
36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAIL="/var/mail/root"
MAKEOPTS="-j2"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/powerpc-unknown-linux-gnu/2.17/
man:/usr/share/gcc-data/powerpc-unknown-linux-gnu/4.1.2/man"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/powerpc-unknown-linux-gnu/gcc-bin/4.1.2"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/enlightenment"
PWD="/root"
PYTHONPATH="/usr/lib/portage/pym"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -P ${DISTDIR} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/powerpc-unknown-linux-gnu/gcc-bin/4.1.2"
RPMDIR="/usr/portage/rpm"
SHELL="/bin/bash"
SHLVL="1"
SSH_CLIENT="192.168.1.33 56947 22"
SSH_CONNECTION="192.168.1.33 56947 192.168.1.37 22"
SSH_TTY="/dev/pts/2"
STAGE1_USE="nptl nptlonly unicode"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="Eterm"
USE="X a52 aac acl alsa altivec berkdb bitmap-fonts bluetooth cdr cli cracklib crypt curl dbus dri dvd dvdread encode fftw flac fortran gdbm gif gpm gtk2 iconv ieee1394 imagemagick imlib isdnlog jpeg libg++ mad midi mmap mp3 mpeg mudflap ncurses nptl nptlonly ogg opengl openmp pcre pdflib perl png posix ppc pppd python radeon readline reflection sdl session spl ssl svg tcpd theora tiff truetype truetype-fonts type1-fonts unicode usb vorbis wifi x264 xml xorg xv xvid zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon fbdev"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal"
VIDEO_CARDS="radeon fbdev"
XARGS="xargs -r"
_="/usr/bin/emerge"


I'm wondering if it can have something to do with the supplied yaboot.conf in /etc/mol/, that maybe one has to specify where to boot the Mac "disk", other than the '-boot' flag i molrc.osx? But I'm just guessing..

Edit: Ok, tried disabling all the blockdevices, but the disk image, in molrc.osx.
This post made me think about the boot-strap partition on /dev/hda2, so I uncommented that line, too. Saving the file, and running 'startmol -X' results in the "--> Boot loader failure: No bootable disk found" error, that I found examples of on google. Now, after I had disabled /dev/hda2 in molrc.osx, it still returns the boot loader failure, where before it just hang (4 x SyncRead: error), so yay, progress..! Or?

Which .conf does the "MacOS X Boot Loader 0.9.27" look for?

Thanks!
_________________
--- checking for native Win32 platform... no


Last edited by NumaSan on Tue Jun 26, 2007 6:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Jun 26, 2007 5:51 pm    Post subject: Reply with quote

Hmm, that's pretty strange. Can you try with a smaller disk image (say 3GB?)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
NumaSan
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2003
Posts: 100
Location: Copenhagen

PostPosted: Tue Jun 26, 2007 9:32 pm    Post subject: Reply with quote

Wow, that was nice. I made a new disk image on 4GB at /opt/X.img, and started the installation again. It went completely fluid, with the reboots shutting down nicely - the post-installation went perfect as well. I also got a chance to clean out all the printer-drivers, and most languages, so that's nice. Feels good to finally shift between Linux and OSX with F7 & F8 :)

Guess MOL doesn't like >4gig partitions? Glad that it worked, anyway!

Now there's only two minor problems I have with OSX on MOL: The sound stutters a little, and I have to figure out how I shutdown OSX :oops:

Thanks, JoseJX!
_________________
--- checking for native Win32 platform... no
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Jun 27, 2007 12:18 pm    Post subject: Reply with quote

Well, it should work with >4GB, I'll have to look into that some more, thanks for letting me know. The sound stuttering is a known issue related to the overhead of copying the sound between the VM and the sound device. It's being worked on. :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum