Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PS3 kboot missing /dev/sr0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
cancech
Apprentice
Apprentice


Joined: 22 Dec 2004
Posts: 171

PostPosted: Sun Jul 15, 2007 3:10 am    Post subject: PS3 kboot missing /dev/sr0 Reply with quote

I've been trying to install Gentoo onto my PS3 according to this guide using this live cd and right now I can't get anywhere because kboot doesn't have a /dev/sr0. A little backgournd information... first I installed YDL and then after about two weeks I installed Ubuntu (in both cases the dev node for the CD drive "disapeared" after a short while... about a week of very light usage). So now I decided to install Gentoo, I installed the otheros.cdonly to my PS3 (after renaming it to otheros.bld so that the PS3 would recognize it) boot into "Other OS", get the kboot prompt and that's as far as I can get. I've tried hitting tab to cycle through the options, but I don't have any options. I go to the kboot console and there is a link for /dev/cdrom, but that's just pointing to /dev/sr0... which doesn't exist. I then tried again put back the Ubuntu kboot and this wouldn't do anything either, not even boot Ubuntu which was already installed. Thinking that it was a problem with the ubuntu install interfering I renamed the installed Ubuntus kboot to backup.kboot.conf, rebooted... no change. I then went and did 3-4 quick formats (tried after each with no change) and finally one full format with no change what so ever.

I'm stumped, I've no idea what the problem is or even could be. I also tried installing from my USB key (copied the contents of the live cd to it) tried installing from there, and that gave me a UDF error of somesorts (UDF filesystem missing I think it was).

Any ideas what it could be? I'm pretty sure that it's not the old linux installs acting up, since there aren't any of those on the HDD anymore. Could it be a corrupted kboot?

Thanks in advance :)
Back to top
View user's profile Send private message
cancech
Apprentice
Apprentice


Joined: 22 Dec 2004
Posts: 171

PostPosted: Sun Jul 15, 2007 6:58 pm    Post subject: Reply with quote

The drive works perfectly in the XMB (watching a movie as I write this) and I'll try using one of the other ones bootloaders.
Back to top
View user's profile Send private message
cancech
Apprentice
Apprentice


Joined: 22 Dec 2004
Posts: 171

PostPosted: Sun Jul 15, 2007 10:56 pm    Post subject: Reply with quote

I tried using otheros.default and also the otheros as supplied by YDL. Neither had /dev/sr0, otheros.default didn't have any options to list through, the YDL one did but they didn't work ("install" complained about not finding the kernel on /dev/sr0).
Back to top
View user's profile Send private message
cancech
Apprentice
Apprentice


Joined: 22 Dec 2004
Posts: 171

PostPosted: Mon Jul 16, 2007 2:57 am    Post subject: Reply with quote

I restored, did quick format (10GB to other OS), installed otheros.cdonly from the gentoo minimal live cd, boot into other os...... no change. /dev/sr0 is still missing, there are no options for me to list through in kboot.

Is there anyway of uninstalling/deleting/clearing out the otheros which is installed? Becuase a restore evidentally doesn't do that (I tried booting into other os right after restoring and the old one was still there :?)
Back to top
View user's profile Send private message
cancech
Apprentice
Apprentice


Joined: 22 Dec 2004
Posts: 171

PostPosted: Tue Jul 17, 2007 2:49 am    Post subject: Reply with quote

Dude, you make no sense :lol:

Turns out that it's something faulty with my PS3 directly. After booting into kboot my PS3 won't see the cd drive (hence /dev/sr0 missing) until I halt the system. Same thing with the XMB though it wasn't until now that I realized that the two things were related. After halting the system then it sees /dev/sr0 and I can then go ahead and install Gentoo..... won't for now, first I'll be giving Sony a call.

Thanks for the help!!
Back to top
View user's profile Send private message
saber850
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2004
Posts: 115
Location: NY

PostPosted: Sat May 31, 2008 1:23 pm    Post subject: Reply with quote

cancech wrote:
After booting into kboot my PS3 won't see the cd drive (hence /dev/sr0 missing) until I halt the system.


I'm having a similar problem, though I'm only trying to launch the Gentoo Live CD (not install it). I setup otheros, then reboot. The kernel messages are displayed and I'm brought to the kboot prompt. I tab to the 1080p image and hit enter, and I see some errors about missing /dev/sr0.

Any suggestions?
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5866

PostPosted: Sun Jun 01, 2008 3:40 am    Post subject: Reply with quote

Moved from Gentoo on Alternative Architectures to Gentoo on PPC.
_________________
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.

banned from #gentoo since sept 2017
Back to top
View user's profile Send private message
saber850
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2004
Posts: 115
Location: NY

PostPosted: Thu Jun 05, 2008 8:48 am    Post subject: Reply with quote

saber850 wrote:
I see some errors about missing /dev/sr0.


Looking into this further it turns out the errors were not about missing /dev/sr0, they were about I/O errors from /dev/sr0. This was enough info to lead me in the right direction. I remembered when burning the ISO that it did not fit cleanly onto a CD. The image is 725MB, while a CD supports up to 700MB. At the time I just enabled over-burn and burned it anyway. So the I/O errors were a result of having bogus and/or incomplete data on the disk.

I just burned the image to a DVD and it worked properly.

FWIW, to boot back to the GameOS, the command is 'ps3-boot-game-os', not 'boot-game-os'...at least for my version of otheros.bld.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum