Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] - Thanks! emerge -DNeva world
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 12 Feb 2006
Posts: 131
Location: West Sussex, UK

PostPosted: Thu Jul 19, 2007 8:45 am    Post subject: [solved] - Thanks! emerge -DNeva world Reply with quote

Hello Everyone,

I am taking the advice of Thomas who kindly helped me here.

When I try and kick off the emerge, it looks like I have a circular dependency between sys-apps/pam-login and sys-apps/shadow. Is PAM used by default? I don't know what shadow does.

What do you recommend to resolve this?

ebs / # emerge -DNeva world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild   R   ] sys-apps/portage-  USE="-build -doc -epydoc (-selinux)" LINGUAS="-pl" 0 kB
[ebuild     U ] sys-devel/gnuconfig-20070118 [20060227] 40 kB
[ebuild   R   ] virtual/libintl-0  0 kB
[ebuild   R   ] sys-devel/automake-wrapper-3-r1  0 kB
[ebuild   R   ] virtual/libiconv-0  0 kB
[ebuild     U ] dev-util/pkgconfig-0.21-r1 [0.20] USE="-hardened" 976 kB
[ebuild   R   ] sys-devel/autoconf-wrapper-4-r3  0 kB
[ebuild   R   ] app-misc/pax-utils-0.1.15  USE="-caps" 0 kB
[ebuild  N    ] dev-libs/gmp-4.2.1-r1  USE="-doc -nocxx" 1,686 kB
[ebuild   R   ] dev-util/ctags-5.5.4-r2  0 kB
[ebuild     U ] sys-apps/debianutils-2.17.5 [2.14.1-r1] USE="-static (-build%)" 0 kB
[ebuild   R   ] sys-apps/tcp-wrappers-7.6-r8  USE="ipv6" 113 kB
[ebuild   R   ] app-crypt/hashalot-0.3-r2  79 kB
[ebuild     U ] sys-apps/setarch-1.8 [1.0] 4 kB
[ebuild  N    ] dev-util/unifdef-1.20  65 kB
[ebuild   R   ] sys-apps/sandbox-1.2.17  0 kB
[ebuild  N    ] sys-libs/timezone-data-2007f  USE="nls" 343 kB
[ebuild   R   ] sys-process/cronbase-0.3.2  0 kB
[ebuild   R   ] dev-libs/libol-0.3.18  0 kB
[ebuild     U ] sys-apps/busybox-1.4.1-r2 [1.00-r4] USE="-debug -make-symlinks -savedconfig -static (-floppyboot%) (-netboot%)" 1,476 kB
[ebuild   R   ] sys-devel/patch-2.5.9  USE="-build -static" 198 kB
[ebuild     U ] app-arch/bzip2-1.0.4 [1.0.3-r5] USE="-static (-build%)" 822 kB
[ebuild     U ] app-arch/cpio-2.8 [2.6-r5] USE="nls" 728 kB
[ebuild     U ] sys-kernel/linux-headers-2.6.21 [2.6.11-r2] 4,287 kB
[ebuild  N    ] dev-libs/libpcre-6.6  USE="-doc" 545 kB
[ebuild  N    ] sys-apps/mktemp-1.5  0 kB
[ebuild     U ] sys-apps/sysvinit-2.86-r8 [2.86-r3] USE="(-ibm) (-selinux) -static (-bootstrap%) (-build%)" 0 kB
[ebuild     U ] net-misc/iputils-20060512 [021109-r3] USE="ipv6 -doc -static" 87 kB
[ebuild     U ] sys-libs/ncurses-5.6-r1 [5.4-r6] USE="-bootstrap -build -debug -doc -gpm* -minimal -nocxx -trace% -unicode" 2,353 kB
[ebuild     U ] app-shells/bash-3.2_p15-r1 [3.0-r12] USE="nls -afs% -bashlogger -vanilla% (-build%)" 0 kB
[ebuild     U ] sys-process/procps-3.2.7 [3.2.6] USE="(-n32)" 276 kB
[ebuild     U ] sys-apps/less-394 [385_p4-r2] USE="-unicode" 481 kB
[ebuild     U ] sys-libs/zlib-1.2.3-r1 [1.2.3] USE="(-build%)" 416 kB
[ebuild     U ] sys-devel/gcc-config-1.3.16 [1.3.12-r6] 0 kB
[ebuild   R   ] dev-libs/expat-1.95.8  USE="-test" 311 kB
[ebuild   R   ] sys-devel/gettext-0.16.1  USE="nls -doc -emacs -nocxx" 0 kB
[ebuild     U ] sys-apps/texinfo-4.8-r5 [4.8-r2] USE="nls -build -static" 1,487 kB
[ebuild     U ] sys-apps/sed-4.1.5 [4.1.4-r1] USE="nls -static (-bootstrap%) (-build%)" 781 kB
[ebuild   R   ] sys-devel/m4-1.4.9-r1  USE="nls -examples" 0 kB
[ebuild     U ] sys-libs/com_err-1.39 [1.38] USE="nls" 3,609 kB
[ebuild     U ] sys-devel/flex-2.5.33-r2 [2.5.33-r1] USE="nls -static" 680 kB
[ebuild     U ] sys-apps/findutils-4.3.7 [4.1.20-r2] USE="nls (-selinux) -static (-build%)" 1,766 kB
[ebuild     U ] sys-apps/grep-2.5.1a-r1 [2.5.1-r8] USE="nls pcre%* -static (-build%)" 516 kB
[ebuild     U ] dev-libs/popt-1.10.7 [1.7-r1] USE="nls" 712 kB
[ebuild     U ] app-arch/gzip-1.3.12 [1.3.5-r8] USE="nls -pic -static (-build%)" 452 kB
[ebuild     U ] sys-apps/net-tools-1.60-r12 [1.60-r11] USE="nls -static" 298 kB
[ebuild     U ] sys-apps/gawk-3.1.5-r3 [3.1.5] USE="nls (-build%)" 2,257 kB
[ebuild     U ] app-arch/tar-1.17 [1.15.1-r1] USE="nls -static (-build%) (-bzip2%*)" 1,839 kB
[ebuild     U ] app-editors/nano-2.0.6 [1.3.9] USE="ncurses nls -debug -justify -minimal -slang -spell* -unicode (-build%)" 1,285 kB
[ebuild     U ] sys-devel/make-3.81 [3.80-r4] USE="nls -static (-build%)" 1,125 kB
[ebuild     U ] sys-devel/bison-2.3 [1.875d] USE="nls -static" 1,055 kB
[ebuild     U ] sys-devel/binutils-config-1.9-r4 [1.8-r6] 0 kB
[ebuild     U ] sys-libs/ss-1.39 [1.38] USE="nls" 0 kB
[ebuild   R   ] net-misc/rsync-2.6.9-r2  USE="ipv6 -acl -static -xinetd" 0 kB
[ebuild   R   ] app-admin/syslog-ng-1.6.11-r1  USE="tcpd -hardened (-selinux) -static" 0 kB
[ebuild   R   ] sys-apps/which-2.16  123 kB
[ebuild     U ] sys-devel/binutils-2.17 [2.16.1] USE="nls -multislot (-multitarget) -test -vanilla%" 13,502 kB
[ebuild     U ] sys-fs/e2fsprogs-1.39-r2 [1.38-r1] USE="nls -static" 0 kB
[ebuild  NS   ] sys-libs/db-4.5.20_p2  USE="-bootstrap -doc -java -nocxx -tcl -test" 9,068 kB
[ebuild     U ] sys-devel/libperl-5.8.8-r1 [5.8.7] USE="berkdb -debug -gdbm -ithreads" 9,887 kB
[ebuild     U ] dev-lang/perl-5.8.8-r2 [5.8.7-r3] USE="berkdb -build -debug -doc -gdbm -ithreads -perlsuid (-minimal%)" 0 kB
[ebuild   R   ] sys-devel/autoconf-2.61  USE="-emacs" 0 kB
[ebuild   R   ] dev-perl/Locale-gettext-1.05  USE="(-minimal%)" 0 kB
[ebuild  N    ] perl-core/Test-Harness-2.64  70 kB
[ebuild     U ] app-admin/perl-cleaner-1.04.3 [1.01] 6 kB
[ebuild  N    ] perl-core/PodParser-1.35  96 kB
[ebuild     U ] sys-apps/util-linux-2.12r-r7 [2.12r-r2] USE="crypt nls perl -old-crypt (-selinux) -static (-pam%*)" 1,509 kB
[ebuild   R   ] sys-devel/autoconf-2.13  0 kB
[ebuild     U ] sys-apps/help2man-1.36.4 [1.33.1] USE="nls" 0 kB
[ebuild   R   ] sys-devel/automake-1.4_p6  0 kB
[ebuild   R   ] sys-devel/automake-1.5  0 kB
[ebuild   R   ] sys-devel/automake-1.6.3  0 kB
[ebuild   R   ] sys-devel/automake-1.7.9-r1  0 kB
[ebuild   R   ] sys-devel/automake-1.8.5-r3  0 kB
[ebuild   R   ] sys-devel/automake-1.10  0 kB
[ebuild     U ] sys-devel/automake-1.9.6-r2 [1.9.6-r1] 0 kB
[ebuild     U ] sys-devel/libtool-1.5.23b [1.5.22] 2,846 kB
[ebuild     U ] sys-apps/groff-1.19.2-r1 [1.19.1-r2] USE="-X* -cjk%" 2,836 kB
[ebuild  N    ] dev-libs/mpfr-2.2.0_p16  739 kB
[ebuild     U ] sys-process/psmisc-22.3 [22.1] USE="ipv6 nls -X* (-selinux)" 252 kB
[ebuild  NS   ] sys-devel/gcc-4.1.2  USE="fortran mudflap nls (-altivec) -bootstrap -build -d -doc -gcj -gtk (-hardened) -ip28 -ip32r10k (-multilib) -multislot (-n32) (-n64)       -nocxx -objc -objc++ -objc-gc -test -vanilla" 38,840 kB
[ebuild     U ] sys-apps/man-1.6e-r3 [1.6-r1] USE="nls" 247 kB
[ebuild     U ] sys-libs/glibc-2.5-r4 [2.3.5-r2] USE="nls nptl -build -debug% -glibc-compat20 -glibc-omitfp (-hardened) (-multilib) -nptlonly -profile (-selinux) (-erandom%)       (-linuxthreads-tls%) (-pic%) (-userlocales%)" 16,182 kB
[ebuild   R   ] sys-apps/man-pages-2.61-r1  USE="nls" 0 kB
[ebuild   R   ] sys-apps/coreutils-6.9-r1  USE="nls -acl (-selinux) -static -xattr" 0 kB
[ebuild     U ] sys-apps/diffutils-2.8.7-r2 [2.8.7-r1] USE="nls -static" 1,038 kB
[ebuild     U ] sys-devel/gcc-3.4.6-r2 [3.4.4-r1] USE="fortran nls (-altivec) -bootstrap -boundschecking -build -d% -doc% -gcj -gtk* (-hardened) -ip28 -ip32r10k% (-multilib)       -multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -test% -vanilla" 27,700 kB
[ebuild   R   ] app-misc/banner-1.3.2  0 kB
[ebuild     U ] dev-libs/openssl-0.9.8d [0.9.7i] USE="(sse2%*) zlib -bindist -emacs -test" 3,238 kB
[ebuild     U ] app-misc/ca-certificates-20070303-r1 [20050804] 95 kB
[ebuild   R   ] net-misc/wget-1.10.2  USE="ipv6 nls ssl -build -debug -socks5 -static" 1,190 kB
[ebuild     U ] sys-libs/readline-5.1_p4 [5.1_p2] 1,989 kB
[ebuild     U ] dev-lang/python-2.4.4-r4 [2.4.2] USE="berkdb ipv6 ncurses readline ssl -bootstrap -build -doc -examples% -gdbm -nocxx -nothreads% -tk% -ucs2 (-X%*) (-tcltk%)      " 7,976 kB
[ebuild   R   ] sys-apps/baselayout-vserver-1.11.14-r4  USE="-bootstrap -build -static -unicode" 0 kB
[ebuild     U ] sys-libs/cracklib-2.8.9-r1 [2.8.5-r1] USE="nls python" 563 kB
[ebuild   R   ] dev-python/python-fchksum-1.7.1  27 kB
[ebuild   R   ] dev-python/pycrypto-2.0.1-r5  USE="-bindist -gmp -test" 0 kB
[ebuild     U ] sys-apps/file-4.21-r1 [4.13] USE="python (-build%)" 538 kB
[ebuild  N    ] app-admin/python-updater-0.2  3 kB
[ebuild   R   ] app-portage/gentoolkit-0.2.3-r1  0 kB
[ebuild     U ] sys-libs/pam-0.78-r5 [0.78-r3] USE="berkdb -nis -pam_chroot -pam_console -pam_timestamp -pwdb (-selinux)" 6,350 kB
[ebuild   R   ] app-admin/eselect-1.0.7  USE="-bash-completion -doc" 0 kB
[ebuild   R   ] app-admin/eselect-vi-1.1.4  0 kB
[ebuild   R   ] net-mail/mailbase-1  USE="pam" 0 kB
[ebuild     U ] sys-apps/shadow- [4.0.14-r1] USE="cracklib%* nls pam -nousuid (-selinux) -skey" 1,481 kB
[ebuild   R   ] app-editors/vim-core-7.0.235  USE="nls -acl -bash-completion -livecd" 0 kB
[ebuild   R   ] mail-mta/ssmtp-2.61-r2  USE="ipv6 ssl -mailwrapper -md5sum" 0 kB
[ebuild     U ] net-misc/openssh-4.5_p1-r1 [4.2_p1-r1] USE="pam tcpd -X% -X509 -chroot -hpn -kerberos -ldap -libedit (-selinux) -skey -smartcard -static (-ipv6%*) (-sftplogg      ing%)" 0 kB
[ebuild   R   ] app-editors/vim-7.0.235  USE="nls perl python -acl -bash-completion -cscope -gpm -minimal -ruby -vim-pager -vim-with-x" 0 kB
[ebuild   R   ] sys-process/vixie-cron-4.1-r10  USE="pam -debug (-selinux)" 0 kB
[ebuild   R   ] app-vim/gentoo-syntax-20051221-r1  USE="-ignore-glep31" 0 kB
[blocks B     ] sys-apps/pam-login (is blocking sys-apps/shadow-
[blocks B     ] >=sys-apps/shadow-4.0.14-r2 (is blocking sys-apps/pam-login-4.0.14)

Total: 111 packages (56 upgrades, 9 new, 2 in new slots, 44 reinstalls, 2 blocks), Size of downloads: 181,503 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

Thanks for looking,

Best Regards, Paul.

Last edited by wilf on Thu Jul 19, 2007 9:13 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 04 May 2006
Posts: 461
Location: localhost

PostPosted: Thu Jul 19, 2007 8:48 am    Post subject: Reply with quote
Software is like sex. It's better when it's free
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 12 Feb 2006
Posts: 131
Location: West Sussex, UK

PostPosted: Thu Jul 19, 2007 8:53 am    Post subject: Reply with quote


Thanks for this, I'd just tracked it down here with my good friend Google.

I'll be quiet and try and sort it out :-)
michel7 wrote:

Thanks very much for your quick answer.

Best Regards, Paul.
Back to top
View user's profile Send private message

Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu Jul 19, 2007 9:29 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.
_________________ || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum