Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] [résolu] où démasquer ce package ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Lecaramel
n00b
n00b


Joined: 01 Apr 2007
Posts: 13

PostPosted: Thu Jul 26, 2007 1:51 pm    Post subject: [emerge] [résolu] où démasquer ce package ? Reply with quote

Bonjour,

Je suis en train d'essayer d'installer Red5 sur mon dédié (Gentoo 64, mais made in OVH), qui est un serveur de streaming flash open source.
Pour ce faire, j'ai utilisé un tutorial trouvé ici : http://overlays.gentoo.org/dev/bangert/wiki/Red5Gentoo

Tout se passe bien jusqu'au emerge red5 :
Quote:
# emerge red5
Calculating dependencies
!!! All ebuilds that could satisfy "red5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/red5-0.6.1 (masked by: missing keyword)
- dev-java/red5-0.6 (masked by: missing keyword)
- dev-java/red5-0.6.2 (masked by: missing keyword)

For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook.

J'ai bien regardé si red5 a été ajouté aux mots clefs ce qui est le cas, j'ai beaucoup googlisé et cherché sur les forums, j'ai même contacté l'auteur, en vain.
J'ai regardé sur la doc d'emerge s'il y'avait un moyen de forcer le emerge, je n'ai pas trouvé non plus.

Si quelqu'un à une idée ? Merci !

Edit : j'ai oublié de préciser, red5 n'apparait pas dans /usr/portage/profiles/package.mask


Last edited by Lecaramel on Thu Jul 26, 2007 3:05 pm; edited 2 times in total
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Thu Jul 26, 2007 1:53 pm    Post subject: Reply with quote

Code:
echo 'dev-java/red5 **' >> /etc/portage/package.keywords

Cela devrait faire l'affaire !!
Back to top
View user's profile Send private message
Lecaramel
n00b
n00b


Joined: 01 Apr 2007
Posts: 13

PostPosted: Thu Jul 26, 2007 2:02 pm    Post subject: Reply with quote

DidgeriDude : idem, cela sort le même message... snif !
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Thu Jul 26, 2007 2:14 pm    Post subject: Reply with quote

Alors là, je vois pas car je viens de tester et ça marche nickel (avec et sans les **) !!!!
Back to top
View user's profile Send private message
Lecaramel
n00b
n00b


Joined: 01 Apr 2007
Posts: 13

PostPosted: Thu Jul 26, 2007 2:17 pm    Post subject: Reply with quote

Si je savais, snif :(
Donc, tu as pu installer red5 sans problèmes.... J'arrive pas à voir ce qui peut coincer...
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Thu Jul 26, 2007 2:26 pm    Post subject: Reply with quote

Bah je ne l'ai pas installé, mais un emerge -pv red5 me dis que c'est bon !
Es-tu certain de bien avoir renseigné /etc/portage/package.keywords ? (pas de fautes d'orthographe, pas d'oubli du '5' après le red, chemin correct, etc., etc.)

Par contre, si je ne renseigne pas /etc/portage/package.keywords, il me sort :
Code:
emerge -pv red5

These are the packages that would be merged, in order:

Calculating dependencies -
!!! All ebuilds that could satisfy "red5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/red5-0.6.1 (masked by: ~x86 keyword)
- dev-java/red5-0.6 (masked by: ~x86 keyword)
- dev-java/red5-0.6.2 (masked by: ~x86 keyword)

Ce qui ne correspond pas à ton erreur !

Essaie un layman -d bangert suivi d'un layman -a bangert, pour voir si cela change quelque chose.
Back to top
View user's profile Send private message
Lecaramel
n00b
n00b


Joined: 01 Apr 2007
Posts: 13

PostPosted: Thu Jul 26, 2007 2:48 pm    Post subject: Reply with quote

remplacer ** par ~x86 a résolu le problème... pourtant, j'avais testé cette solution avant, je ne comprends pas de trop.

Bon, maintenant, plus qu'a espérer que ça ne crash pas mon serveur..

En tout cas, un grand merci !
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Thu Jul 26, 2007 2:59 pm    Post subject: Reply with quote

ajoute [résolu] à ton titre :)
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum