Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-drm or kernel drm modules for Rage 128 in B&W PowerMac?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 376

PostPosted: Tue Aug 14, 2007 2:21 pm    Post subject: x11-drm or kernel drm modules for Rage 128 in B&W PowerM Reply with quote

Should I install the x11-drm package from portage, or compile the DRM into the Kernel for my Rage 128 card in my Blue & White PowerMac G3?

Stable x11-drm doesn't seem to compile.

If I need to compile DRM into the kernel, should I build it in, or build as modules?
Back to top
View user's profile Send private message
theethicalatheist
n00b
n00b


Joined: 11 Apr 2006
Posts: 68
Location: University of Massachusetts Lowell

PostPosted: Tue Aug 14, 2007 5:32 pm    Post subject: Reply with quote

I have a G4 with that same card. For me, the driver was pre-selected as a module in Device Drivers >> Character Devices. I didn't bother to install the x11-drm package, and everything is fully functional, although 3D acceleration is quite unstable, which I hear is common on PPC Linux.

AFAIK, the drm kernel module is a dependency of the Rage 128 driver. Just add "drm" and "r128" to the /etc/modules.autoload.d/kernel-2.6 file, and it should be good to go.

You probably also want to select the Rage 128 driver in Graphics Support, along with Framebuffer support.
_________________
"Be excellent to each other" - Bill & Ted
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 376

PostPosted: Tue Aug 14, 2007 10:27 pm    Post subject: Reply with quote

I built agpgart as a module, but emerged x11-drm-20070314. I've also got ATI Rage 128 support built into the kernel for framebuffer.

My devices section in xorg.conf is
Code:
Section "Device"
   Identifier  "Card0"
   Driver      "ati"
   VendorName  "ATI Technologies Inc"
   BoardName   "Rage 128 RE/SG"
   BusID       "PCI:0:16:0"
EndSection


/var/log/Xorg.0.log says DRM/DRI is working, but when I run glxgears or glxinfo, X hardlocks. I've tried adding the following to my Devices section, but nothing has fixed it.

Option "ForcePCIMode" "true"
Option "AGPMode" "2"

I still get lockups. How can I fix this?
Back to top
View user's profile Send private message
theethicalatheist
n00b
n00b


Joined: 11 Apr 2006
Posts: 68
Location: University of Massachusetts Lowell

PostPosted: Tue Aug 14, 2007 11:37 pm    Post subject: Reply with quote

There very well may be a fix for this, but every distro I've ever used on PPC, including Gentoo, has given me lockups when trying to use 3D acceleration. Technically it works, I have DRI working, and can play Neverball, but it usually freezes after a few seconds.

Does anyone here actually have 3D support working reliably?
_________________
"Be excellent to each other" - Bill & Ted
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 376

PostPosted: Wed Aug 15, 2007 2:56 am    Post subject: Reply with quote

Hmm, glxgears functions fine now. Getting almost 600 FPS. Quake 3 is semi-playable (20 FPS at default settings).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum