Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gentoo-security] GLSA: apache-2.x (200305-13)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message

Joined: 16 Apr 2002
Posts: 18505

PostPosted: Sun Jun 01, 2003 4:03 pm    Post subject: [gentoo-security] GLSA: apache-2.x (200305-13) Reply with quote

Daniel Ahlberg wrote:
- - - ---------------------------------------------------------------------
- - - ---------------------------------------------------------------------

PACKAGE : apache-2.x
SUMMARY : denial of service
DATE : 2003-06-01 12:01 UTC
EXPLOIT : remote
VERSIONS AFFECTED : <apache-2.0.46
FIXED VERSION : >=apache-2.0.46
CVE : CAN-2003-0245 CAN-2003-0189

- - - ---------------------------------------------------------------------

- From announcement:

"Apache 2.0 versions 2.0.37 through 2.0.45 can be caused to crash in
certain circumstances. This can be triggered remotely through mod_dav
and possibly other mechanisms. The crash was originally reported by
David Endler <> and was researched and fixed by
Joe Orton <>. Specific details and an analysis of the
crash will be published Friday, May 30. No more specific information
is disclosed at this time, but all Apache 2.0 users are encouraged to
upgrade now."

"Apache 2.0 versions 2.0.40 through 2.0.45 on Unix platforms were
vulnerable to a denial-of-service attack on the basic authentication
module, which was reported by John Hughes <>.
A bug in the configuration scripts caused the apr_password_validate()
function to be thread-unsafe on platforms with crypt_r(), including
AIX and Linux. All versions of Apache 2.0 have this thread-safety
problem on platforms with no crypt_r() and no thread-safe crypt(),
such as Mac OS X and possibly others. When using a threaded MPM (which
is not the default on these platforms), this allows remote attackers
to create a denial of service which causes valid usernames and
passwords for Basic Authentication to fail until Apache is restarted.
We do not believe this bug could allow unauthorized users to gain
access to protected resources."

Read the full advisories at:


It is recommended that all Gentoo Linux users who are running
net-www/apache-2.x upgrade to apache-2.0.46 as follows

emerge sync
emerge apache
emerge clean

- - - --------------------------------------------------------------------- - GnuPG key is available at
- - - ---------------------------------------------------------------------

Mailing List Archive: Unavailable
The media sells it and you live the role.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum