Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
some G4 packages available
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Mon Oct 08, 2007 8:25 am    Post subject: some G4 packages available Reply with quote

i compiled several packages the last few days and as i have some spare space now on my webspace i just uploaded the packages here.
I probably will only upload big packages but if you need any other ones let me know and i will upload them temporarily.

Openoffice is of course compiled with stripped down cflags (-O2 -mcpu=7400 -pipe -maltivec -mabi=altivec ).

cheers
_________________
Error: Failing not supported by current locale


Last edited by gringo on Sat Feb 16, 2008 10:24 am; edited 3 times in total
Back to top
View user's profile Send private message
praveen
n00b
n00b


Joined: 08 Jun 2005
Posts: 43

PostPosted: Mon Oct 08, 2007 3:24 pm    Post subject: Reply with quote

I tried the openoffice on my ibook G4 but I get error on startup

Unknown error forking main binary / abnormal early exit

I could not locate the cause of this error (I dont use kde/gnome).
_________________
http://pc.freeshell.org/comp/ibook
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Mon Oct 08, 2007 6:30 pm    Post subject: Re: G4 binaries available Reply with quote

gringo wrote:
i compiled several packages the last few days and as i have some spare space now on my webspace i just uploaded the binaries here.
More to come ( my internet connection sucks badly) and will try to keep them updated if anyone is interested.
Openoffice was of course compiled with stripped down cflags (-O2 -mcpu=7400 -mtune=7400 -pipe -maltivec -mabi=altivec iirc).

cheers



openoffice can't be compiled with the -O2
see the related topic
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Tue Oct 09, 2007 7:16 am    Post subject: Reply with quote

Quote:
Unknown error forking main binary / abnormal early exit


never seen this error before, sorry ... anyone can confirm if it works or not ?
Does the firefox binary work for you praveen ?

Quote:
openoffice can't be compiled with the -O2
see the related topic


will check but im pretty sure -O2 was used and it just works here.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
praveen
n00b
n00b


Joined: 08 Jun 2005
Posts: 43

PostPosted: Tue Oct 09, 2007 7:42 am    Post subject: Reply with quote

I already use firefox 2.0.0.1 but I have been having problem with openoffice for quite some time. None of the binaries I tried works. This latest error has been reported by many people on the internet but I dont know whats the cause of the error.
_________________
http://pc.freeshell.org/comp/ibook
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Tue Oct 09, 2007 11:46 am    Post subject: Reply with quote

Quote:
I already use firefox 2.0.0.1


ok, could you pls try out my firefox binary ?. If you do backup yours first.
I just want to check if the other binaries provided do work and are not crappy.

Quote:
This latest error has been reported by many people on the internet but I dont know whats the cause of the error.


yes, i searched a bit around too, but couldn´t find anything that could help me diagnose why it isn´t working for you.
Do other oo binaries you tried fail in the same way as mine ?

thanks !
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
praveen
n00b
n00b


Joined: 08 Jun 2005
Posts: 43

PostPosted: Tue Oct 09, 2007 1:18 pm    Post subject: Reply with quote

Yes, your firefox binary works. I dont think it was the same error as this with the older openoffice binaries that I have tried.
_________________
http://pc.freeshell.org/comp/ibook
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Oct 09, 2007 1:39 pm    Post subject: Reply with quote

I suspect that you're missing a library, or that OO.o is compiled against a different version of some library on your system. The ooffice executable is actually just a script. Can you take a look, using ldd, at which libraries are used by the executable called from ooffice?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Tue Oct 09, 2007 1:58 pm    Post subject: Reply with quote

Quote:
Yes, your firefox binary works


thanks very much for testing ! :)

Quote:
I suspect that you're missing a library, or that OO.o is compiled against a different version of some library on your system. The ooffice executable is actually just a script. Can you take a look, using ldd, at which libraries are used by the executable called from ooffice?


just guessing but could it be because of ~arch versions of boost or STLport ? I don´t think gnome or kde dependencies could be the problem, right ? These are just wrappers for stuff like menu entries and things like that.

Thanks for making the thread sticky JoseJX !

For others that have binaries available, not just for G4, please put your link in this thread and i will update the first post.

thanks !
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 419
Location: London, U.K. & Lisbon, Portugal

PostPosted: Thu Oct 11, 2007 12:57 am    Post subject: Re: G4 binaries available Reply with quote

ddc wrote:
openoffice can't be compiled with the -O2
see the related topic

Yes, it can. That's how I compile it.
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Thu Oct 11, 2007 6:30 pm    Post subject: Re: G4 binaries available Reply with quote

Sodki wrote:
ddc wrote:
openoffice can't be compiled with the -O2
see the related topic

Yes, it can. That's how I compile it.


could you past your /etc/make.conf

in 2005 i successfully compiled openoffice with the -O2, 3 weeks ago i switched my gentoo to a fresh 2006.1 install and i personally compiled the last openoffice: well this time i had no success, as reported by other people in a specific thread on this forum:

see https://forums.gentoo.org/viewtopic-t-570617.html

it was reported that compiling openoffice with "-O2" causes issues and failure
so, the solution posted, the solution that fixes the issue, is to remove the "-O2"
personally i removed it and i got success where i got failure


so, if you say success with the "-O2", could i see your /etc/make.conf ? could you tell me exactly what you did to compile the last openoffice ?

i mean the gcc version, the binutils version, and the environment

regards
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Oct 11, 2007 10:41 pm    Post subject: Reply with quote

I've never seen -O2 cause an OO.o build failure. Using -mcpu=G4 or 7450 however seems to sometimes not work, try substituting 7400 and your problems should go away.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 419
Location: London, U.K. & Lisbon, Portugal

PostPosted: Sat Oct 13, 2007 10:15 am    Post subject: Re: G4 binaries available Reply with quote

ddc wrote:
so, if you say success with the "-O2", could i see your /etc/make.conf ? could you tell me exactly what you did to compile the last openoffice ?

Try this:

1. Create the file
Code:
 /etc/portage/env/app-office/openoffice

2. Put the following in that file:
Code:
CFLAGS="-O2 -mcpu=7400 -maltivec -mabi=altivec -pipe"
CXXFLAGS="${CFLAGS}"


This is what I use so that OpenOffice.org uses this settings instead of the ones in /etc/make.conf. This way I don't have to change /etc//make.conf to compile OpenOffice.org. It's a neat trick I learned here in the Forum.

Try it and see if it works for you.
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1609
Location: U.S.A.

PostPosted: Tue Oct 16, 2007 12:17 am    Post subject: Reply with quote

I don't recall every having a problem building OpenOffice on my 7400. My make.conf specifies -O2, but I always assumed the ebuild would be setting any unusually conservative compiler options required.

emerge info:
Code:

Portage 2.1.3.9 (default-linux/ppc/ppc32/2007.0/desktop/G4, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4 ppc)
=================================================================
System uname: 2.6.21-gentoo-r4 ppc 7400, altivec supported
Timestamp of tree: Mon, 15 Oct 2007 06:50:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="ppc"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mtune=7400 -mcpu=7400 -maltivec -mabi=altivec -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=7400 -mcpu=7400 -maltivec -mabi=altivec -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://open-systems.ufl.edu/mirrors/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 alsa altivec bash-completion berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread encode esd fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv imagemagick java jpeg logrotate mad mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl pam pcre pdf perl png ppc python quicktime readline reflection reiserfs samba sdl session spl ssl svg threads tiff truetype truetype-fonts type1-fonts unicode userlocales vorbis xml xorg xv zlib" ALSA_CARDS="powermac" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="r128"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
patrix_neo wrote:
The human thought: I cannot win.
The ratbrain in me : I can only go forward and that's it.
Back to top
View user's profile Send private message
ndansmith
n00b
n00b


Joined: 01 Aug 2005
Posts: 60

PostPosted: Tue Oct 16, 2007 4:01 am    Post subject: Reply with quote

Anyone have an idea as to how to get the spell-checking working for this openoffice build? I tried the old eselect oodict set myspell-en method, but no luck there. No errors, it just does not work.
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1609
Location: U.S.A.

PostPosted: Tue Oct 16, 2007 1:07 pm    Post subject: Reply with quote

For which build? 2.3.0?

[Edit]: I'm using 2.2.1 - just thought clarification would help.
_________________
patrix_neo wrote:
The human thought: I cannot win.
The ratbrain in me : I can only go forward and that's it.


Last edited by Bones McCracker on Wed Oct 17, 2007 7:11 am; edited 1 time in total
Back to top
View user's profile Send private message
ndansmith
n00b
n00b


Joined: 01 Aug 2005
Posts: 60

PostPosted: Wed Oct 17, 2007 3:45 am    Post subject: Reply with quote

BoneKracker wrote:
For which build? 2.3.0?

Yes.
Back to top
View user's profile Send private message
salzd
n00b
n00b


Joined: 17 Oct 2007
Posts: 1
Location: Bern

PostPosted: Wed Oct 17, 2007 7:13 am    Post subject: Reply with quote

ndansmith wrote:
Anyone have an idea as to how to get the spell-checking working for this openoffice build? I tried the old eselect oodict set myspell-en method, but no luck there. No errors, it just does not work.


No Idea - but I'm dealing with the same kind of problem. Would be nice to get a fix soon....
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 419
Location: London, U.K. & Lisbon, Portugal

PostPosted: Wed Oct 17, 2007 3:08 pm    Post subject: Reply with quote

Do you have hunspell installed? Also, check in Options -> Language Settings -> Writing ainds. I'm sorry I can't help more, but I do have OOo 2.3 with spellchecking enabled.
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Thu Oct 25, 2007 11:37 pm    Post subject: Reply with quote

about OpenOffice, i emerged the 2.2.1

do you read these errors when you invoke ooffice ?

Quote:

(process:15330): GLib-GObject-CRITICAL **: gtype.c:2242: initialization assertion failed, use IA__g_type_init() prior to this function
(process:15330): Gdk-CRITICAL **: gdk_screen_get_font_options: assertion `GDK_IS_SCREEN (screen)' failed
(process:15330): GLib-GObject-CRITICAL **: gtype.c:2242: initialization assertion failed, use IA__g_type_init() prior to this function
(process:15330): Gdk-CRITICAL **: gdk_screen_get_font_options: assertion `GDK_IS_SCREEN (screen)' failed
/usr/lib/openoffice/program/soffice: line 269: 15330 Segmentation fault "$sd_prog/$sd_binary" "$@"


what does they means ?


Last edited by ddc on Sat Oct 27, 2007 8:08 am; edited 1 time in total
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1609
Location: U.S.A.

PostPosted: Fri Oct 26, 2007 12:27 am    Post subject: Reply with quote

OpenOffice 2.3.0 is stable for ppc. Spellcheck works fine for me.

Code:
~ $ dep -k openoffice
app-office/openoffice:
      |                           s   
      |                   p       p   
      |                   p       a   x
      |                   c       r   8
      |                   -       c   6
      | a a             p m     s -   -
      | l m   h i m m   p a s   p f   f
      | p d a p a 6 i p c c 3   a b x b
      | h 6 r p 6 8 p p 6 o 9 s r s 8 s
      | a 4 m a 4 k s c 4 s 0 h c d 6 d
------+---------------v----------------
2.3.0 >   ~           +         -   + 
Back to top
View user's profile Send private message
ndansmith
n00b
n00b


Joined: 01 Aug 2005
Posts: 60

PostPosted: Fri Oct 26, 2007 7:37 pm    Post subject: Reply with quote

BoneKracker wrote:
OpenOffice 2.3.0 is stable for ppc. Spellcheck works fine for me.

Well, for what its worth I took the time to emerge it myself and spell check worked perfectly (no change in hunspell or myspell dicts). So I suppose it is a mystery, or the inability of the oodict eselect module to work on precompiled packages.
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Sat Oct 27, 2007 8:01 am    Post subject: Reply with quote

BoneKracker wrote:
Code:
~ $ dep -k openoffice


which ebuild emerge the "dep" tool ?
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Sat Oct 27, 2007 8:06 am    Post subject: Re: G4 binaries available Reply with quote

gringo wrote:
i compiled several packages



how do you generate the .tgz ?
i mean ...
A) have you used "equery files package" + scripting
or
B) is there a tool that is able to tarball an ebuild binary contents
?
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Sat Oct 27, 2007 8:16 am    Post subject: Reply with quote

about other apps:

i'm not able to emerge the last VLC with wxwindows gui: it doesn't work (probably GTK or other issues, i emerged with the ncurses GUI only, and it is not working as mplayer does: VLC has noises in audio reproduction, while mplayer has not)

i'm not able to emerge a real working qemu: it needs a manual patch, or a gcc-config to set the 3.3.6 version. In this way it is possibile to compile it, but it stops when invoked .... so, from my point of view it is not working

GTK seems to have issues ... (see the previous post, issues with openoffice ... emerged with GTK in USE flags)

i'm not able to emerge scilab: stopped by a blas issues (hoping to fix it as soon as possible)

i'm not able to emerge a not bugged firefox: the problem is relate to cairo, so the fix is to set X11.org color depth to 24
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum