Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo on Acer TM C200 (tablet pc)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message

Joined: 02 Nov 2004
Posts: 21

PostPosted: Wed Oct 31, 2007 3:13 pm    Post subject: Gentoo on Acer TM C200 (tablet pc) Reply with quote

This is the second time I try to install Gentoo on this laptop. Both times I had problems so I decided to document the installation process a little for others who might need help and myself as well.

(at the end of this post there's a list with helpful and important resources)

    CPU: Intel Pentium M 760 “Dothan” 2GHz, 2MB L2 Cache
    Chipset: Mobile Intel 915PM
    Front-side Bus: 533MHz
    Memory: DDR2 SDRAM - 533MHz
    Memory Capacity: Up to 2GB (base may come with 2×512MB = 1GB)

    Display: 12.1″ TFT LCD
    Resolution: 1024×768 XGA (262K colors)
    Touchscreen: Yes
    Widescreen: No
    Graphics Chipset: NVIDIA GeForce Go 6200
    Graphics Memory: 64MB (Dedicated)
    Other: VGA Out

    Hard Drive: 100GB ATA/100
    Optical: CD-RW/DVD Writer (Dual-Layer)

    Wireless: Intel PRO/Wireless 2200BG 802.11b/g with Acer SignalUp Technology
    Modem: 56K V.92 (*)
    Ethernet: 10/100/1000 Gigabit
    Bluetooth: Bluetooth wireless PAN (*)

    Audio Chipset: Intel High Definition Audio
    Speakers: Integrated microphone and speaker
    Audio I/O: Microphone/Line-in, Headphones/speakers/line-out
    USB: 3x USB 2.0
    Firewire: 1x IEEE 1394 (*)
    PC Card: 1x Type II/CardBus (*)
    Flash/Memory Card Reader: 4-in-1 card reader - MultiMediaCard (MMC), Secure Digital (SD), Memory Stick or Memory Stick Pro (MS or MS Pro) (*)
    Other: Inverted T cursor layout, hotkey, embedded numeric keypad, Trackpoint with two buttons, scroll wheel, FIR (fast infrared), Optional Port Replicator

    Biometric/Fingerprint: Yes (*)

    Options: Lithium Ion, 2 batteries internally - 1x 6-cell and 1x 3-cell
    Battery Life: 6-cell = up to 3.6 hours, additional 3-cell = 1.6 hours additional (5.2 hours altogether)

    Width: 12.4 inches (315mm)
    Depth: 9.4 inches (238mm)
    Height: 1.4 inches (35.3mm)
    Weight: 5.7 pounds (2.6kg) with both batteries installed

* devices I've had little or no interaction with under linux (up to date)

Dual-boot (Windows XP and Gentoo Linux 2007.0)

Current status:
    + nvidia graphics card working
    + Intel HDA working with ALSA
    - Touchscreen and stylus not yet configured/installed
    - Bluetooth not configured
    - Firewire not configured
    - Card Reader not configured
    - Modem not configured

I booted up from the LiveDVD and tried both installers inside X (command line and GTK+). Both of them seemed to crash so I decided for the "old-fashioned" way: console with Gentoo H[/list]andbook on the side (not the first time I've done it). However, this time there was one thing I did that helped me greatly and I didn't do the other times: I read 90%-100% of the text that was in the HOWTO guides I followed.

The basics covered in the Gentoo Handbook went well without remarks. After my first boot into my freshly installed Gentoo box I noticed I had no framebuffer. I hate console without framebuffer (not talking about themes...just plain framebuffer...nice fonts) but I decided to correct it after I had my system up and running.

I emerged nvidia-drivers and when I tried Xorg startx crashed with an ugly error:
(EE) NVIDIA(0): The NVIDIA kernel module does not appear to be receiving
(EE) NVIDIA(0):     interrupts generated by the NVIDIA graphics device
(EE) NVIDIA(0):     PCI:1:0:0.  Please see Chapter 8: Common Problems in the
(EE) NVIDIA(0):     README for additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!

I asked for help in the forums and at sometime I got to a guide that said that this is a generic error and the problem might be due to IRQ problems (either routing, sharing, etc). I didn't quite believe it but I tried rebooting my laptop with some of the kernel options suggested in the guide pci=noacpi pci=biosirq. None of those help so I tried to look for some more help and info on the problem. Everything seemed to be ok so it had to be something missing from my installing. As it turns out, nvidia-drivers need that the kernel has support for Message Signalled Interrupts (MSI). As soon as I got support for MSI in my kernel startx worked fine.

At the same time I tried to correct my nvidia problem, I tried to correct my framebuffer problem. Again, it was a missing option in my kernel configuration that prevented uvesafb from doing its work. This option was CONFIG_FRAMEBUFFER_CONSOLE.
To get uvesafg to work I followed spocks howto to the letter (I did this prior to enabling the above option in my kernel config).

Intel HDA with ALSA
I chose KDE as my graphical environment and the next step had to be ALSA. Has I had a bad experience regarding ALSA on this laptop (my previous attempt to install gentoo only got sound working through the headphones jack) I searched for a howto on ALSA. I found one in Gentoo Wiki which I followed (again) to the letter. When I got through it, sound was working great (better than before) through both speaker (this laptop has only a mono speaker built in) and headphone jack.

TODO (next step):
Get touchscreen and stylus to work

Gentoo Handbook I followed
Forum thread with framebuffer problem and solution
Forum thread with nvidia problem and solution
ALSA howto
Intel HDA module

Sorry if this is a little messy but it's the first time I've written a howto guide (well at least kind of one). If some more help is needed pvt me.

P.S: I'll update when I have something new to add.
Back to top
View user's profile Send private message

Joined: 02 Nov 2004
Posts: 21

PostPosted: Wed Oct 31, 2007 6:26 pm    Post subject: Reply with quote

I forgot to mention 1 important detail:

- I thought my graphics card was AGP but as it turns out it's not, it's PCI-E. This is important so as to enable support for PCI-E in the kernel otherwise, you'll end up like me trying to figure out what's the problem despite everything looking ok.
Back to top
View user's profile Send private message

Joined: 02 Nov 2004
Posts: 21

PostPosted: Thu Nov 01, 2007 3:58 pm    Post subject: Reply with quote

Stylus and touchscreen already working

This is really simple to achieve. My only problem was finding out the important information such as what type of touchscreen this laptop has and which make.

The touchscreen is Wacom (almost every touchscreen is as far as I could see). However, unlike other Wacom models this one uses a serial port instead of a USB port. Apparently this is standard for all tablet pc's. Having this said it's time to say how I got it to work.

It's quite simple really, I followed this guide up to number 9. Here, as this is a serial tablet, I had to do things differently. You have to find out to which device is the screen linked. To do so...
# cat /proc/tty/drivers
/dev/tty             /dev/tty        5       0 system:/dev/tty
/dev/console         /dev/console    5       1 system:console
/dev/ptmx            /dev/ptmx       5       2 system
/dev/vc/0            /dev/vc/0       4       0 system:vtmaster
serial               /dev/ttyS       4 64-67 serial
pty_slave            /dev/pts      136 0-1048575 pty:slave
pty_master           /dev/ptm      128 0-1048575 pty:master
pty_slave            /dev/ttyp       3 0-255 pty:slave
pty_master           /dev/pty        2 0-255 pty:master
unknown              /dev/tty        4 1-63 console

Now we look where it says it is serial...
# ls -l /dev/ttyS*
crw-rw---- 1 root uucp 4, 64 Nov  1 15:25 /dev/ttyS0
crw-rw---- 1 root uucp 4, 65 Nov  1 15:25 /dev/ttyS1
crw-rw---- 1 root uucp 4, 66 Nov  1 15:25 /dev/ttyS2
crw-rw---- 1 root uucp 4, 67 Nov  1 15:25 /dev/ttyS3

Now in the previously mentioned guide, it says to use wacdump to determine which device to use. But wacdump does not work here. So a simple
cat /dev/ttyS*
will have to do (still with Xorg stopped). Where you have * replace with numbers (in this case 0 through 3) until you find one that dumps some weird characters when you move the pen. That's the one you want.

Now it's time to configure Xorg (and that's all there's left to do). Again, you can follow the same guide regarding xorg.conf. Don't forget to follow the referenced links to get the eraser to work as well. The only thing to watch for are the entries where it states
where * is the number to the device where your touchscreen is.

Now you just fire up Xorg again and start using your stylus. :)
Back to top
View user's profile Send private message

Joined: 17 Dec 2005
Posts: 155

PostPosted: Thu Jan 10, 2008 8:18 am    Post subject: Reply with quote

Hey,i am not any more the only one who use Linux on that notebook.
I use gentoo Linux on that device since 2 Years. I was also the person who get the sound-support into alsa :wink:
I own the c204tmi. If you doesnt know that already - there is a new bios for the device available. :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum