Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Way to stop trackpad tapping? [resolved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
JeanValjean
n00b
n00b


Joined: 27 Aug 2007
Posts: 61

PostPosted: Tue Nov 13, 2007 7:16 pm    Post subject: Way to stop trackpad tapping? [resolved] Reply with quote

I just installed gentoo on my iBook-SE and I can say that I really like it. I'm running the new gnome and the response is resonable for a 300MHz processor, in fact it's pretty darn good.

I am going just about crazy though.

I often find myself typing and a context-menu pops up. This leaves me having to type on a awkward hand angle to avoid contacting the trackpad.

I looked at the kernel .config file and it appears one driver controls everything. If I disable the ADB then it looks as if the keyboard and mouse will be disabled as well.

This is almost unusable, any ideas on how I can fix this?


Last edited by JeanValjean on Wed Dec 12, 2007 11:06 am; edited 1 time in total
Back to top
View user's profile Send private message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3789
Location: sleeping in the bathtub

PostPosted: Tue Nov 13, 2007 7:19 pm    Post subject: Reply with quote

Just disable it via xorg.conf?
_________________
"You have to invite me in"
Back to top
View user's profile Send private message
skunk
l33t
l33t


Joined: 28 May 2003
Posts: 646
Location: granada, spain

PostPosted: Tue Nov 13, 2007 8:12 pm    Post subject: Reply with quote

if you are using the synaptics driver kde-misc/ksynaptics or gnome-extra/gsynaptics will do the job else look at this.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Nov 14, 2007 9:52 pm    Post subject: Reply with quote

You can also turn off tapping using pbbuttonsd.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
JeanValjean
n00b
n00b


Joined: 27 Aug 2007
Posts: 61

PostPosted: Thu Nov 15, 2007 6:13 pm    Post subject: Reply with quote

Thanks for all the replies. I've tried all the suggestions. I disabled the trackpad in xorg.conf but this had no effect. I looked up information on appletouch but the driver only works on macs post 2005 (my ibook was created in 1997). So then I tried pbbuttonsd. With powerprefs I inputed notap for the touchpad but I HAVE STILL that dang tapping :( .

I'm considering just disabling ADB from the kernel. If I do this then the x server driver can handle the keyboard and the usb driver should be able to drive the mouse. Yes? No? Has has anyone tried this?
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1556
Location: Germany

PostPosted: Thu Nov 15, 2007 10:19 pm    Post subject: Reply with quote

Did you set..?
/etc/pbbuttonsd.cnf:
[MODULE PMAC]
NoTapTyping=yes

_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Nov 16, 2007 1:27 am    Post subject: Reply with quote

The trackpad on that model is definitely an ADB device, not a USB mouse. So, if you disable ADB, you won't be able to use the trackpad at all. How did you disable tapping in pbbuttonsd?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
JeanValjean
n00b
n00b


Joined: 27 Aug 2007
Posts: 61

PostPosted: Wed Dec 12, 2007 11:05 am    Post subject: Reply with quote

Appreciate the help. I figured it out. I was using powerprefs as root. When I set "notap" as regular user the tapping ended.

:D

FYI, I did remove ADB from the kernel and set GDM to automatic login but the X driver apparently uses the kernel keyboard driver, so the trackpad and the keyboard were disabled. I'll probably end up just opening the iBook and disabled (manually) the trackpad.

Resolved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum