Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trouble installing Gentoo on Performa 5400 : Kernel panic
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Lumbermatt
n00b
n00b


Joined: 18 Nov 2007
Posts: 5

PostPosted: Sun Nov 18, 2007 11:06 pm    Post subject: Trouble installing Gentoo on Performa 5400 : Kernel panic Reply with quote

Hi there,

I'm playing with an old Macintosh Performa 5400/160 (PPC603e CPU, 138 Mo RAM) and try to install Gentoo (latest release).

I kept a minimal MacOS9 installation with BootX to load the Linux kernel. I got the minimal LiveCD to boot with the arguments of the documentation. The startup is slow but works (the bash prompt shows up).

The problem is that the Performa make a kernic panic (or freeze sometimes) 10-15 secondes after the prompt showed up. During this short time, I can switch console, display ifconfig setting, etc...

I was wondering that maybe the 603e is unsupported in the last Gentoo release.

If somebody have a clue how to avoid this kernel panic, it would be great.

Thanks a lot.

Lumbematt.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Nov 18, 2007 11:33 pm    Post subject: Reply with quote

Can you give us the backtrace (perhaps a photo?), it would help to determine where the problem is.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Lumbermatt
n00b
n00b


Joined: 18 Nov 2007
Posts: 5

PostPosted: Sun Nov 18, 2007 11:35 pm    Post subject: Reply with quote

JoseJX wrote:
Can you give us the backtrace (perhaps a photo?), it would help to determine where the problem is.


Okay. There's only the last stuff displayed. How could I get the begin of the kernel panic output ?
Back to top
View user's profile Send private message
Lumbermatt
n00b
n00b


Joined: 18 Nov 2007
Posts: 5

PostPosted: Mon Nov 19, 2007 12:10 am    Post subject: Reply with quote

So I didn't found how to get to the begining of the kernel panic buffer. So I filmed (sounds wired yes :D ) the kernel panic. The first line is :

Code:
eth0 : timeout expired stopping DMA


So I build the network card out of the performa, guess what it works (but without network). The card is based on an Digital Corp DC1017BA chip. This card worked nice with the tulip driver with an other distro.


Last edited by Lumbermatt on Mon Nov 19, 2007 10:54 am; edited 1 time in total
Back to top
View user's profile Send private message
Lumbermatt
n00b
n00b


Joined: 18 Nov 2007
Posts: 5

PostPosted: Mon Nov 19, 2007 10:54 am    Post subject: Reply with quote

Some news : I put a cheap NE2000-clone card in the performa and now everything seems to work. Some module issues I think.

Thanks for help indeed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum