Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-lang/R-2.6.0-r2 building error [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
mabhobs
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2006
Posts: 83

PostPosted: Thu Nov 22, 2007 6:08 pm    Post subject: dev-lang/R-2.6.0-r2 building error [SOLVED] Reply with quote

I tried to install the new R package and received the following error even though I have the fortran flag switched on:

Code:
These packages will be installed:

* dev-lang/R [U 2.6.0-r1 -> 2.6.0-r2] <world>
    X -blas -debug -doc+ -java+ jpeg -lapack -minimal+ -nls png readline tk

Total: 1 package (1 upgrade)

Use flags:

* doc:             Adds extra documentation (API, Javadoc, etc)
* java:            Adds support for Java
* minimal:         Install a very minimal build (disables, for example, plugins, fonts, most drivers, non-critical features)

(1 of 1) Installing dev-lang/R-2.6.0-r2:0::gentoo

paludis@1195758232: [WARNING] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When fetching 'dev-lang/R-2.6.0-r2:0::gentoo':
  ... When checking permissions on '/mnt/data/distfiles' for userpriv:
  ... Directory '/mnt/data/distfiles' does not group write permission,cannot enable userpriv
Checking 'R-2.6.0.tar.gz'... ok
paludis@1195758244: [WARNING] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When installing 'dev-lang/R-2.6.0-r2:0::gentoo':
  ... When checking permissions on '/mnt/data/tmp/paludis' for userpriv:
  ... Directory '/mnt/data/tmp/paludis' does not group write permission,cannot enable userpriv
>>> Running ebuild phase prepare as root:root...
>>> Starting builtin_prepare
>>> Done builtin_prepare
>>> Completed ebuild phase prepare
>>> Running ebuild phases init saveenv as root:root...
>>> Starting builtin_init
>>> Done builtin_init
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases init saveenv
>>> Running ebuild phases loadenv setup saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting pkg_setup
 * None of the needed Fortran Compilers (gfortran ifc g77) is installed.
 * To install one of these, choose one of the following steps:
 * [1] USE="fortran" emerge =sys-devel/gcc-4*
 * [3] USE="fortran" emerge =sys-devel/gcc-3*

!!! ERROR in dev-lang/R-2.6.0-r2:
!!! In need_fortran at line 3618
!!! Install a Fortran Compiler !

!!! Call stack:
!!!    * need_fortran (/mnt/data/tmp/paludis/dev-lang/R-2.6.0-r2/temp/loadsaveenv:3618)
!!!    * fortran_pkg_setup (/mnt/data/tmp/paludis/dev-lang/R-2.6.0-r2/temp/loadsaveenv:2622)
!!!    * pkg_setup (/mnt/data/tmp/paludis/dev-lang/R-2.6.0-r2/temp/loadsaveenv:3741)
!!!    * ebuild_f_setup (/usr/libexec/paludis/pkg_setup.bash:45)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:431)
!!!    * main (/usr/libexec/paludis/ebuild.bash:449)

diefunc: making ebuild PID 23820 exit with error
die trap: exiting with error.

Install error:
  * In program paludis -i world:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'dev-lang/R-2.6.0-r2:0::gentoo':
  * Install error: Install failed for 'dev-lang/R-2.6.0-r2:0::gentoo'



Resume command: paludis --log-level qa --install --add-to-world-spec '( )' --dl-deps-default discard '=dev-lang/R-2.6.0-r2:0::gentoo'


Last edited by mabhobs on Thu Nov 22, 2007 8:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Nov 22, 2007 6:36 pm    Post subject: Reply with quote

Code:
!!! Install a Fortran Compiler !

Sometimes developers actually intend you to read the messages the put into the ebuilds :wink:
USE="fortran" emerge gcc should help
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
mabhobs
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2006
Posts: 83

PostPosted: Thu Nov 22, 2007 7:10 pm    Post subject: Reply with quote

Can I quote myself? ..."even though I have the fortran flag switched on."

Thank you for the reply though.
Back to top
View user's profile Send private message
mabhobs
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2006
Posts: 83

PostPosted: Thu Nov 22, 2007 8:03 pm    Post subject: Reply with quote

I had to config the gcc compiler and run source /etc/profile. This was the solution:

Code:
calvin mabhobs # gcc-config powerpc-unknown-linux-gnu-4.1.2
 * Switching native-compiler to powerpc-unknown-linux-gnu-4.1.2 ...
>>> Regenerating /etc/ld.so.cache...                                      [ ok ]

 * If you intend to use the gcc from the new profile in an already
 * running shell, please remember to do:

 *   # source /etc/profile

calvin mabhobs # source /etc/profile
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum