Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[partly solved] can't emerge "anything"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Thu Jan 03, 2008 9:31 pm    Post subject: [partly solved] can't emerge "anything" Reply with quote

Hello, I am trying to install from a live cd to a mac g4 laptop (15" 1.67ghz). I have come as far as Code Listing 2.1 and cannot get anything to emerge. For example,(emerge --sync) or (emerge-webrsync). I get no response except to return to ">" Any ideas?

An update from the top lines: Sat. 1/5/08
I tried today with network support and a minimal install cd. Things went a bit better, the process progressed as far as compiling the kernel which ended with a failed compilation message with several errors. I don't know how to copy the output directly to post it here. I could use some suggestions about choosing a g4 or ppc version if that makes a difference. Also, I did not specify any special use parameters. I have been being very careful about attention to detail with the manual instructions and don't want to call it quits on this learning curve.
Many thanks to all...
Anthonny


Last edited by anjmar on Sun Jan 06, 2008 1:42 am; edited 2 times in total
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2469
Location: /home/zach

PostPosted: Thu Jan 03, 2008 9:35 pm    Post subject: Reply with quote

Could you please provide more information about the problem? Are you getting an error message? Does the system hang during an emerge? That type of information will help us narrow down your problem.
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Fri Jan 04, 2008 2:38 am    Post subject: NB needs help for Gentoo on mac g4 laptop Reply with quote

Well, I did make a vallient try and managed to get as far as 'Configuring Portage' in the install manual. At this point I could not emerge anything. The notations in (nano -w /mnt/gentoo/etc/make.conf) never seemed to indicate that I had use the correct Stage tarball ( I tried both the "g4" and the "ppc" tarballs and the comments in make.conf continued to suggest I might not have the correct tarball. I am installng from a llive cd on to a 1.67 ghz ppc 15" powerbook. I can get as far as configuring Portage but nothing happens. I had the feeling that I was not getting a correct rsync ( I tried different mirrors with the same results on two different install attempts. I am using a basic partitioning setup and that all seems to get in place properly and mounted etc. but I can't get the install for move into configuring Portage and moving forward..... Help! :?
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2469
Location: /home/zach

PostPosted: Fri Jan 04, 2008 5:08 am    Post subject: Reply with quote

Hello,

I responded to your last post, which seems to be related to this same issue ( https://forums.gentoo.org/viewtopic-t-640274.html ). It will be helpful if you could give some more information. For instance, please post the output of

Code:

emerge --info


and the contents of /etc/fstab

Thanks.
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Fri Jan 04, 2008 4:53 pm    Post subject: Reply with quote

I will try again today. I gave up yesterday and deleted what I had set up. I don't have a internet connection today, so I will try to work with the live cd. Thanks for your input. I will let you know what goes...
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 1:16 am    Post subject: Reply with quote

Hello again, as mentioned I do not have internet access at this time and have gotten as far as installing a Stage3 Tarball. Can I proceed without downloading a Portage snapshot?

Thanks,
Anthony
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2469
Location: /home/zach

PostPosted: Sat Jan 05, 2008 1:29 am    Post subject: Reply with quote

You do need a Portage snapshot, as Portage is the package manager for Gentoo. You could always download it somewhere else, burn it to a CD, and install the snapshot from the CD.
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 1:56 am    Post subject: Reply with quote

Well, according to the manual, there should be a Portage snapshot in my Universall install cd. I get a return of no such file when I try to ls Portage snapshots on the cd. I must have the wrong download burned to cd. I'll try with a different download. I am using Camino to download from mirrors and disk utility to burn the iso. I assume that is a workable method.
Many thanks,
Anthony
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 2:09 am    Post subject: Reply with quote

After talking with a knowledgeable friend, I am going to download new isos and reburn them. I may have browsed the first isos before I burned them to disk...

Thanks for your help so far...
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 4:42 am    Post subject: Reply with quote

New download, same problem... Can't get past the install of Stage3 tarball. Portage snapshot install attempr returns-( Cannot open: No such file or directory ) The cd shows a Portage snapshot when browsed. I'm tryin' here..... Any ideas?.....

Thanks.....
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 5:29 am    Post subject: Reply with quote

Code:

emerge --info


and the contents of /etc/fstab

<emerge --info> returns command not found
</etc/fstab> returns permissioin denied

:?
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Sat Jan 05, 2008 5:39 am    Post subject: Reply with quote

Maybe the problem is, that you don't know where you are during the installation. If you browse your CD and the snapshot is there, then you should be able to get on.

This is the part of the handbook for the networkless install:
Code:

Now that the stage is installed, continue with Installing Portage.

5.c. Installing Portage

Unpacking a Portage Snapshot

You now have to install a Portage snapshot, a collection of files that inform Portage what software titles you can install, which profiles are available, etc.

Unpack the Snapshot from the Installation CD

To install the snapshot, take a look inside /mnt/cdrom/snapshots/ to see what snapshot is available:

Code Listing 3.1: Checking the /mnt/cdrom/snapshots content

# ls /mnt/cdrom/snapshots

Now extract the snapshot using the following construct. Again, make sure you use the correct options with tar. Also, the -C is with a capital C, not c. In the next example we use portage-<date>.tar.bz2 as the snapshot filename. Be sure to substitute with the name of the snapshot that is on your Installation CD.

Code Listing 3.2: Extracting a Portage snapshot

# tar xvjf /mnt/cdrom/snapshots/portage-<date>.tar.bz2 -C /mnt/gentoo/usr

Copy Source Code Archives

You also need to copy over all source code from the Universal Installation CD.

Code Listing 3.3: Copy over source code

# mkdir /mnt/gentoo/usr/portage/distfiles
# cp /mnt/cdrom/distfiles/* /mnt/gentoo/usr/portage/distfiles/


And don't mount the livecd.iso with disk utility when you want to burn it. That was a common mistake with its predecessor.
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 5:52 am    Post subject: Reply with quote

When I say that I browsed the cd, I mean that I checked it after I burned it and the files are visable. I am new at all this and I started by downloading the iso's and draging the iso into disk utility and burning it (disk utility notes disk write status as "not mounted" ). I don't believe it gets mounted when burned it this manner. If I am wrong, please tell me what the proper steps would be. I have been following the manual very carefully and paying attention to detail as best I can.

Many thanks,
Anthony
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Sat Jan 05, 2008 6:21 am    Post subject: Reply with quote

Well, it seems that you have burnt the CD correctly. I remember that disk utility handles this issue better than that app that came before disk utility (or maybe it was even an earlier version of it). If you haven't burnt the iso correctly you probably couldn't boot.

Did you try the steps in the handbook?
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 6:31 am    Post subject: Reply with quote

From the start, I've followed the manual like a dog on a bone !
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
anjmar
n00b
n00b


Joined: 03 Jan 2008
Posts: 11
Location: Minneapolis

PostPosted: Sat Jan 05, 2008 7:12 am    Post subject: Reply with quote

O.K.
I can get as far as having a stage installed and then attempts to get portage results in:
code: ls /mnt/cdrom/snapshots returns: cannot access..... : No such file or directory
tar: says no such file or directory

You got me..... :roll:
_________________
In Praise of Dependent Arising...
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Sat Jan 05, 2008 7:50 am    Post subject: Reply with quote

I think I had that problem once too. Try a ls /mnt/cdrom and look at the output. In my case I had misspelling somewhere.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Jan 05, 2008 12:21 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on PPC.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1609
Location: U.S.A.

PostPosted: Mon Jan 07, 2008 7:39 pm    Post subject: Reply with quote

Has this been resolved or are you still stuck? :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum