Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[NVIDIA] startx plante mon PC (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
remitbo
n00b
n00b


Joined: 09 Jan 2008
Posts: 9
Location: Dunkerque

PostPosted: Wed Jan 09, 2008 4:20 pm    Post subject: [NVIDIA] startx plante mon PC (résolu) Reply with quote

Salut

Je viens d'installer gentoo sur un PC relativement ancien (c'est pas une antiquité non plus) :

Athlon XP 1,6 GHZ
256 Mo de ram
DD 60 GB
SB Live emu10k1
NVIDIA GeForce4 TI 4200 AGP 8x

L'installation du système de base c'est déroulée. le premier boot sur le kernel tout neuf impeccable, je fais une premiere recompilation complète du système.

Ensuite j'installe Xorg, gnome et les nvidia-drivers en suivant le guide gentoo nvidia. Après environ 12 h de compilation ( :? ) je suis enfin près à lancer gdm.

je lance donc un startx (sans avoir toucher xorg.conf, d'ailleurs le fichier n'existais pas) et la mon ecran affiche 'HV frequency over-range'. Je fais une Ctrl-Alt-BackSp. pour revenir en console, je lance 'xorg-reconf', je réponds aux question et je rentre à la main les fréquences de rafraichissement de mon écran trouver sur le site du constructeur.

après dépoussiérage et ajout de quelques options, j'ai le xorg.conf suivant
Code:
Section "Module"
   Load   "dbe"
   Load   "glx"
#   Load   "GLcore"
   Load   "extmod"
   SubSection "extmod"
      Option   "omit wfree86-dga"
   EndSubSection
   Load   "record"
   Load   "xtrap"
   Load   "dri"
   Load   "bitmap"
   Load   "ddc"
   Load   "freetype"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section   "ServerFlags"
   Option   "AIGLX"   "true"
EndSection

Section "Extensions"
   Option   "Composite"   "true"
EndSection

Section "DRI"
   Group   0
   Mode   0666
EndSection

Section "Files"
   FontPath   "/usr/share/fonts/Type1"
   FontPath   "/usr/share/fonts/misc"
   FontPath   "/usr/share/fonts/freefonts"
   FontPath   "/usr/share/fonts/encodings"
   FontPath   "/usr/share/fonts/util"
   FontPath   "/usr/share/fonts/default"
   FontPath   "/usr/share/fonts/corefonts"
   FontPath   "/usr/share/fonts/75dpi"
   FontPath   "/usr/share/fonts/100dpi"
   ModulePath   "/usr/lib/xorg/modules/extensions"
   ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
   Identifier   "Keyboard1"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "fr"
EndSection

Section "InputDevice"
   Identifier   "Mouse1"
   Driver      "mouse"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "auto"
EndSection


Section "Device"
   Identifier   "GeForce4 Ti 4200 AGP 8x"
   Driver      "nvidia"
   Option      "AddARGBGLXVisuals"   "true"
   Option      "TripleBuffer"      "true"
EndSection


Section "Monitor"
   Identifier   "CRT ViewSonic E70"
   HorizSync   30-70
   VertRefresh   50-160
EndSection


Section "Screen"
   Identifier   "Default Screen"
   Device      "GeForce4 Ti 4200 AGP 8x"
   Monitor      "CRT ViewSonic E70"
   DefaultDepth   24
   SubSection "Display"
      Modes   "1024x768"
   EndSubSection
EndSection


Section "ServerLayout"
   Identifier   "Simple Layout"
   Screen      "Default Screen"
   InputDevice   "Mouse1"   "CorePointer"
   InputDevice   "Keyboard1"   "CoreKeyboard"
EndSection

Je relance startx et la mon PC plante completement plus de Ctrl-Alt-BackSp ni rien d'autre. Ecran noir, ssh coupé etc.
après reboot , /var/log/Xorg.0.log ne comporte aucune erreur ( :!: ), tout juste des avertissement comme quoi il ne trouve pas certains dossiers de font. J'ai la même chose quand je commente les lignes concernant les fréquences de rafraîchissement de l'écran.

J'ai essayé pas mal de choses que je n'ai pas mentionné mais là je suis à cours d'idée.
Help please.

Rémi


Last edited by remitbo on Wed Jan 09, 2008 5:40 pm; edited 3 times in total
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Wed Jan 09, 2008 4:31 pm    Post subject: Reply with quote

Et si tu enlèves le dri et l'AIGLX (inutiles, je crois, avec le pilote propriétaire nvidia) ?

Et avec le pilote nv sans composite pour commencer ?
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Wed Jan 09, 2008 4:49 pm    Post subject: Reply with quote

Salut et bienvenue !
Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Wed Jan 09, 2008 4:51 pm    Post subject: Reply with quote

Le Xorg.0.log serait intéressant aussi :)

(un pastebin stp :wink: )
Back to top
View user's profile Send private message
remitbo
n00b
n00b


Joined: 09 Jan 2008
Posts: 9
Location: Dunkerque

PostPosted: Wed Jan 09, 2008 5:39 pm    Post subject: Reply with quote

Merci les gars
DidgeriDude wrote:
Et si tu enlèves le dri et l'AIGLX (inutiles, je crois, avec le pilote propriétaire nvidia) ?

J'avais tester comme ça en premier lieu sans succès. je les ai ajouté juste au cas où (on fait des choses stupides quand on sait plus quoi faire :) )


DidgeriDude wrote:
Et avec le pilote nv sans composite pour commencer ?

impeccable ça fonctionne en lancant /etc/init.d/xdm start 8)

Je vais donc utiliser les drivers libres (c'est pas plus mal :wink: ), mais je ne sais pas s'ils sont aussi efficaces que les propriétaires (peut-etre même plus, qui sait).

Rémi
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Wed Jan 09, 2008 5:40 pm    Post subject: Reply with quote

Si toi vouloir jouer ... toi oublier driver libre :/ ca dommage :cry:
Back to top
View user's profile Send private message
remitbo
n00b
n00b


Joined: 09 Jan 2008
Posts: 9
Location: Dunkerque

PostPosted: Wed Jan 09, 2008 6:20 pm    Post subject: Reply with quote

dapsaille wrote:
Si toi vouloir jouer ... toi oublier driver libre :/ ca dommage :cry:

ça ça m'embête. Pas que je sois gamer (en plus j'ai une autre machine plus performante), mais j'aime bien que mon materiel fonctionne au max de ses capacités (c'est un peu pour ça aussi que je suis gentoo : noyau léger et adapté + programmes optimisés).

Mais bon j'ai pas le courage de me replonger dedans pour l'instant. donc je vous referai signe au besoin si je retente les drivers proprio.

Salut chez vous et bonne année :D !

Rémi
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Wed Jan 09, 2008 6:37 pm    Post subject: Reply with quote

Oui enfin l'affichage en prend un coup avec le driver nv quand même.
Je me rappelle il y a quelques années, j'ai senti la différence avec le driver nvidia, les fenêtres se rafraichissaient plus rapidement, tout ça...
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Wed Jan 09, 2008 7:31 pm    Post subject: Reply with quote

Temet wrote:
Oui enfin l'affichage en prend un coup avec le driver nv quand même.
Je me rappelle il y a quelques années, j'ai senti la différence avec le driver nvidia, les fenêtres se rafraichissaient plus rapidement, tout ça...

Je sais que le driver n'est pas fini, mais ça vaut ptet le coup de tenter avec "nouveau" (y a un overlay : layman -a nouveau)
je m'en sers de temps en temps, pour le tester : la 2D est bien accélérée, c'est super fluide, ça tourne vraiment au poil. Par contre, pour la 3D, c'est pas du tout fini, ça plante grave en général.
Mais ne serait-ce que pour la 2D, ça peut valoir le coup par rapport au driver nv (qui n'a pas de 3D non plus d'ailleurs)

Ah, sinon, a propos du driver nvidia proprio, pour une geforce4, tu as biens limité à la version 96xxx du driver ? les version plus récentent ne sont plus sensées les supporter...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
remitbo
n00b
n00b


Joined: 09 Jan 2008
Posts: 9
Location: Dunkerque

PostPosted: Thu Jan 10, 2008 1:35 pm    Post subject: Reply with quote

guilc wrote:
Ah, sinon, a propos du driver nvidia proprio, pour une geforce4, tu as biens limité à la version 96xxx du driver ? les version plus récentent ne sont plus sensées les supporter...
Oui, j'ai masqué tout ce qui est >= à 0.97 donc je vois pas bien d'ou viens mon plantage, d'autant plus que Xorg.0.log ne mentionne aucune erreur ni avertissement.
Je pense que ca peut venir de ma config kernel. J'ai activé le support Agpart mais je n'ai rien fait d'autre : pas de support framebuffer ni rien d'autre.
Mais comme le "nv" fonctionne bien je vois pas pourquoi le "nvidia" ne fonctionnerai pas. Ce qui me paraît bizarre aussi c'est que l'écran ne supporte pas les valeurs de rafraichissement par défault avec le driver "nvidia". Je l'ai déjà utilisé avec d'autres PC ( eux ce sont vraiment des antiquités : un Pentium 133 32Mo de ram et un Matrox mystique sous debian ainsi qu'un Pentium II 350 128 Mo avec une ATI Rage 128 sous Slackware) et je n'ai jamais eu de souci avec Xorg ou XFree86.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Thu Jan 10, 2008 1:49 pm    Post subject: Reply with quote

Question bête: le driver legacy, il est toujours maintenu par nvidia, ou bien les gens qui l'utilisent sont condamnés à rester à une certaine version du kernel?
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
remitbo
n00b
n00b


Joined: 09 Jan 2008
Posts: 9
Location: Dunkerque

PostPosted: Thu Jan 10, 2008 3:12 pm    Post subject: Reply with quote

El_Goretto wrote:
Question bête: le driver legacy, il est toujours maintenu par nvidia, ou bien les gens qui l'utilisent sont condamnés à rester à une certaine version du kernel?

Ceci pourrait expliquer mon desarroi : j'ai la dernière version du kernel (du moins la stable avec gentoo sources, c'est la 2.6.23-gentoo-r5)

mais si tel était le cas je n'aurais pas pu compiler x11-drivers/nvidia-drivers, où je me gourre ?

Rémi
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Jan 10, 2008 7:00 pm    Post subject: Reply with quote

El_Goretto wrote:
Question bête: le driver legacy, il est toujours maintenu par nvidia, ou bien les gens qui l'utilisent sont condamnés à rester à une certaine version du kernel?

Oui, c'est le principe des versions legacy :

nVidia maintient :
- la Head
- la 96xx
- la 71xx

Les autres version intermédiaires par contre ne sont pas maintenues (et ne s'appellent pas legacy d'ailleurs, dans la nomenclature nVidia)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum