Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gnome-sound] pas de son système
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Thu Nov 29, 2007 10:05 pm    Post subject: [gnome-sound] pas de son système Reply with quote

Bonjour,

cela fait des mois que je n'ai plus de son système sous gnome.
quand je vais dans gnome-sound-properties dans l'onglet "périphériques" et que je teste le son,
j'entend bien un long bip mais lorsque je vais dans l'onglet "sons" les tests ne fonctionnent pas, et aucun message d'erreur.

pourtant si je vais jouer les sons système avec un lecteur audio quelquonque, ça fonctionne!!

c'est à n'y rien comprendre.

z'auriez une idée.?

--
Mobidyc
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Fri Nov 30, 2007 7:52 am    Post subject: Reply with quote

salut,

As-tu été voir le panneau de configuration "multimedia" (ou quelque chose du genre, je ne suis plus sous Gnome depuis un moment) ? Ou alors, est-ce que esound est installé (USE esd) mais le démon non démarré ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Fri Nov 30, 2007 7:05 pm    Post subject: Reply with quote

Salut,

oui dans le panneau "selecteur de multimedia" les tests sons fonctionnent.
par contre j'ai pas activé le use esd, seulement alsa et hal.

esd est indispensable pour avoir les sons systèmes de gnome?

--
Mobidyc
Back to top
View user's profile Send private message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Wed Jan 02, 2008 11:52 am    Post subject: Reply with quote

UP!

je n'ai toujours aucun son système.

lorsque je lance gnome-sound-properties et que je teste les sons système(dans l'onglet "sons"), rien ne se passe, pas d'erreur rien.
voici comment est compilé gnome-control-center (qui contient gnome-sound-properties):
Code:

gnome-base/control-center-2.20.1:
+alsa       : Adds support for media-libs/alsa-lib (Advanced Linux Sound
              Architecture)
+debug^     : Enable extra debug codepaths, like asserts and extra output. If
              you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml .
-eds        : Enables support for Evolution-Data-Server (EDS)
-esd        : Adds support for media-sound/esound (Enlightened Sound Daemon)
+hal        : Enable Hardware Abstraction Layer (HAL) support



"esd" est-il nécessaire/obligatoire pour avoir les sons système? car si c'est le cas, je n'arrive pas à compiler avec ce USE flag.

--
Mobidyc
Back to top
View user's profile Send private message
Animatrix
Guru
Guru


Joined: 13 May 2006
Posts: 480
Location: France - Gard (30)

PostPosted: Wed Jan 02, 2008 12:27 pm    Post subject: Reply with quote

Je crois qu'il faut compiler avec eds.
Mais il faut qu'un autre paquet de gnome, soit compilé avec ce use (je sais plus lequel)
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Jan 02, 2008 6:18 pm    Post subject: Reply with quote

salut,
esound est censé être obligatoire depuis la 2.18 cf : http://www.gentoo.org/proj/fr/desktop/gnome/howtos/gnome-2.18-upgrade.xml
après moi j'ai suivi bêtement les instructions et ne peut pas te confirmer à 100% que c'est réellement obligatoire....
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Wed Jan 02, 2008 6:28 pm    Post subject: Reply with quote

'lut,

me suis recemment posé la question et me suis egalement rendu compte que esd ( daemon ) est obligatoire.
J'etais un peu sur le c... parce qu'en plus esd c'est relatif a enlightenment donc bof bof
Mais , je crois avoir lu que les dev de gnome sont bien au courant ( tu m'etonnes ) de la situation, ils sont en ce moment en train de virer ces dependances pour les remplacer par :?:

EDIT : peut-etre un debut de reponse ;)

et la page traitant le remplacement d'esd ( c'est tout simplement gstreamer )


Last edited by ryo-san on Thu Jan 03, 2008 1:28 am; edited 2 times in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Wed Jan 02, 2008 6:50 pm    Post subject: Reply with quote

... Duke Nukem Forever
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
davidou2a
Guru
Guru


Joined: 15 Dec 2006
Posts: 574
Location: Ajaccio

PostPosted: Thu Jan 03, 2008 9:38 am    Post subject: Reply with quote

il faut aussi le gst-plugins-esd je crois :) et avoir effectivement /etc/init.d/esound de lançé :P
_________________
L'enfer je connais, il s'appelle Windows...
Back to top
View user's profile Send private message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Thu Jan 03, 2008 10:05 am    Post subject: Reply with quote

merci pour ces infos/liens,
je vais tenter de recompiler esd, sinon, voir avec gstreamer.

en attendant, bonne année ;)

--
Mobidyc
Back to top
View user's profile Send private message
neb0jsa
n00b
n00b


Joined: 04 Jan 2008
Posts: 1

PostPosted: Fri Jan 04, 2008 10:06 am    Post subject: Reply with quote

Salut mobydic, dis moi j'ai le meme soucis , je suis en train de regarder ...
J'aimerai connaitre l'option que tu utilises avec emerge pour avoir la liste des variables et leur signification avant compilation :=)
Merci d avance !
Back to top
View user's profile Send private message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Fri Jan 04, 2008 10:11 am    Post subject: Reply with quote

Salut neb0jsa,

j'utilise dep provenant de app-portage/udept
après un simple :
#> dep -u sendmail
mail-mta/sendmail-8.14.0:
-ipv6 : Adds support for IP version 6
-ldap : Adds LDAP support (Lightweight Directory Access Protocol)
-mailwrapper: Adds mailwrapper support to allow multiple MTAs to be installed
+mbox^ : Adds support for mbox (/var/spool/mail) style mail spools
-nis : Support for NIS/YP services
-sasl : Adds support for the Simple Authentication and Security Layer
-sockets : Adds support for tcp/ip sockets
+ssl : Adds support for Secure Socket Layer connections
+tcpd : Adds support for TCP wrappers

plein de bonnes options dans dep aussi par exemple, si tu veux savoir pourquoi un paquet est installé (quel autre paquet le demande):
#> dep -L unzip
app-arch/unzip:
app-text/docbook-xml-dtd-4.1.2-r6 >=app-arch/unzip-5.41
app-text/docbook-xml-dtd-4.3 >=app-arch/unzip-5.41
app-text/docbook-xml-dtd-4.4-r1 >=app-arch/unzip-5.41
www-client/mozilla-firefox-2.0.0.11 app-arch/unzip

--
Mobidyc
Back to top
View user's profile Send private message
debotux
n00b
n00b


Joined: 14 Aug 2007
Posts: 29

PostPosted: Sun Jan 13, 2008 3:11 pm    Post subject: Reply with quote

Je me suis également posé la question d'avoir les sons systèmes sous gnome et voici la solution :

1. Recompiler quelques ebuilds avec le USE esd :
Code:
# Obligatoire :
gnome-base/control-center
gnome-base/libgnome
# Facultatif :
gnome-base/gnome-session (pour avoir les sons de login/logout)

2. Installer les sons système :
Code:
emerge gnome-audio

3. Configuration :
Allez dans Système=>Préférences=>Son, cliquez sur l'onglet "Sons" et cochez les cases :
Code:
Aciver le mixage son logiciel (ESD)
Jouer les sons systèmes

4. Facultatif :
Pour que les sons de login/logout fonctionnent,
Code:
rc-update add esound default


Notes : J'ai également du recompiler esoud avec le USE alsa qui n'y était pas car j'avais un problème de latence sans lui.
Je précise que je suis en full stable x86.

++'ll

debotux
Back to top
View user's profile Send private message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Mon Jan 14, 2008 7:58 pm    Post subject: Reply with quote

Hello,

effectivement esd n'est pas activé chez moi pour libgnome ni gnome-session.

je recompile en espérant que ça va marcher ;)

merci pour le tuto

--
Mobidyc
Back to top
View user's profile Send private message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Mon Jan 14, 2008 8:11 pm    Post subject: Reply with quote

ça y est, ça marche.

merci beaucoup ;)

--
Mobidyc
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum