Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
building for G3 on G4 ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Sat Jan 26, 2008 7:06 pm    Post subject: building for G3 on G4 ? Reply with quote

how would i do that accurately ? Is the main difference between both that G3s have no altivec ?
If thats true, do i need a complete new toolchain or is there some way to just (temporaly) disable altivec in my current one ?

TIA
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Jan 26, 2008 7:13 pm    Post subject: Reply with quote

If all you're trying to do is building for a G3, simply set the compiler flags properly and compile the package(s). Just make sure anything it depends on doesn't have altivec support compiled in. If you are using your G4 as host to compile for another G3 machine, setup a chroot for the G3 target and build everything for the G3 in the chroot.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Sat Jan 26, 2008 8:05 pm    Post subject: Reply with quote

thanks for your quick reply :)
yes, i was thinking about building G3 compatible packages on a G4 alubook.

If chroot isnt a choice ( i think i wont have much room to play in this lappy) would a altivec disabled toolchain do the trick ? I mean f.ex. installing another target with crossdev, explicitely disabling altivec ? Does that make sense or is there something easier ?

thanks !
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Feb 04, 2008 2:10 pm    Post subject: Reply with quote

You don't need to remove altivec from your toolchain, the same toolchain that built for your G4 will build the same packages for G3 by simply changing the CFLAGS. However, some packages do autodetect altivec, these packages would be better built on a G3.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Feb 06, 2008 11:47 am    Post subject: Reply with quote

i was trying to build a G3 compatible package of openoffice but, if i got your last answer right, it looks like i won´t be able to do this on my alubook, right ?

thanks !
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum