Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I need to update my packages/modules for upgrade to .24 krnl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 703
Location: Billings, MT, USA

PostPosted: Sat Jan 26, 2008 6:06 pm    Post subject: I need to update my packages/modules for upgrade to .24 krnl Reply with quote

I want to upgrade all my systems to the .24 kernel, but what do I need to do about the modules/packages that depend on the kernel?

I know I need to re-emerge them, but how do I find out which ones I need to?
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Sat Jan 26, 2008 6:23 pm    Post subject: Reply with quote

Code:
dep -L virtual/linux-sources
Back to top
View user's profile Send private message
psomas
Retired Dev
Retired Dev


Joined: 23 Sep 2006
Posts: 212
Location: Greece

PostPosted: Sat Jan 26, 2008 6:28 pm    Post subject: Reply with quote

or you could emerge module-rebuild... ;)

however, some modules may not compile with2.6.24 kernel...
psomas wrote:
AM088 wrote:
Maybe I'll try iwlwifi, but I still can't use VirtualBox or my WebCam...

Here's another post where someone can't build an external module:
https://forums.gentoo.org/viewtopic-t-651875-highlight-.html

http://archives.gentoo.org/gentoo-dev/msg_150497.xml
http://tsunam.org/2008/01/25/kernel-development-2624/
https://bugs.gentoo.org/show_bug.cgi?id=207383

2.6.24 is not stable yet...
there are some regressions with some portage packages-modules...
some work(nvidia-drivers compile without probs with 2.6.24) without any modidication and some don't work yet...
but i think that this will be solved soon...

_________________
myblog
FOSS NTUA Community
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Sat Jan 26, 2008 6:42 pm    Post subject: Reply with quote

Module-rebuild won't rebuild packages. For example such as hal, hplip, iptables, lm_sensor, etc.

btw similar to dep is to use:
Code:
equery d linux-sources
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 703
Location: Billings, MT, USA

PostPosted: Sat Jan 26, 2008 7:18 pm    Post subject: Reply with quote

Thanks for the quick reply.

The only modules I use is ndiswrapper for one system (darn Inprocomm PITA) and rt2x00 on another as an AP.

At least the Inprocomm is client only. It connects via a Cantenna to my access point (parents..)

I did find when I emerged the latest kernel that NOTHING is set up, so I ended up using my old .config file from .23-r6 and tweaking it up a little.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum