Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] choisir sa version de python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
MARACHE
n00b
n00b


Joined: 18 Jun 2004
Posts: 35

PostPosted: Tue Dec 18, 2007 3:24 pm    Post subject: [emerge] choisir sa version de python Reply with quote

Bonjour,

j'ai un problème avec les versions de python.
La situation:
-- /usr/bin/python/ pointe vers /usr/bin/python2.5
-- zope utilise python2.4
-- le zproduit zpsycopgda utilise le package python psycopg-1.1.21
-- emerge installe psycopg dans python2.5/site-package
-- zope ne trouve pas psycopg

bref, ma question est la suivante: je pense que je dois compiler psycopg avec python2.4, pour cela dois-je changer temporairement le lien comme suggère boozo en le faisant pointer vers python2.4 ou y a-t-il une autre méthode qui serait préférable?

Etienne

PS pour plus de détail voir fil parallèle «Z psycopg n'apparait pas dans Select type to add».
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Tue Dec 18, 2007 3:32 pm    Post subject: Reply with quote

n'y a-t-il pas un module python avec eselect ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Alexis
Developer
Developer


Joined: 25 Jun 2004
Posts: 241

PostPosted: Tue Dec 18, 2007 4:12 pm    Post subject: Reply with quote

ou alors tu peux aussi utiliser "python-updater" pour tout passer en python 2.5
Back to top
View user's profile Send private message
MARACHE
n00b
n00b


Joined: 18 Jun 2004
Posts: 35

PostPosted: Tue Dec 18, 2007 4:30 pm    Post subject: Reply with quote

Tu peux préciser Xavier ? J'ai jeté un oeil sur eselect, cela n'a pas l'air fait pour moi, jai déjà bien du mal avec les commandes de base de portage.

As-tu bien lu Alexis? Ou c'est moi qui ne sais pas tout? Je crois que zope ne fonctionne pas avec python2.5. D'ailleurs bien que mon python soit 2.5, il va chercher le 2.4 pour son installation.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Tue Dec 18, 2007 6:58 pm    Post subject: Reply with quote

désolé, pas vu de "eselect python" :(
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Tue Dec 18, 2007 6:59 pm    Post subject: Reply with quote

MARACHE wrote:
jai déjà bien du mal avec les commandes de base de portage.


Hé bien, au boulot ! Sinon, tu vas te sentir frustré et en punition, on te forcera à passer à Ubunutu :lol:
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Mon Feb 11, 2008 4:17 pm    Post subject: Reply with quote

XavierMiller wrote:
désolé, pas vu de "eselect python" :(


juste pour signaler que désormais il existe :wink:
Code:
[I] app-admin/eselect-python
     Available versions:  (~)20080124
     Installed versions:  20080124(15:58:55 11.02.2008)
     Homepage:            http://www.gentoo.org
     Description:         Manages multiple Python versions

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum