Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] PyQt 3.17.3 won't compile
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message

Joined: 10 Mar 2004
Posts: 262
Location: Regina, SK Canada

PostPosted: Mon Feb 11, 2008 1:11 am    Post subject: [SOLVED] PyQt 3.17.3 won't compile Reply with quote

Getting this error:


x86_64-pc-linux-gnu-g++ -c -pipe -fPIC -march=k8 -O2 -pipe -fno-strict-aliasing -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -I. -I/usr/include/python2.5 -I/usr/qt/3/mkspecs/linux-g++ -I/usr/qt/3/include -I/usr/X11R6/include -o sipqtQUrl.o sipqtQUrl.cpp
sipqtQUrl.cpp: In function 'PyObject* slot_QUrl___ne__(PyObject*, PyObject*)':
sipqtQUrl.cpp:1381: error: 'class QUrl' has no member named 'operator!='
sipqtQUrl.cpp:1395: error: 'class QUrl' has no member named 'operator!='
make[1]: *** [sipqtQUrl.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/dev-python/PyQt-3.17.3/work/PyQt-x11-gpl-3.17.3/qt'
make: *** [all] Error 2
 * ERROR: dev-python/PyQt-3.17.3 failed.
 * Call stack:
 *  , line 1701:  Called dyn_compile
 *  , line 1039:  Called qa_call 'src_compile'
 *  , line   44:  Called src_compile
 *   PyQt-3.17.3.ebuild, line   45:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/PyQt-3.17.3/temp/build.log'.

Emerge --info

Portage (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r6 x86_64)
System uname: 2.6.23-gentoo-r6 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
Timestamp of tree: Sun, 10 Feb 2008 08:46:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
CFLAGS="-march=k8 -O2 -pipe -msse3"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/nx /usr/local/portage"
USE="3dnow 3dnowext 7zip X a52 aac aalib acl acpi alsa amd64 apache2 apm ares automount berkdb bitmap-fonts bzip2 cddb cdparanoia cli cpudetection cracklib crypt css ctype cups dbus directfb divx dri dts dv dvd dvdnav dvdr dvdread ecc encode esd exif fame fasttrack ffmpeg firefox flac foomaticdb ftp gd gdbm gif gmedia gnutella gnutls gphoto2 gpm gs hal hddtemp iconv idea ieee1394 imagemagick imlib insecure-savers isdnlog javascript jce jpeg jpeg2k kde kqemu lame lm_sensors lzo mad midi mjpeg mmx mmxext mp2 mp3 mpeg mplayer mudflap musepack musicbrainz mysql mysqli ncurses nls nptl nptlonly nsplugin offensive ogg openft opengl openmp pam pcre pdf perl png pnm ppds python qt3 qt3support qt4 quicktime rar rdesktop readline realmedia reflection rle rtc samba sdl session signatures slp sound speex spell spl sse sse2 ssl ssse3 svg swat symlink syslog tcpd theora tidy tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd vhosts vnc vorbis vorbis-psy wavpack wideband wifi winbind wma wmf wmp x264 xine xml xorg xpm xprint xscreensaver xvid zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nv nvidia"

Last edited by infecticide on Mon Feb 11, 2008 2:08 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 30 Sep 2007
Posts: 605
Location: Manchester, CT, USA

PostPosted: Mon Feb 11, 2008 2:00 am    Post subject: Reply with quote

Looks like you have to update to the latest testing version, PyQt-3.17.4
[SOLVED] I think I broke it. (emerge world problem)
Gentoo is the stick-shift of Linux.
You work it manually, it has somewhat better performance, but it's really for the fun of it.
Back to top
View user's profile Send private message

Joined: 10 Mar 2004
Posts: 262
Location: Regina, SK Canada

PostPosted: Mon Feb 11, 2008 2:09 pm    Post subject: Reply with quote

Thanks Om,

I had to add PyQt to the package.keywords file to obtain version 3.17.4 and it compiled successfully.
Back to top
View user's profile Send private message

Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Mon Feb 11, 2008 3:23 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.
_________________ || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum