Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-libs/openmotif-2.3.0-r1 ebuild error ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Fri Mar 07, 2008 12:54 pm    Post subject: x11-libs/openmotif-2.3.0-r1 ebuild error ? Reply with quote

Quote:

Calculating dependencies ... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) x11-libs/openmotif-2.3.0-r1 to /
* openmotif-2.3.0.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking openmotif-2.3.0.tar.gz ;-) ... [ ok ]
/usr/portage/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild: line 40: unexpected argument `(' to conditional binary operator
/usr/portage/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild: line 40: syntax error near `(o'
/usr/portage/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild: line 40: ` if [[ -L "${i}" && $(readlink "${i}") =~ (openmo|less)tif- ]]; then'
*
* ERROR: x11-libs/openmotif-2.3.0-r1 failed.
* Call stack:
* ebuild.sh, line 1696: Called die
* The specific snippet of code:
* source "${EBUILD}" || die "error sourcing ebuild"
* The die message:
* error sourcing ebuild
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-libs/openmotif-2.3.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-libs/openmotif-2.3.0-r1/temp/die.env'.
*

* Messages for package x11-libs/openmotif-2.3.0-r1:

*
* ERROR: x11-libs/openmotif-2.3.0-r1 failed.
* Call stack:
* ebuild.sh, line 1696: Called die
* The specific snippet of code:
* source "${EBUILD}" || die "error sourcing ebuild"
* The die message:
* error sourcing ebuild
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-libs/openmotif-2.3.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-libs/openmotif-2.3.0-r1/temp/die.env'.
*
Back to top
View user's profile Send private message
ulm
Developer
Developer


Joined: 04 Oct 2004
Posts: 92
Location: Mainz, Germany

PostPosted: Fri Mar 07, 2008 4:47 pm    Post subject: Re: x11-libs/openmotif-2.3.0-r1 ebuild error ? Reply with quote

ddc wrote:

/usr/portage/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild: line 40: unexpected argument `(' to conditional binary operator
/usr/portage/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild: line 40: syntax error near `(o'
/usr/portage/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild: line 40: ` if [[ -L "${i}" && $(readlink "${i}") =~ (openmo|less)tif- ]]; then'

Looks like it doesn't work with bash versions <3.2.
Can you report this as a bug please?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum