Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Improving PS3 X resolution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
pmatos
Veteran
Veteran


Joined: 06 Jun 2003
Posts: 1220
Location: Cambridge, UK

PostPosted: Wed Mar 12, 2008 7:57 pm    Post subject: Improving PS3 X resolution Reply with quote

Hello all,

I am using PS3 with a Std resolution TV. I cannot obviously expect a superb resolution but two things are quite strange:
    The image seems to be constantly shaking which is enough to hurt my eyes after a while;

    The image does not fill the TV screen completely. There's a huge (2cm) border around the whole tv screen;


My question is... are these known issues? Any way to improve them?

My X config follows:
Code:
# XFree86 4 configuration - mtb test for ps2 livecd
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen  0      "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
        RgbPath      "/usr/share/X11/rgb"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/X11/fonts/misc/"
        FontPath     "/usr/share/X11/fonts/TTF/"
        FontPath     "/usr/share/X11/fonts/Type1/"
        FontPath     "/usr/share/X11/fonts/75dpi/"
        FontPath     "/usr/share/X11/fonts/100dpi/"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Unknown monitor"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "fbdev"
        Option "ShadowFB" "false"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth 24
        DefaultFbBpp 32
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "DRI"
        Group        0
        Mode         0666
EndSection
Back to top
View user's profile Send private message
ArchCC
n00b
n00b


Joined: 26 Mar 2008
Posts: 1

PostPosted: Wed Mar 26, 2008 3:32 pm    Post subject: Reply with quote

This is not problem of X's, this is problem of Kboot.conf.

Code:
Changing Resolution:
Edit /etc/kboot.conf using any editor and add a special parameter at the end of the kernel line:

linux="/boot/vmlinux-2.6.16 initrd=/boot/initrd.img video=ps3fb:mode:3"

Here's the full list of mode-ids
0: auto mode , default value
YUV 60Hz 1:480i 2:480p 3:720p 4:1080i 5:1080p
YUV 50Hz 6:576i 7:576p 8:720p 9:1080i 10:1080p
RGB 60Hz 33:480i 34:480p 35:720p 36:1080i 37:1080p
RGB 50Hz 38:576i 39:576p 40:720p 41:1080i 42:1080p
VESA 11:WXGA 12:SXGA 13:WUXGA

Just change the mode:X to reflect your resolution's mode-id. Reboot and it should use the new resolution settings. Give me a holler if it doesn't. I'll look for alternatives.
(c) http://forums.qj.net/f-ps3-linux-283/t-ps3-linux-faq-thread-78750.html


Basic I'am use mode:5 it's have the same border like you, i saw some topic with advice to add 128 to all mode(in my case this mean mode:133), because some kind of errors. It's help, but resolution sets to few pixsels more than FHD for my tv... I am don't try to use others mode, becouse have other problems and haven't much time to solve this ^_^

[ADD]
http://ps3wiki.qj.net/index.php/PS3_Video_Mode find good instruction ^_^
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum