Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage refuses to use cdrom packages, PPC 2007.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
tobias_r33per
n00b
n00b


Joined: 16 Mar 2008
Posts: 6

PostPosted: Sun Mar 16, 2008 9:44 pm    Post subject: Portage refuses to use cdrom packages, PPC 2007.0 Reply with quote

I have Gentoo 2007.0 PPC, and G4 Packages CD.
To install on a Powerbook G4 "15.4 1.33Ghz 2GB 160GB ATI 9700 64MB Leopard 10.5.1

I have installed the system fine from the Install CD, stage3-g4 & portage snapshot-2007.0. Also used distfiles from liveCD and gentoo-sources from the same (genkernel 2.6.19). Basically it was a networkless install. BUT after i booted the system and got to the stage of emerging the system, i insert the package cd using the following still the machine refuses to use the packages on the cd and treis the repositories for the files.

Code:

# export PKGDIR="/mnt/cdrom"
# emerge --usepkg kde

OR

# export PKGDIR="/mnt/cdrom"
# emerge --usepkg gnome


bith of these produce the same issue? i dont get it i have never had this issue before on a gentoo installation, but i have never built for PPC before.

Anyone have any ideas :(
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Sun Mar 16, 2008 11:52 pm    Post subject: Reply with quote

Stupid question: did you mount the cd? Or if you were relying on automounting,
checked that the cd was mounted _and_ that PKGDIR was actually at the root
level of the cd filesystem? Shouldn't it be in some folder?
Back to top
View user's profile Send private message
tobias_r33per
n00b
n00b


Joined: 16 Mar 2008
Posts: 6

PostPosted: Sun Mar 16, 2008 11:59 pm    Post subject: Reply with quote

Yeah :)

i did think that at one stage, but alas no

and it does seem odd but the g4 packages disc has all the packages in the root of the cd?
but all the other package cd's ive ever used for gentoo on other systems have had them sorted into the different catagories like app-kde
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Mon Mar 17, 2008 12:10 am    Post subject: Reply with quote

Actually what "error messages" or just "messages" do you get from portage,
it may enlighten me or other people around here.
I fact try with "-Kv" (or --usepkgonly --verbose if you prefer the long form) there may be
more interesting output with that.
Back to top
View user's profile Send private message
tobias_r33per
n00b
n00b


Joined: 16 Mar 2008
Posts: 6

PostPosted: Mon Mar 17, 2008 12:45 am    Post subject: Reply with quote

the actual output of portage -Kv "package" i will have to check tonight, but
when i run a package with just --usepkg it no check the local or the cd it will just skip straight to the internet repositories.

i do remember having this trouble with 2005.1 but i did fix it and could not remember for i fixed it :(
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Mon Mar 17, 2008 8:57 am    Post subject: Reply with quote

just guessing but ... you haven´t run emerge --sync, didn´t you ?

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
tobias_r33per
n00b
n00b


Joined: 16 Mar 2008
Posts: 6

PostPosted: Tue Mar 18, 2008 1:47 am    Post subject: Reply with quote

Well i tried and it seems the checking for ebuild section returns [ebuild N] on all packages,

I hav'nt run emerge --sync yet but thats kinda only useful if you have a active net connection right?
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Tue Mar 18, 2008 8:19 am    Post subject: Reply with quote

tobias_r33per wrote:
Well i tried and it seems the checking for ebuild section returns [ebuild N] on all packages,
I hav'nt run emerge --sync yet but thats kinda only useful if you have a active net connection right?


oops, you´re right of course, i thought that you maybe synced the tree and therefore portage was looking for other (newer) versions that you might have not available on the package cd. I suppose all the packages you have available are stable versions.

What does it say when you force it to merge it giving a version number, something like fb said above ?
F.ex. emerge -Kav =kde-3.5.8 ?

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
tobias_r33per
n00b
n00b


Joined: 16 Mar 2008
Posts: 6

PostPosted: Wed Mar 19, 2008 3:31 am    Post subject: Reply with quote

well it seems i have given use and connected the laptop to the interwebs....

emerge --sync

and then.....

magic, it all works now... not the way i wished but anyways have to download newer packages now but never mind, just wish i knew why it wouldnt emerge from the packages cd???
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Mar 19, 2008 10:56 pm    Post subject: Reply with quote

I think the directions are still wrong in the handbook (my fault, sorry!) but if you mount the package CD at /usr/portage/packages/All I think it works.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
tobias_r33per
n00b
n00b


Joined: 16 Mar 2008
Posts: 6

PostPosted: Thu Mar 20, 2008 1:33 am    Post subject: Reply with quote

waoh!!!! 8O i thought that may be the case but i wasnt sure...

its ok i couldnt build my laptop via the net anyways cause it has been down for the last 2 days, had to post from another machine.

But i will try to build it using that command and see what happens.

in a new partition of course :o
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum