Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Problème avec gnome-desktop [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
smu
n00b
n00b


Joined: 13 May 2006
Posts: 28

PostPosted: Sun Mar 23, 2008 7:40 pm    Post subject: [emerge] Problème avec gnome-desktop [Résolu] Reply with quote

B'soir,

Je souhaiterais m'essayer à C# donc je me décide à installer monodevelop mais le paquet gnome-desktop est récalcitrant.

Voilà le sortie console :

Quote:
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/desktop-docs/fdl'
xsltproc -o fdl-C.omf --stringparam db2omf.basename fdl --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DT
D DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/
usr/share/gnome/help" --stringparam db2omf.omf_in "/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/deskto
p-docs/fdl/fdl.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` C/fdl.xml || { rm -f "fdl-C.omf"; exit 1; }
xsltproc -o fdl-fr.omf --stringparam db2omf.basename fdl --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//D
TD DocBook XML V4.1.2//EN" --stringparam db2omf.lang fr --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir
"/usr/share/gnome/help" --stringparam db2omf.omf_in "/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/desk
top-docs/fdl/fdl.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` fr/fdl.xml || { rmoil -f "fdl-fr.omf"; exit 1; }
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/desktop-docs/fdl'
Making all in gpl
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/desktop-docs/gpl'
if ! test -d fr/; then mkdir fr/; fi
if [ -f "C/gpl.xml" ]; then d="../"; else d="/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/desktop-docs
/gpl/"; fi; \
(cd fr/ && \
`which xml2po` -e -p \
"${d}fr/fr.po" \
"${d}C/gpl.xml" > gpl.xml.tmp && \
cp gpl.xml.tmp gpl.xml && rm -f gpl.xml.tmp)
xsltproc -o gpl-C.omf --stringparam db2omf.basename gpl --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DT
D DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/
usr/share/gnome/help" --stringparam db2omf.omf_in "/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/deskto
p-docs/gpl/gpl.omf.in" `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` C/gpl.xml || { rm -f "gpl-C.omf"; exit 1; }
Traceback (most recent call last):
File "/usr/bin/xml2po", line 35, in <module>
import libxml2
ImportError: No module named libxml2
make[3]: *** [fr/gpl.xml] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/desktop-docs/gpl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3/desktop-docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/work/gnome-desktop-2.20.3'
make: *** [all] Error 2
*
* ERROR: gnome-base/gnome-desktop-2.20.3 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 620: Called gnome2_src_compile
* environment, line 550: Called die
* The specific snippet of code:
* emake || die "compile failure"
* The die message:
* compile failure
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-desktop-2.20.3/temp/environment'.
*


Et voici le résultat d'un emerge --info :
Quote:
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r9 i686)
=================================================================
System uname: 2.6.23-gentoo-r9 i686 Intel(R) Pentium(R) M processor 1.73GHz
Timestamp of tree: Sun, 23 Mar 2008 10:46:01 +0000
app-shells/bash: 3.2_p17-r1
dev-lang/python: 2.4.3-r4, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox: 1.2.18.1-r2
sys-devel/autoconf: 2.13, 2.61-r1
sys-devel/automake: 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/zugaina /usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl bash-completion berkdb cli cracklib crypt cups dri exif fortran gdbm gif gpm iconv ipv6 isdnlog jpeg jpeg2k midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl png pppd python qt3support qt4 readline reflection session spl ssl tcpd tiff unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="radeon flgrx vesa"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Si un participant a une idée sur le problème, je suis preneur.

smu


Last edited by smu on Mon Mar 24, 2008 10:00 am; edited 1 time in total
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Sun Mar 23, 2008 8:12 pm    Post subject: Reply with quote

bonsoir,

Je n'ai pas gnome ; je ne connais rien au c# :wink:

mais ta sortie d'erreur donne
Quote:
File "/usr/bin/xml2po", line 35, in <module>
import libxml2
ImportError: No module named libxml2

donc question :
as-tu
Quote:
libxml2
d'installé ?
"chez-moi"
Code:
eix libxml2
[I] dev-libs/libxml2
     Available versions:  (2)  2.6.30-r1 (~)2.6.31
   {bootstrap build debug doc examples ipv6 python readline test}
     Installed versions:  2.6.31(2)(23:52:54 09.03.2008)(python readline -bootstrap -build -debug -doc -examples -ipv6 -test)
     Homepage:            http://www.xmlsoft.org/
     Description:         Version 2 of the library to manipulate XML files
bonne chance :jlp
Back to top
View user's profile Send private message
smu
n00b
n00b


Joined: 13 May 2006
Posts: 28

PostPosted: Sun Mar 23, 2008 8:56 pm    Post subject: Reply with quote

B'soir,

Merci pour la piste mais libxml2 est bien installé...

smu
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Mar 23, 2008 9:06 pm    Post subject: Reply with quote

installe le avec le USE python.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr


Last edited by Desintegr on Sun Mar 23, 2008 9:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
smu
n00b
n00b


Joined: 13 May 2006
Posts: 28

PostPosted: Sun Mar 23, 2008 9:32 pm    Post subject: Reply with quote

B'soir,

C'est le cas...

smu
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Mar 23, 2008 9:36 pm    Post subject: Reply with quote

Réinstalle le car il est surement mal installé. Le module libxml2.py ne doit pas être installé sur ton système :
Code:
equery f libxml2 | grep /libxml2.py$
/usr/lib64/python2.5/site-packages/libxml2.py

_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
smu
n00b
n00b


Joined: 13 May 2006
Posts: 28

PostPosted: Mon Mar 24, 2008 7:53 am    Post subject: Reply with quote

B'jour,

La commande me donne :

Quote:

equery f libxml2 | grep /libxml2.py$
/usr/lib/python2.4/site-packages/libxml2.py


Est ce que cela pourrait être un problème de chemin d'accès ?

smu
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Mon Mar 24, 2008 8:29 am    Post subject: Reply with quote

Python 2.5 est installé sur ta machine et il est surement utilisé lors de l'installation des logiciels.
Le module python libxml2 est installé pour Python 2.4 uniquement sur ta machine, c'est surement cela qui pose problème.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
smu
n00b
n00b


Joined: 13 May 2006
Posts: 28

PostPosted: Mon Mar 24, 2008 10:00 am    Post subject: Reply with quote

B'jour,

Finalement, j'ai réinstallé libxml2 sur ton conseil et cela fonctionne. Effectivement, j'ai python2.5 d'installer.

Merci

smu
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Mar 24, 2008 10:17 am    Post subject: Reply with quote

As tu lancé :
Code:
python-updater
lorsque que tu as fait la mise à jour de python-2.4 vers python-2.5?
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Sun Mar 30, 2008 12:59 am    Post subject: Reply with quote

i know that this is the French subforum, but i had exactly the same problem. Using the python USE flag worked
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum