Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
configure cannot find 'threads' library when emerging glibc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Corvinian
n00b
n00b


Joined: 07 Sep 2007
Posts: 42
Location: Europe

PostPosted: Tue Oct 20, 2009 8:23 am    Post subject: configure cannot find 'threads' library when emerging glibc Reply with quote

Hi,

I have a problem with my recent emerge-run:
emerge, specifically the configure-script cannot find 'threads' library when re-emerging glib

Code:
>>> Unpacking source...
>>> Unpacking glib-2.20.5.tar.bz2 to /var/tmp/portage/dev-libs/glib-2.20.5/work
>>> Source unpacked in /var/tmp/portage/dev-libs/glib-2.20.5/work
>>> Preparing source in /var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5 ...
 * Applying glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch ...
  [ ok ]
 * Applying glib-2.12.12-fbsd.patch ...
  [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5 ...
[...]
checking for sys/inotify.h... yes
checking for inotify_init1... yes
Not building FAM support
checking for platform-dependent source...
checking whether to compile timeloop... yes
checking if building for some Win32 platform... no
checking for thread implementation... posix
checking thread related cflags... -D_REENTRANT
checking for pthread_create/pthread_join... no
checking for pthread_create/pthread_join in -lpthread... no
checking for pthread_create/pthread_join in -lpthread32... no
checking for pthread_create/pthread_join in -lpthreads... no
checking for pthread_create/pthread_join in -lthread... no
checking for pthread_create/pthread_join in -ldce... no
configure: error: I can't find the libraries for the thread implementation
      posix. Please choose another thread implementation or
      provide information on your thread implementation.
      You can also run 'configure --disable-threads'
      to compile without thread support.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5/config.log
 *
 * ERROR: dev-libs/glib-2.20.5 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 2856:  Called econf '--disable-xattr' '--disable-man' '--disable-gtk-doc' '--disable-fam' '--disable-selinux' '--enable-static' '--enable-regex' '--with-pcre=internal' '--with-threads=posix'
 *               ebuild.sh, line  534:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/dev-libs:glib-2.20.5:20091020-073452.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-2.20.5/temp/environment'.
 *



Code:
emerge -s pth
Searching...
[ Results for search key : pth ]
[ Applications found : 1 ]

*  dev-libs/pth
      Latest version available: 2.0.6
      Latest version installed: 2.0.6
      Size of files: 632 kB
      Homepage:      http://www.gnu.org/software/pth/
      Description:   GNU Portable Threads
      License:       LGPL-2.1



'pth' should 'install' the threads-libraries as far as I know.


- my 'emerge --info':
Code:

Portage 2.1.6.13 (hardened/linux/x86/10.0, gcc-3.4.6, glibc-2.9_p20081201-r2, 2.6.20-hardened-r6 i686)
=================================================================
System uname: Linux-2.6.20-hardened-r6-i686-Intel-R-_Core-TM-2_Duo_CPU_T5250_@_1.50GHz-with-gentoo-1.12.11.1
Timestamp of tree: Tue, 20 Oct 2009 07:00:01 +0000
app-shells/bash:     4.0_p28
dev-lang/python:     2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--deep --with-bdeps y"
FEATURES="buildsyspkg distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500 --exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/om"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups curl dri gdbm gpm hardened iconv isdnlog modules mudflap ncurses nls nptl nptlonly openmp pam pcre perl pic pppd python readline reflection session spl ssl sysfs tcpd urandom x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1    emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m    maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config log_forensic logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 imstt intel    mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage    siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware    voodoo"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS



'pth' should 'install' the threads-libraries as far as I know.

I did not update the Gentoo virtual machine for almost two months, but this should be no problem.
What's wrong here?

Grateful for any help or hints :)
Back to top
View user's profile Send private message
sera
Retired Dev
Retired Dev


Joined: 29 Feb 2008
Posts: 1017
Location: CET

PostPosted: Tue Oct 20, 2009 8:36 am    Post subject: Reply with quote

Code:
euse -i nptlonly
global use flags (searching: nptlonly)
************************************************************
no matching entries found

local use flags (searching: nptlonly)
************************************************************
[+  D ] nptlonly (sys-libs/glibc):
Disables building the linuxthreads fallback in glibc ebuilds that support building both linuxthread and nptl


You have enabled this useflag.

Updating your kernel might be necessary as nptl is not just a user space library.
Back to top
View user's profile Send private message
loki_val
Retired Dev
Retired Dev


Joined: 13 Nov 2006
Posts: 408
Location: Denmark

PostPosted: Tue Oct 20, 2009 9:16 am    Post subject: Reply with quote

Please Post: /var/tmp/portage/dev-libs/glib-2.20.5/work/glib-2.20.5/config.log
Back to top
View user's profile Send private message
Corvinian
n00b
n00b


Joined: 07 Sep 2007
Posts: 42
Location: Europe

PostPosted: Tue Oct 20, 2009 9:55 am    Post subject: Reply with quote

sera wrote:
Code:
euse -i nptlonly
global use flags (searching: nptlonly)
************************************************************
no matching entries found

local use flags (searching: nptlonly)
************************************************************
[+  D ] nptlonly (sys-libs/glibc):
Disables building the linuxthreads fallback in glibc ebuilds that support building both linuxthread and nptl


You have enabled this useflag.
Updating your kernel might be necessary as nptl is not just a user space library.


I cannot recompile/-configure kernel now - too much workload.
Can I change the useflag (in removing local ntplonly-flag), so I do not need to recompile kernel right now?
Back to top
View user's profile Send private message
Corvinian
n00b
n00b


Joined: 07 Sep 2007
Posts: 42
Location: Europe

PostPosted: Tue Oct 20, 2009 10:04 am    Post subject: long config.log, part1 Reply with quote

[deleted snippet and posted URL to logfile]

Last edited by Corvinian on Tue Oct 20, 2009 10:27 am; edited 1 time in total
Back to top
View user's profile Send private message
Corvinian
n00b
n00b


Joined: 07 Sep 2007
Posts: 42
Location: Europe

PostPosted: Tue Oct 20, 2009 10:26 am    Post subject: Reply with quote

sorry, I cannot add the log here, even tried small snippets, but the full log is here:

http://selfnotes.net/56a5324139cf4cf4b5348d7bb5eb357b
Back to top
View user's profile Send private message
loki_val
Retired Dev
Retired Dev


Joined: 13 Nov 2006
Posts: 408
Location: Denmark

PostPosted: Tue Oct 20, 2009 10:41 am    Post subject: Reply with quote

sera is probably right. This looks like bug 276212. A user there reported upgrading the kernel solved the problem
Back to top
View user's profile Send private message
sera
Retired Dev
Retired Dev


Joined: 29 Feb 2008
Posts: 1017
Location: CET

PostPosted: Tue Oct 20, 2009 10:51 am    Post subject: Reply with quote

Corvinian wrote:
I cannot recompile/-configure kernel now - too much workload.
Can I change the useflag (in removing local ntplonly-flag), so I do not need to recompile kernel right now?


You are using "virtual/os-headers: 2.6.27-r2". Quite a difference to the actual kernel in use. So updating the kernel could work on it's own and as far as I recall 2.6.20 to 2.6.22 had severe security leaks.

Removing the nptlonly use flag and recompile glibc is an alternative but I suspect not what you want either and also not guaranteed to succeed.
Back to top
View user's profile Send private message
sera
Retired Dev
Retired Dev


Joined: 29 Feb 2008
Posts: 1017
Location: CET

PostPosted: Tue Oct 20, 2009 10:57 am    Post subject: Reply with quote

loki_val wrote:
sera is probably right. This looks like bug 276212. A user there reported upgrading the kernel solved the problem


Lucky guess :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum