Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVidia: new BETA-driver [173.08]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ejs76
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2004
Posts: 148

PostPosted: Fri Apr 11, 2008 1:10 am    Post subject: NVidia: new BETA-driver [173.08] Reply with quote

From:
http://www.nvnews.net/vbulletin/showthread.php?s=009e612a7420c4db99bcdf52516bbd5a&t=111460

Quote:

Release Highlights:

* Added support for the following new GPUs:
o Quadro FX 3600M
o GeForce 9800 GX2
o GeForce 9800 GTX
o GeForce 9600 GT
o GeForce 9500M GS
o GeForce 8400
o GeForce 8400 GS
* Added support for Quadro FX 5600/4600 SDI and Quadro G-Sync II.
* Fixed a problem that caused OpenGL to stop rendering to windows with origins at or beyond 4096 pixels (horizontally) on GeForce 8 and 9 GPUs.
* Fixed OpenGL rendering corruption with textures compressed using the DXT5 compression algorithm.
* Fixed a regression that caused invalid EDIDs to be detected for the internal display device on some notebooks.
* Improved hotkey switching and power management support on some GeForce 8 notebooks.
* Fixed a bug that prevented the console from being restored correctly in SLI mode on GeForce 6 and 7 GPUs.
* Fixed a problem that caused the synchronization signal polarity to always be positive for DVI devices on GeForce 8 and 9 GPUs.
* Fixed a problem that caused TV output on secondary TVs to be black and white on some GPUs.
* Restored compatibility with recent Linux 2.6 kernels.


Coppied and renamed the 171.06 ebuild (originally 169.12 I think :roll: ) and it compiled fine (against zen-2.6.25-rc8 that is).

I'm not gonna test it right now cause I need some sleep real bad :wink:
_________________
~amd64
PhenomII x4 955 | MSI 790GX-G65 | ATI Radeon 5770 | 8GB DDR3 1333
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 468

PostPosted: Sun Apr 13, 2008 4:13 am    Post subject: Reply with quote

UT2004 graphical corruption is fixed with this release, at least with my 8800gt.
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 869

PostPosted: Sun Apr 13, 2008 7:14 am    Post subject: Reply with quote

I can't wait for the new driver to hit the portage tree because of this:

Quote:
Fixed a bug that prevented the console from being restored correctly in SLI mode on GeForce 6 and 7 GPUs.


Since 169.12 I can't get back to console from X after CTRL-ALT-Backspace nor do I get a console after shutdown and reboot; Geforce 7600 gt 2x on sli mode with gentoo-sources 2.6.24* 64bit system.
Back to top
View user's profile Send private message
mathusael
n00b
n00b


Joined: 22 Jun 2006
Posts: 22

PostPosted: Sun Apr 13, 2008 8:01 am    Post subject: for 9600GT owner... this driver is not an option Reply with quote

Hopefully, I got it working very quickly by setting a local overlay and copying the 169.12 ebuild.

The display with my 9600GT and the latest (keyworded) nv drivers was very unstable. (and not working at all with the 169 line)
Back to top
View user's profile Send private message
kmare
l33t
l33t


Joined: 20 Nov 2004
Posts: 619
Location: Thessaloniki, Greece

PostPosted: Sun Apr 13, 2008 4:47 pm    Post subject: Reply with quote

Just wanted to report that these drivers really slow down 2D rendering (at least for me under kde). It's been acknowledged by a nvidia developer and hopefully we'll get it fixed in the next driver, but yeah.. the DXT5 bug is gone. For now i had to roll back to 171.06.
see here: http://www.nvnews.net/vbulletin/showthread.php?t=111571
_________________
Never argue with an idiot. They will only pull you down to their level, then beat you with experience.
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Sun Apr 13, 2008 8:55 pm    Post subject: Reply with quote

The high pitch noise is now gone from when my thinkpad ran on batteries (T61p, nvidia quadro fx 570). With these drivers it's nice and quiet :)


dodo
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Mon Apr 21, 2008 8:46 pm    Post subject: Reply with quote

Iop, I'm french

I have a nvidia 9600GT too, I need ebuild 173.08 which works fine for arch amd64, please

I have error messages like : Cannot find $EPATCH_SOURCE!

Thanks
Back to top
View user's profile Send private message
ejs76
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2004
Posts: 148

PostPosted: Mon Apr 21, 2008 9:49 pm    Post subject: Reply with quote

Hallo! Ca va?

Sounds like you forgot to copy the "files" subdirectory from the "nvidia-drivers" directory in the portage tree to your overlay? This map contains the patch-files.

Salut :D
_________________
~amd64
PhenomII x4 955 | MSI 790GX-G65 | ATI Radeon 5770 | 8GB DDR3 1333
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue Apr 22, 2008 1:21 am    Post subject: Reply with quote

dodo1122 wrote:
The high pitch noise is now gone

That's probably the nvidia driver waking up the CPU 60 times a second (refresh rate) and preventing the CPU from going into a deeper power-saving state :wink:

NEOxAKIRA, see ebuild guide.
Back to top
View user's profile Send private message
Dagger
Retired Dev
Retired Dev


Joined: 11 Jun 2003
Posts: 765
Location: UK

PostPosted: Tue Apr 22, 2008 9:21 am    Post subject: Reply with quote

2D performance is really slow comparing to previous releases. I think I will wait a bit before I switch.
_________________
95% of all computer errors occur between chair and keyboard (TM)
Join the FSF as an Associate Member!
Post under CC license.
Back to top
View user's profile Send private message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Tue Apr 22, 2008 12:01 pm    Post subject: Reply with quote

http://gpo.zugaina.org/x11-drivers/nvidia-drivers?57389 here, there is an ebuild for nvidia-drivers-173.08-r10 from overlay sabayon.
I will try this tonight.
Back to top
View user's profile Send private message
alienvenom
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jan 2005
Posts: 123
Location: San Francisco, CA

PostPosted: Fri May 09, 2008 3:37 pm    Post subject: Reply with quote

Please note, in order for this to work with kernel 2.6.26, vanilla-sources-2.6.26-git6 or greater is required. This will NOT work -rc1 which is currently in portage.
Back to top
View user's profile Send private message
kev009
n00b
n00b


Joined: 17 Oct 2005
Posts: 43
Location: Tempe, Arizona

PostPosted: Tue May 13, 2008 8:40 am    Post subject: Reply with quote

Works great here on gentoo-sources 2.6.25 amd64. No noticed 2d slowdown..
_________________
http://www.kev009.com
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 869

PostPosted: Sat May 17, 2008 12:29 pm    Post subject: Reply with quote

I've just installed nvidia-drivers-173.08. Its splash warns me in red letters about the beta status 8O
but now I can get back onto the console with CTRL-ALT-Backspace again although I'm still missing the credits on shutdown. But may be the system shuts down so fast? :?
I can't confirm a slowdown in 2D performance here with KDE as WM. :o
Switching desktops seems to be a little slower but the driver IS beta.

All in all: :D

Parts of emerge --info


Code:
emerge --info
Portage 2.1.4.4 (default-linux/amd64/2006.1, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r3 x86_64 Intel(R) Pentium(R) 4 CPU 3.40GHz
Timestamp of tree: Sat, 17 May 2008 05:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.4-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool: 1.5.26
virtual/os-headers:  2.6.25-r3


Edit May 18:
The "credits" on shutdown are back again too. :lol: Even cpu load is less than before with the old driver!


Last edited by transsib on Sun May 18, 2008 5:40 am; edited 2 times in total
Back to top
View user's profile Send private message
Eckos
Apprentice
Apprentice


Joined: 25 Jan 2008
Posts: 197
Location: Houston, Texas, USA

PostPosted: Sat May 17, 2008 2:08 pm    Post subject: Reply with quote

Allows me to link against zen-2.6.26-r2 :D
_________________
AMD Athlon 64 X2 3800+ | 2GB DDR2 533MHz RAM | GCC-4.3.2 | Gentoo x86_64 | KDE 4.1.2
Back to top
View user's profile Send private message
geburns
n00b
n00b


Joined: 19 Apr 2002
Posts: 65
Location: st paul, mn

PostPosted: Thu May 29, 2008 11:24 pm    Post subject: Reply with quote

odd... i still can't access my consoles with this driver.

i tried to go back to -100.14.19, but the compile fails.

is there anything special i need to do to get my console back?

-=g=-
Back to top
View user's profile Send private message
SeaTiger
l33t
l33t


Joined: 22 Nov 2007
Posts: 603
Location: Toronto, Ontario, Canada

PostPosted: Fri May 30, 2008 2:40 am    Post subject: Reply with quote

How can we test 2D performace? I feels my compiz-fusion effect are faster than before.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum