Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[apache] emerge failed with acces violation error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
bixibu
n00b
n00b


Joined: 04 Apr 2008
Posts: 25

PostPosted: Fri Apr 11, 2008 8:17 am    Post subject: [apache] emerge failed with acces violation error Reply with quote

Hello ;)

I'm trying to install apache-ovh-2.0.59..

when I emerge that i'm having an ACCES VIOLATION error at the end of the compilation (I think) when the script tries to create news directorys :

ps:i'm under normal root account
ps2:it's the first emerge bug I ever had
ps3: the directories mentionned below DOESN'T exists before or after that failed emerge

ps4:maybe the problem occurs because I'm getting this package through an overlay (ovh-overlay) different than the original ? don't know...

Thanks

console logs :

Quote:

make[3]: Entering directory `/var/tmp/portage/net-www/apache-ovh-2.0.59/work/httpd-2.0.59/srclib/apr'
make[3]: Leaving directory `/var/tmp/portage/net-www/apache-ovh-2.0.59/work/httpd-2.0.59/srclib/apr'
if [ ! -d /usr/local/apache/include ]; then \
/var/tmp/portage/net-www/apache-ovh-2.0.59/work/httpd-2.0.59/srclib/apr/build/mkdir.sh /usr/local/apache/include; \
fi;
mkdir /usr/local/apache
ACCESS DENIED mkdir: /usr/local/apache
mkdir: cannot create directory `/usr/local/apache': Permission denied
mkdir /usr/local/apache/include
ACCESS DENIED mkdir: /usr/local/apache/include
mkdir: cannot create directory `/usr/local/apache/include': Permission denied

make[2]: *** [install] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-www/apache-ovh-2.0.59/work/httpd-2.0.59/srclib/apr'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-www/apache-ovh-2.0.59/work/httpd-2.0.59/srclib'
make: *** [install-recursive] Error 1
*
* ERROR: net-www/apache-ovh-2.0.59 failed.
* Call stack:
* ebuild.sh, line 49: Called src_install
* environment, line 2037: Called die
* The specific snippet of code:
* make install || die "Install failed";
* The die message:
* Install failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/net-www/apache-ovh-2.0.59/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/net-www/apache-ovh-2.0.59/temp/environment'.
*
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-26976.log"

mkdir: /usr/local/apache
mkdir: /usr/local/apache/include
--------------------------------------------------------------------------------

* Messages for package net-www/apache-ovh-2.0.59:

*
* ERROR: net-www/apache-ovh-2.0.59 failed.
* Call stack:
* ebuild.sh, line 49: Called src_install
* environment, line 2037: Called die
* The specific snippet of code:
* make install || die "Install failed";
* The die message:
* Install failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/net-www/apache-ovh-2.0.59/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/net-www/apache-ovh-2.0.59/temp/environment'.
*

Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Apr 11, 2008 5:09 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
stuff from an overlay, so unsupported
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
bixibu
n00b
n00b


Joined: 04 Apr 2008
Posts: 25

PostPosted: Fri Apr 11, 2008 7:04 pm    Post subject: Reply with quote

Ok..

Subsidiary question :

When I do an emerge --search apache.. I can only find 3 or 4 builds.. the LATEST 3 or 4 so only apache-2.2.8..

how could I get older versions ? like 2.0.*

Do I need to use an other overlay (like I just did)?
or
Do I need to change my Rsynx address ? => to which? is there a list of server?

thanks
Back to top
View user's profile Send private message
bixibu
n00b
n00b


Joined: 04 Apr 2008
Posts: 25

PostPosted: Sun Apr 13, 2008 8:17 pm    Post subject: Reply with quote

up
Back to top
View user's profile Send private message
Marsu
Guru
Guru


Joined: 18 Jun 2003
Posts: 329
Location: Lyon

PostPosted: Fri Apr 18, 2008 10:07 am    Post subject: Reply with quote

did you try to emerge with FEATURES="-sandbox" ?
_________________
qui ne tente rien n'a rien
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1285
Location: Ashford, Kent

PostPosted: Fri Apr 18, 2008 11:29 am    Post subject: Reply with quote

bixibu wrote:
Ok..

Subsidiary question :

When I do an emerge --search apache.. I can only find 3 or 4 builds.. the LATEST 3 or 4 so only apache-2.2.8..

how could I get older versions ? like 2.0.*

Do I need to use an other overlay (like I just did)?
or
Do I need to change my Rsynx address ? => to which? is there a list of server?

thanks


See this thread on the same issue
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Apr 18, 2008 11:36 am    Post subject: Reply with quote

I think it's a bit different.

bixibu uses a custom Gentoo distribution available on Kimsufi Dedicated Servers (OVH).
This distribution is named Release 2 and works with a special overlay for Apache, PHP, MySQL, etc.

However, the ebuilds provided by this overlay are really crappy...
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum