Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ssh] Derrière un proxy... [resolu]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Thu Apr 17, 2008 3:09 pm    Post subject: Reply with quote

gbetous wrote:

En prime t'as une manip excellente à faire :
Tu peux t'amuser à monter un proxy chez toi (par exemple squid). Ainsi, tu demandes à ton putty de te faire un tunnel sur ce proxy (par exemple un tunnel entre le port 3128 de ton serveur, et 3128 de ton client Windows du boulot). Ensuite, tu n'as plus qu'à configurer ton browser Internet pour qu'il utilise le proxy localhost:3128 (c'est à dire le port 3128 de ton PC WIndows du boulot), putty va balancer ça sur le 3128 de ton serveur, et hop! tu browse le web en utilisant le proxy de ton serveur, donc no limit, et le tout crypté par ssh !
Firefox propose un plugin (switch proxy) qui permet de passer facilement d'un proxy (boulot) à un autre (perso), c'est le top confort !


Héhé, c'est pile poil ce que je fais au boulot :)
Le web est filtré façon chinoise dans l'educ, même pas droit au porno et au warez : je vois plus l'intérêt du web là ;)
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Thu Apr 17, 2008 8:47 pm    Post subject: Reply with quote

BENJI wrote:
Ouais, bon l'euphorie est retombée... j'ai pas mis le chrono mais je perds la connexion au bout d'environ 1 minute... C'est à cause du proxy ou c'est autre chose !
Heureusement j'utilise screen donc je ne perds rien !


Non, non, c'est normal c'est SSH qui le fait par défaut. Active le TCPKeepalive dans ton serveur (toujours le /etc/sshd/sshd.conf) et dans putty (je crois que je le mets toutes les 5 secondes). ainsi t'as un petit paquet qui passe pour dire "eh oh ! je suis toujours vivant !", et ton ssh reste ouvert :wink:
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Apr 18, 2008 8:12 am    Post subject: Reply with quote

8) ok merci ça marche !
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Apr 18, 2008 12:47 pm    Post subject: Reply with quote

euh non ça marche plus :?

J'ai toujours des déconnexions, moins rapidement et moins fréquente mais j'en ai toujours !

Sinon effet de bord ou pas voilà ce que me dit apache quand je le lance maintenant :
Code:
ataualpa ~ # /etc/init.d/apache2 start
 * Starting apache2 ...
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs                                                       [ !! ]


Le port 443, comme par hasard !

Je suis en train de mettre en place un blog sur mon PC, histoire de tester Dotclear et depuis la manip ssh je ne peux plus y accéder depuis l'extérieur.
En local chez moi je n'ai pas testé pour le moment !
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Apr 18, 2008 12:48 pm    Post subject: Reply with quote

Si tu n'as pas besoin du vhost SSL pour Apache, désactive le.
Sinon change le port du serveur SSH pour un autre port autorisé.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Apr 18, 2008 2:05 pm    Post subject: Reply with quote

ok ça marche de nouveau ! Merci !
Avec cette connexion ssh je vais faire des progrès à grande vitesse sous gentoo !
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Wed Jul 02, 2008 7:37 am    Post subject: Reply with quote

El_Goretto wrote:
Pour ceux que ça intéresse, j'ai trouvé une howto utilisant proxytunnel, et un apache comme second proxy.

Ok, j'ai mis en place cette configuration sur ma machine perso, et... ça ne mache pas le proxy initial.
Par contre, via un proxy d'un autre type tout aussi bourru au départ, cela m'a permis de sortir... ouf.

Intéressant, il est question du non support par mod_proxy d'apache de la méthode connect quand SSL est activé... Alors que c'est le cas en http standard. Apparemment, le patch a u mal à faire son chemin jusqu'au code source. cf le lien vers le bas de la howto: http://issues.apache.org/bugzilla/show_bug.cgi?id=29744 On y trouve une version précompilée et un fichier source modifié pour corriger le problème. Cela fonctionne sur un apache 2.2.8.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum