Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with nvdia driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Robinson Cruseo
n00b
n00b


Joined: 17 Apr 2008
Posts: 7

PostPosted: Thu Apr 17, 2008 9:18 am    Post subject: Reply with quote

Installing the bata-drivers gives me following error:

Quote:
pop8-1840 nvidia-drivers # emerge nvidia-drivers -av

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] x11-drivers/nvidia-drivers-173.08 [169.09-r1] USE="acpi gtk -custom-cflags (-multilib)" 0 kB [0=>1]

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /usr/portage/local/local-overlay

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-173.08 to /
* NVIDIA-Linux-x86-173.08-pkg0.run RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking NVIDIA-Linux-x86-173.08-pkg0.run ;-) ... [ ok ]
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/2.6.24-gentoo-r4/build
* Found sources for kernel version:
* 2.6.24-gentoo-r4
* Checking for MTRR support ... [ ok ]
* Checking for Paravirtualized guest support ...
>>> Unpacking source...
Creating directory NVIDIA-Linux-x86-173.08-pkg0
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 173.08......................................................................................................................................

* Cannot find $EPATCH_SOURCE! Value for $EPATCH_SOURCE is:
*
* /usr/portage/local/local-overlay/x11-drivers/nvidia-drivers/files/NVIDIA_glx-defines.patch
* ( NVIDIA_glx-defines.patch )

*
* ERROR: x11-drivers/nvidia-drivers-173.08 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 3759: Called epatch 'src_unpack'
* environment, line 1498: Called die
* The specific snippet of code:
* die "Cannot find \$EPATCH_SOURCE!";
* The die message:
* Cannot find $EPATCH_SOURCE!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-173.08/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-173.08/temp/environment'.
*

* Messages for package x11-drivers/nvidia-drivers-173.08:

* Cannot find $EPATCH_SOURCE! Value for $EPATCH_SOURCE is:
*
* /usr/portage/local/local-overlay/x11-drivers/nvidia-drivers/files/NVIDIA_glx-defines.patch
* ( NVIDIA_glx-defines.patch )
*
* ERROR: x11-drivers/nvidia-drivers-173.08 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 3759: Called epatch 'src_unpack'
* environment, line 1498: Called die
* The specific snippet of code:
* die "Cannot find \$EPATCH_SOURCE!";
* The die message:
* Cannot find $EPATCH_SOURCE!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-173.08/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-173.08/temp/environment'.
*



Any ideas but downgrade?
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Thu Apr 17, 2008 10:48 pm    Post subject: Reply with quote

Split from this thread and moved to US as this version of the drive won't make to the portage tree.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Thu Apr 17, 2008 10:53 pm    Post subject: Reply with quote

Copy /usr/portage/x11-drivers/nvidia-drivers/files directory into your nvidia-drivers overlay directory.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Robinson Cruseo
n00b
n00b


Joined: 17 Apr 2008
Posts: 7

PostPosted: Fri Apr 18, 2008 8:22 am    Post subject: Reply with quote

I downloaded the sh-installer from http://www.nvidia.com/Download/Find.aspx?lang=en-us.

But I'll try you suggestion later, as it is the way it should be.

Thanks and a happy weekend.
Back to top
View user's profile Send private message
movrev
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2004
Posts: 114
Location: Berkeley, CA - USA

PostPosted: Sat May 03, 2008 2:22 am    Post subject: Reply with quote

Amazing, moving the files directory into the local overlay works. I could now install nvidia-drivers-173.08-r10, now it's time to check these drivers out. Thanks.
_________________
Shuttle SN25P - FN25 mobo nForce 4 - AMD Athlon 64 3500+ - nVidia GeForce 6800 - Maxtor 200Gb - 2x1024 Mb Corsair XMS RAM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum