Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot compile linuxsampler - says I need gcc 4.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
musicman
n00b
n00b


Joined: 13 Jun 2004
Posts: 66

PostPosted: Thu Apr 24, 2008 3:58 am    Post subject: Cannot compile linuxsampler - says I need gcc 4.2 Reply with quote

I'm running amd64 kernel gentoo-sources-2.6.24-r4, and I'm trying to compile linuxsampler from the pro-audio overlay. It says I need gcc 4.2 because 4.1 causes linuxsampler to crash a lot. The problem is that gcc-4.2.3 is masked on all architectures, and when I try and unmask it, it fails to compile.

When I try to compile linuxsampler from the regular portage tree, it reaches a certain point and then seems to exponentially gobble up ALL of my ram and swap, bringing the system to a standstill, after 30 minutes of which I just flip the computer's power off.

Does anyone know how to get linuxsampler to compile? Maybe I should try earlier versions of gcc?
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu Apr 24, 2008 6:00 am    Post subject: Reply with quote

Moved from Multimedia to Unsupported Software.

You don't need to unmask gcc-4.2, you need to accept the ~arch keyword for it.
Code:
# echo "sys-devel/gcc:4.2" >> /etc/portage/package.keywords
will do it.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 701
Location: Billings, MT, USA

PostPosted: Thu Apr 24, 2008 2:44 pm    Post subject: Reply with quote

Either that or ACCEPT_KEYWORDS="~x86" emerge gcc.

I usually put ACCEPT_KEYWORDS="~x86" in my make.conf anyway.
_________________
Router(Nokia IP390,2GB RAM,160GB HDD,8xGigE ports,pfSense) | MyDT(Xeon X3470@3.4GHz,32GB RAM,6x2TB R5,GTX560Ti,2xLG BD-RE,Win10Pro)
MyLT(Asus G53SX,32GB RAM,2x2TB HDDs,BD-RE,Intel 6230,Win10Pro) | Wife(PnmIIX3@3.3GHz,8GB RAM,1TB HDD,DVDRW,Win10Pro)
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Thu Apr 24, 2008 2:47 pm    Post subject: Reply with quote

Simba7 wrote:
Either that or ACCEPT_KEYWORDS="~x86" emerge gcc.

I usually put ACCEPT_KEYWORDS="~x86" in my make.conf anyway.


This is not advisable because of many reasons.

Use package.keywords instead as suggested above.

If you use that in command line, you are not only accepting the keyword for the package, but also for any dependency that it requires. Also, that would not be remembered. The next time you do an emerge -auDvN world to update everything, it will want to downgrade gcc because it's not rightly keyworded.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 701
Location: Billings, MT, USA

PostPosted: Thu Apr 24, 2008 2:49 pm    Post subject: Reply with quote

Ahh.. True.. It's best to put it in your make.conf file so it doesn't goof everything up. But that's only if you want the *LATEST* of everything.

..or use package.keywords above..
_________________
Router(Nokia IP390,2GB RAM,160GB HDD,8xGigE ports,pfSense) | MyDT(Xeon X3470@3.4GHz,32GB RAM,6x2TB R5,GTX560Ti,2xLG BD-RE,Win10Pro)
MyLT(Asus G53SX,32GB RAM,2x2TB HDDs,BD-RE,Intel 6230,Win10Pro) | Wife(PnmIIX3@3.3GHz,8GB RAM,1TB HDD,DVDRW,Win10Pro)
Back to top
View user's profile Send private message
musicman
n00b
n00b


Joined: 13 Jun 2004
Posts: 66

PostPosted: Thu Apr 24, 2008 6:56 pm    Post subject: Reply with quote

This is not unsupported software, as I am having problems getting linuxsampler IN the portage tree to build as well.

I got the newer gcc to emerge by doing emerge -Duv --newuse system, but in the process I broke tons of other things, relating to libexpat-2.0.1 (which I later downgraded because I couldn't fix things - some kind of circular brokenness and revdep-rebuilding).

Since emerge -Duv --newuse system, I'm also having trouble getting libXt to compile:

Code:

...
No package 'sm' found
configure:19898: $? = 1
Package sm was not found in the pkg-config search path.
Perhaps you should add the directory containing 'sm.pc' to the PKG_CONFIG_PATH environment variable
No package 'sm' found
configure:19919: error: Package requirements (sm x11 xproto kbproto) were not met.
...


And I'm also having trouble with gnome-session, libbonoboui, qt, and untold numbers of other packages.
Back to top
View user's profile Send private message
musicman
n00b
n00b


Joined: 13 Jun 2004
Posts: 66

PostPosted: Thu Apr 24, 2008 7:28 pm    Post subject: Reply with quote

Wow. Never mind. Somehow, when I ran
Code:
equery files libSM
, it showed that only a couple of the package's files were actually installed where they should have been. An
Code:
emerge libSM
fixed some things... hopefully things will work now... Thanks for your help.

Is there a better solution than to keep using the old expat instead of expat-2.0.1 ? I tried searching the forums for all that stuff, but none of it helped... maybe things will be better since I fixed the libSM problem.

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum