Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Frame Buffer] Se lance longtemps après le boot !
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Sun Apr 27, 2008 2:45 pm    Post subject: [Frame Buffer] Se lance longtemps après le boot ! Reply with quote

Bonjour,

Depuis un certains nombres de noyaux, je n'ai plus le frame buffer qui se charge dès le boot mais plus plutôt vers le montage des fs et j'ai pas mal cherché sans trouver une solution. Tout d'abord sur le wiki ICI ou se problème est cité mais les pistes enumérées ne semblent pas les bonnes pour moi ...

1. Vérifier si les fichiers du splash sont bien ds le initr
Code:
IRIA boot # zcat fbsplash-livecd-2007.0-1024x768 | cpio --list
.
etc
etc/splash
etc/splash/livecd-2007.0
etc/splash/livecd-2007.0/1024x768.cfg
etc/splash/livecd-2007.0/Vera.ttf
etc/splash/livecd-2007.0/images
etc/splash/livecd-2007.0/images/overlay-768.png
etc/splash/livecd-2007.0/images/verbose-1024x768.png
etc/splash/livecd-2007.0/images/background-1024x768.png
sbin
sbin/fbcondecor_helper
sbin/splash_helper
dev
dev/console
dev/misc
dev/tty0
dev/fb
dev/vc
dev/null
lib
lib/splash
lib/splash/sys
lib/splash/proc
root
1406 blocks


2. Vérifier que ma carte et mon écran support la résolution
Code:
dry@IRIA ~ $ cat /sys/class/graphics/fb0/modes
U:1024x768p-60
V:1280x1024p-75
V:1280x1024p-60
V:1024x768p-75
V:1024x768p-70
V:1024x768p-60
V:800x600p-75
V:800x600p-72
V:800x600p-60
V:800x600p-56
V:640x480p-75
V:640x480p-72
V:640x480p-60
U:2048x1536p-60
U:1400x1050p-59
U:1600x1200p-60
U:320x240p-60
U:320x400p-59
U:320x200p-59
U:1280x1024p-59
U:1024x768p-60
U:800x600p-59
U:640x480p-60
U:640x400p-59


Voilà, j'aimerais savoir si vous avez le même problème et si une solution existe .

Merci.
_________________
Get Up and Go !
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Apr 27, 2008 4:57 pm    Post subject: Reply with quote

T'en as de la chance :)


Le mien à carément disparu :evil:
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
polytan
Guru
Guru


Joined: 29 Jul 2004
Posts: 370
Location: Cambridge - UK

PostPosted: Sun Apr 27, 2008 10:28 pm    Post subject: Reply with quote

Et moi je l'ai désactivé, ca merdouille avec la mise en veille...
_________________
Wait & See

-=( Polytan )=-
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Mon Apr 28, 2008 7:49 am    Post subject: Reply with quote

Salut il nous faut plus d'infos. Ta carte le noyo etc emerge --info etc

Et je cite cette remarque depuis le thread Baselayout2 centralisation des retours :
gglaboussole wrote:
Merci nemo13 !
Je vais tester dès que je retrouve ma gentoo...(je suis sur l'ubuntu de ma copine là jusqu'à lundi)

Par contre j'ai trouvé la solution pour le splash :

https://forums.gentoo.org/viewtopic-t-679268-highlight-.html

EDIT= Parce qu'en fait la solution c'est réemerger splashutils, or splashutils ne compile plus après avoir upgradé à baselayout2...
il faut aussi faire attention de compiler splasutils avec le USE = fbcondecor et bien sûr avoir préparer son syteme à uvesafb :
http://dev.gentoo.org/~spock/projects/uvesafb/

et le lien du patch étant mort il faut le prendre ici :

http://roy.marples.name/openrc/splash.patch

ensuite ne pas appliquer "bêtement" les commandes données mais plutôt :
Code:

ebuild /usr/portage/media-gfx/splashutils/splashutils-1.5.3.4.ebuild digest


recompiler ensuite splashutils et roule nenesse !

:wink:

_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Mon Apr 28, 2008 9:55 am    Post subject: Reply with quote

Bonjour,

Mickael wrote:
Salut il nous faut plus d'infos. Ta carte le noyo etc emerge --info etc

Et je cite cette remarque depuis le thread Baselayout2 centralisation des retours :


J'ai lu ce thread avant de poster et Je n'ai pas de problème de compilation de splashutils ave baselayaout2.

1. emerge --info
Code:

Portage 2.1.5_rc6 (default/linux/amd64/2008.0/desktop, gcc-4.2.3, glibc-2.7-r2, 2.6.25-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r1 x86_64 AMD Turion(tm) 64 X2 Mobile Technology TL-56
Timestamp of tree: Wed, 23 Apr 2008 16:17:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.4.4-r6, 2.5.2-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -msse3 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -msse3 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="assume-digests digest distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://adelie.polymtl.ca/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo http://gentoo.seren.com/gentoo ftp://gentoo.chem.wisc.edu/gentoo/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS=""
LINGUAS="fr fr_FR"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays /usr/local/layman/desktop-effects"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 bash-completion berkdb bidi bluetooth branding bzip2 cairo caps cdda cdinstall cdio cdr clamav cli cracklib crypt cscope cups dbus dio dri dts dv dvd dvdr dvdread eds emboss emul-linux-x86 encode esd evo fam fbsplash ffmpeg firefox flac fortran freetype gb gdbm gif gphoto2 gpm gstreamer hal iconv imagemagick ipv6 isdnlog jpeg kde kerberos lcms ldap libcaca libnotify live mad matroska midi mikmod mime mmx motif mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg oggvorbis opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection ruby sdl session sockets spell spl sse sse2 ssl startup-notification stream suspend2 svg tcltk tcpd theora tiff truetype unicode vcd videos vlm vorbis xcomposite xine xml xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="nvidia nv v4l"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


2. grep CONFIG_FB /usr/src/linux/.config
Code:

CONFIG_FB=y
# CONFIG_FB_DDC is not set
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
# CONFIG_FB_SYS_FILLRECT is not set
# CONFIG_FB_SYS_COPYAREA is not set
# CONFIG_FB_SYS_IMAGEBLIT is not set
# CONFIG_FB_SYS_FOPS is not set
CONFIG_FB_DEFERRED_IO=y
# CONFIG_FB_SVGALIB is not set
# CONFIG_FB_MACMODES is not set
# CONFIG_FB_BACKLIGHT is not set
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_TILEBLITTING=y
# CONFIG_FB_CIRRUS is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_ARC is not set
# CONFIG_FB_ASILIANT is not set
# CONFIG_FB_IMSTT is not set
# CONFIG_FB_VGA16 is not set
CONFIG_FB_UVESA=y
# CONFIG_FB_VESA is not set
# CONFIG_FB_EFI is not set
# CONFIG_FB_HECUBA is not set
# CONFIG_FB_HGA is not set
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_NVIDIA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_LE80578 is not set
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_S3 is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_KYRO is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_VT8623 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_ARK is not set
# CONFIG_FB_VIRTUAL is not set



3. cat /boot/grub/grub.conf
Code:

default  0
timeout  -1

splashimage=(hd0,2)/boot/grub/vue.xpm.gz


title   Gentoo  GNU/Linux       Genesis-kernel-2.6.25-gentoo-r1
root    (hd0,2)
kernel  /boot/genesis-kernel-2.6.25-gentoo-r1  root=/dev/sda3   splash=silent,fadein,theme:livecd-2007.0 video=uvesafb:1024x768-32@60,mtrr:3,ywrap quiet console=tty1
initrd  /boot/fbsplash-livecd-2007.0-1024x768


title   Windows XP Pro
rootnoverify  (hd0,0)
makeactive
chainloader +1


Ma carte graphique est une Nvidia 6150, je n'ai que cette machine avec baselayout2 et mes autres machines avec cartes NVidia, ATI, noyaux récent (2.6.23 minimum) ont le même soucis avec le frame buffer
et cela ne date pas "d'hier" (6 mois - 1an).

Voilà,

Merci
_________________
Get Up and Go !
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Mon Apr 28, 2008 3:19 pm    Post subject: Reply with quote

J'ai lu quelque part (mais ou ?) que certains qui avaient ce genre de problème l'avaient résolu en plaçant fbcondecor dans le runlevel boot plutôt que défault

EDIT désolé :oops:... je l'ai justement vu dans le lien que tu donnes toi même...
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Tue Apr 29, 2008 7:06 pm    Post subject: Reply with quote

C'est le framebuffer (console haute résolution) qui s'affiche pas où juste le splash ?

Perso le splash ne se lançait plus du tout depuis quelque temps et j'ai résolu ça en remplaçant console=tty1 par CONSOLE=/dev/tty1 dans le grub.conf
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Wed Apr 30, 2008 6:00 am    Post subject: Reply with quote

rajoute çà après le paramètre video :

Code:
vga=0x318


J'ai eu un peu le même problème que toi avec les kernel >=2.6.23 si je me souviens bien ou 2.6.22, il faut passer en plus le paramètre VGA

De plus j'ai vu que comme moi tu utilise le splash du livecd (très bon choix ^^)
Rajoute kdgraphics
çà donne :
Code:
splash=silent,kdgraphics,theme:livecd-2007.0
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Thu May 01, 2008 8:38 pm    Post subject: Reply with quote

En ce moment je passe d'un 2.6.22 au 2.6.25 tout frai démoulu et impossible de refaire marcher ce didiou de fb :( (entre autres merdes).

Chanceux ceux qui ont un fb qui marche :roll: ...
_________________
Ez.
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Fri May 02, 2008 8:50 am    Post subject: Reply with quote

Arretez moi si je dis une connerie, mais si on ne fait pas de ramdisk ou init je sais plus quoi, ou je ne sais quoi, le splash ne se lance qu'après le montage des disques durs, non ?
Je sais plus, j'ai plus d'image de fond dans mon splash moi.... J'ai abandonné l'idée d'en avoir un....
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Sat May 03, 2008 9:39 am    Post subject: Reply with quote

Perso ma config pour avoir un fb qui marche :
- fichier .config fait à la main avec make menuconfig
- genkernel utilisant ce fichier .config pour créer le kernel et l'initrd

Les paramètres additionnels je les ai déjà donné plus haut ;)

Si besoin de mes lignes complètes de grub demandez ;)

Car je peux vous assurez que çà marche très bien !
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Sun May 04, 2008 4:19 pm    Post subject: Reply with quote

Perso sur mon portable il se charge aussi (trop) tard, alors que sur le desktop non.
C'est un mystère de l'informatique sur lequel j'ai décidé de ne pas perdre de temps :lol:
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Sun May 04, 2008 4:51 pm    Post subject: Reply with quote

Moué ben je reste avec mon 2.6.22 qui marche nickel, de toute façon le 25 il aime pas mon reseau wifi :arrow:
_________________
Ez.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum