Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED + AMD64] Problème avec nspluginwrapper
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Sun Apr 27, 2008 7:19 pm    Post subject: [SOLVED + AMD64] Problème avec nspluginwrapper Reply with quote

Bonjour tout le monde,
Je suis depuis peu (c'est à dire hier) passé à gentoo 64 bits, étant utilisateur de gentoo 32 bits depuis un bon moment, je me suis dit, ayant un processeur gérant 64bits autant tester.

J'ai donc comme tout le monde un problème avec flash, mon ami google et le forum m'a aidé à trouver qu'il fallait utiliser "nspluginwrapper" ce que j'ai tenté

J'ai suivis le guide http://gentoo-wiki.com/HOWTO_Flash_9_and_Firefox

Le problème est le suivant :

Code:
# emerge --ask nspluginwrapper
....
 * Auto installing 32bit plugins...
/usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: /usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: cannot execute binary file
/usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: /usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: cannot execute binary file
/usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: /usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: cannot execute binary file


Code:
# nspluginwrapper -v -a -i
Auto-install plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
/usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: /usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: cannot execute binary file
Auto-install plugins from /usr/lib64/mozilla/plugins
Looking for plugins in /usr/lib64/mozilla/plugins
/usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: /usr/lib64/nspluginwrapper/i386/linux/npviewer.bin: cannot execute binary file



Code:
#
# Executable file formats / Emulations
#
...
CONFIG_IA32_EMULATION=y
CONFIG_IA32_AOUT=y
...


Code:
# uname -a
Linux MasteRock 2.6.24-gentoo-r4 #8 SMP Sun Apr 27 19:57:15 CEST 2008 x86_64 Intel(R) Core(TM)2 Quad CPU @ 2.66GHz GenuineIntel GNU/Linux


Version de GCC : x86_64-pc-linux-gnu-4.3.0

Vraisemblement je ne peut pas exécuter /usr/lib64/nspluginwrapper/i386/linux/npviewer.bin malgré que l'émulation d'IA32 soit activée dans le kernel


Auriez-vous une idée de comment résoudre ce problème??


Merci d'avance :)


Last edited by MasterPrenium on Sun Apr 27, 2008 7:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Sun Apr 27, 2008 7:47 pm    Post subject: Reply with quote

Je penses avoir trouver la solution

Cela semble fonctionner

Il faut mettre IA32_AOUT en Module et non en dur ...

étrange mais bon
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8132
Location: ~Brussels - Belgique

PostPosted: Sun Apr 27, 2008 7:48 pm    Post subject: Reply with quote

Salut,

As-tu mis le support pour 32 bits dans ton kernel ? et es-tu en profile "multilib" ?

Sinon, je viens d'essayer swfdec-mozilla et ça marche relativement bien, en 64 bits.

(je pense passer à no-multilib ces jours-ci, et utiliser un chroot 32 bits pour les softs à la skype, et ainsi avoir les libs 32 bits à jour)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Mon Apr 28, 2008 5:48 am    Post subject: Reply with quote

Ba oé j'avais mis le support 32 bits dans le kernel en dur et çà ne marchait pas, et je suis en multilib.
Pour que çà marche j'ai mis :CONFIG_IA32_AOUT=m au lieu de CONFIG_IA32_AOUT=y.
Etrange mais çà marche ....
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Apr 28, 2008 5:55 am    Post subject: Reply with quote

MasterPrenium wrote:
Ba oé j'avais mis le support 32 bits dans le kernel en dur et çà ne marchait pas, et je suis en multilib.
Pour que çà marche j'ai mis :CONFIG_IA32_AOUT=m au lieu de CONFIG_IA32_AOUT=y.
Etrange mais çà marche ....

Ce truc là, t'aurais même pas besoin de le mettre du tout, le format a.out n'est plus utilisé depuis très longtemps, remplacé par le format ELF. :)
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Mon Apr 28, 2008 4:24 pm    Post subject: Reply with quote

ba alors .... je comprends pas pourquoi çà ne marchait pas ^^
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum