Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ELDK on AMD64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
alfredo.salvarani
n00b
n00b


Joined: 23 Sep 2006
Posts: 18

PostPosted: Tue Apr 29, 2008 12:50 pm    Post subject: ELDK on AMD64 Reply with quote

Hello all!

I have a AMD64 machine and a Gentoo 2.6.64-gentoo-r4 kernel installed with a 64 bit architecture.
I need to install the ELDK to compile work with embedded software for ppc, the ELDK is a 32 bit software, because that I can't run the install program (it says: bash: ./install: Permission denied). I was installed all emul-linux-x86 libs, but the sw still not working.
Theres any way to do this 32 bit sw work with the 64 bit kernel? I know that the 32 bit chroot can allow me to run the 32 sw, but I don't want to do this...

(ELDK home: http://www.denx.de/en/News/WebHome)

Thanks.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Tue Apr 29, 2008 3:21 pm    Post subject: Reply with quote

It's probably giving you "permission denied" because it wants to install as root.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Apr 29, 2008 4:11 pm    Post subject: Reply with quote

slycordinator wrote:
It's probably giving you "permission denied" because it wants to install as root.

Most likely this is because ./install is not executable, so try chmod +x it.

Code:
┌--tom@sirius---[Di Apr 29 18:12:01]---[~]
└» touch test
┌--tom@sirius---[Di Apr 29 18:12:05]---[~]
└» ./test
bash: ./test: Keine Berechtigung

etc..
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay


Last edited by gimpel on Tue Apr 29, 2008 4:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
alfredo.salvarani
n00b
n00b


Joined: 23 Sep 2006
Posts: 18

PostPosted: Tue Apr 29, 2008 4:41 pm    Post subject: Reply with quote

I'm trying installing as root.
I'm sure the problem is the 64bit arch, because I tried in the 32bit chroot and it's install well, but I don't want to use a 32bit chroot.

[]'s
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Apr 29, 2008 4:43 pm    Post subject: Reply with quote

Code:
chmod +x install

then try again, as said.

Gentoo's multilib setup is so good, I can even run 32bit Oracle on it.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
alfredo.salvarani
n00b
n00b


Joined: 23 Sep 2006
Posts: 18

PostPosted: Tue Apr 29, 2008 4:54 pm    Post subject: Reply with quote

The file has the right permission. I'm sure that the problem is the arch.
I'm not a n00b...
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Apr 29, 2008 4:56 pm    Post subject: Reply with quote

alfredo.salvarani wrote:
The file has the right permission. I'm sure that the problem is the arch.
I'm not a n00b...

Sorry if it sounded like I did assume that. Actually I overread the part where you said it works fine in a 32bit chroot.

Now, is that ./install a binary? Or is it a shell script? And if it's shell, what on earth is in it , so that it refuses to work on 64bit...

So long you could try to fire it up in a full 32bit env.
Code:
linux32 ./install

..or however that install script is executed. This way uname -m returns a 32bit arch (i686) - maybe that install script/? checks for this.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
alfredo.salvarani
n00b
n00b


Joined: 23 Sep 2006
Posts: 18

PostPosted: Tue Apr 29, 2008 5:04 pm    Post subject: Reply with quote

gimpel wrote:

Sorry if it sounded like I did assume that. Actually I overread the part where you said it works fine in a 32bit chroot.

Now, is that ./install a binary? Or is it a shell script? And if it's shell, what on earth is in it , so that it refuses to work on 64bit...


Ok, no problem...

it's a binary file, first of all I recompile my kernel to support the 32bit emulation then the skype (32bit binary) worked :D but the ELDK intall not :(
The ELDK is normally delivered in pre compiled files, but theres a way to recompile it... The bad is I have to use the GID to get the source... :x it's taking a long time..

[]'s
Back to top
View user's profile Send private message
alfredo.salvarani
n00b
n00b


Joined: 23 Sep 2006
Posts: 18

PostPosted: Tue Apr 29, 2008 6:16 pm    Post subject: Reply with quote

I copied the install file to the /tmp dir and it worked! so I tried to copy entire cd to /tmp and one file failed to copy, then I get a iso file, mount it and it's install fine... I'll check if it's a bad cd media, or it's a bug on the mount system and/or cdrom drivers.

Thanks
Back to top
View user's profile Send private message
alfredo.salvarani
n00b
n00b


Joined: 23 Sep 2006
Posts: 18

PostPosted: Thu May 08, 2008 5:28 pm    Post subject: Reply with quote

I was tested and now I'm sure that theres a bug here, I get another 32 bit application in CD media (QNX Momentum) and it's binary file didn't run from cd, but it's run fine from a mounted iso file.

[]'s
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum