Joined: 12 May 2004
|Posted: Tue Apr 29, 2008 1:26 pm Post subject: [ GLSA 200804-30 ] KDE start_kdeinit: Multiple vulnerabiliti
|Gentoo Linux Security Advisory
Title: KDE start_kdeinit: Multiple vulnerabilities (GLSA 200804-30)
Date: April 29, 2008
Updated: April 08, 2009
Multiple vulnerabilities in start_kdeinit could possibly allow a local
attacker to execute arbitrary code with root privileges.
KDE is a feature-rich graphical desktop environment for Linux and
Unix-like operating systems. start_kdeinit is a wrapper for kdeinit.
Vulnerable: < 4.0
Unaffected: >= 3.5.8-r4 < 3.5.9
Unaffected: >= 3.5.9-r3 < 3.5.10
Unaffected: > 4.0
Unaffected: < 3.5.5
Unaffected: >= 3.5.10-r2 < 3.5.11
Architectures: All supported architectures
Vulnerabilities have been reported in the processing of user-controlled
data by start_kdeinit, which is setuid root by default.
A local attacker could possibly execute arbitrary code with root
privileges, cause a Denial of Service or send Unix signals to other
processes, when start_kdeinit is setuid root.
There is no known workaround at this time.
All kdelibs users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=kde-base/kdelibs-3.5.8-r4"
Last edited by GLSA on Thu Sep 10, 2009 4:18 am; edited 3 times in total