Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
does anybody has libstdc++.so.27 ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed Apr 30, 2008 8:20 am    Post subject: does anybody has libstdc++.so.27 ? Reply with quote

I am not able to understand what is happening to mbrola ...
she is requiring libstdc++.so.27 while on my (last week updated) system is installed libstdc++.so.5.0.6


hard linking libstdc++.so.27 to libstdc++.so.5.0.6 seems to fix the mbrola issue, but it not the Truth .... doing this mbrola simply ignore every parameters passed by the shell

example
mbrola
Not enough arguments, try -h for help

mbrola -h
Not enough arguments, try -h for help



does anybody has the .27 file compiled for ppc ?
hard linking a modern library to mime an old one (mbrola was compiled in 2005) is not a good idea
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Apr 30, 2008 8:58 am    Post subject: Reply with quote

maybe this one contains such library ?

http://ftp.pld-linux.org/PLD-1.0/ppc/PLD/by-group/Libraries/libstdc%2b%2b-compat-1.0-6.ppc.rpm

but this is an ancient library, it looks like mbrola is dead and mbrola is -ppc marked already so ... i wouldn´t expect it to work .

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed Apr 30, 2008 1:34 pm    Post subject: Reply with quote

mbrola is provided as binary (already compiled) packed (and it will installet into /opt/mbrola by emerge)

the binary packet provided is using an old (2005) stdc library which i suppose not compatible with modern one ...

I'd like to fix up the mbrola, cause it is useful combining it with festival or espeak

i need to understand where is the problem ... and (hack) fix it
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Apr 30, 2008 3:19 pm    Post subject: Reply with quote

go ahead and contact upstream, maybe they can help you to fix the code.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Mon May 12, 2008 8:09 am    Post subject: Reply with quote

already contacted, no answer ...
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Mon May 12, 2008 11:03 pm    Post subject: Reply with quote

You may want to try sys-libs/lib-compat you may still need to create a symlink to
the library name you want, but I think that's what you need.
It provides the following:
Code:
lib/ld-linux.so.1 -> ld-linux.so.1.9.11
/lib/ld-linux.so.1.9.11
/usr
/usr/lib
/usr/lib/libc.so.5
/usr/lib/libg++.so.2.7.2 -> libg++.so.2.7.2.8
/usr/lib/libg++.so.2.7.2.8
/usr/lib/libstdc++-2-libc6.1-1-2.9.0.so
/usr/lib/libstdc++-3-libc6.2-2-2.10.0.so
/usr/lib/libstdc++-libc6.1-1.so.2 -> libstdc++-2-libc6.1-1-2.9.0.so
/usr/lib/libstdc++-libc6.2-2.so.3 -> libstdc++-3-libc6.2-2-2.10.0.so
/usr/lib/libstdc++.so.2.7.2 -> libstdc++.so.2.7.2.8
/usr/lib/libstdc++.so.2.7.2.8
/usr/lib/libstdc++.so.2.8 -> libstdc++.so.2.8.0
/usr/lib/libstdc++.so.2.8.0
/usr/lib/libstdc++.so.2.9 -> libstdc++.so.2.9.0
/usr/lib/libstdc++.so.2.9.0

You may want to link to 2.7.2 hopefully.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum