Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 Overlay (Part 6)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6 ... 26, 27, 28  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sat May 10, 2008 4:37 pm    Post subject: Reply with quote

wrc1944 wrote:
On my Arch Installation anonsvn is working normally with no slowdown AFAIK. I use the kdesvn-build script, and the address is specified as 138.246.255.177, which is identical to websvn. What I don't get is why one works normally to do an svn update via konsole but I can't ping the same address, and I can't use any browser to browse the files at the site- the server always times out, on port 80. As I mentioned, this happens on different boxes, different OS's, and different browsers, (going on three days now). I'm not behind a firewall, or using proxies. :?

But websvn is not anonsvn, anonsvn has the IP 78.46.32.117.
Kuhrscher wrote:
beso_1717 wrote:
fldc2 wrote:
Locks in kded4 was fixed earlier today if that was your issue.


i don't think that was the only issue... kde4 still hangs.... now the error messages have changed:

Code:
kdeinit4: preparing to launch /usr/kde/svn/lib64/kde4/libexec/kconf_update
kdeinit4: preparing to launch /usr/kde/svn/bin/kcminit_startup
kdeinit4: preparing to launch /usr/kde/svn/bin/ksmserver
kdeinit4: preparing to launch /usr/kde/svn/bin/krunner
kdeinit4: preparing to launch /usr/kde/svn/bin/knotify4
"kwin"(3557): Couldn't start knotify from knotify4.desktop:  "KDEInit could not launch '/usr/kde/svn/bin/knotify4'."

findServiceByDesktopPath:  not found
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
kdeinit4: preparing to launch /usr/kde/svn/bin/plasma
QFSFileEngine::open: No file name specified
QLayout: Attempting to add QLayout "" to PanelController "", which already has a layout
kdeinit4: preparing to launch
QPainter::begin: Cannot paint on a null pixmap
QPainter::end: Painter not active, aborted
kcminit_startup: Fatal IO error: client killed
QObject: Do not delete object, 'unnamed', during its event handler!
QObject: Do not delete object, 'unnamed', during its event handler!
QObject: Do not delete object, 'unnamed', during its event handler!
QObject: Do not delete object, 'unnamed', during its event handler!
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
QProcess: Destroyed while process is still running.
kded4: Fatal IO error: client killed
klauncher: Exiting on signal 1
XIO:  fatal IO error 4 (Interrupted system call) on X server ":0.0"
      after 25 requests (8 known processed) with 0 events remaining.
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.


I had (and probably still have) the same problems on Gentoo with the ebuilds from the overlay. On Archlinux my recent svn-build works just fine, so it didn't think this is an KDE issue but an issue with the ebuilds of the overlay?


Looks a bit like a config issue. Tried with a clean config?
(mv ~/.kdesvn ~/.kdesvn.backup while kde is not running)
Back to top
View user's profile Send private message
Cephalon
n00b
n00b


Joined: 04 Nov 2007
Posts: 23

PostPosted: Sat May 10, 2008 5:03 pm    Post subject: Reply with quote

Hello, after paludis+kde4 update i have much more problems, first of all and most serious is that after i logged in, i don't know what happen and few minutes later my keyboard stop responding and i have to restart the x. My second problem is tha if i am logged in first time after a reboot everything works but if i logout and try to login again the splash screen appears and crash there on splash screen no message just the splash screen. i need your help. Sorry for my english.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat May 10, 2008 5:03 pm    Post subject: Reply with quote

beso_1717 wrote:
Quote:
then maybe your isp uses a route to that ip address that is full of traffic. from time to time i experience the same problems with some sites, that aren't reachable from one ip but are reachable from an external free proxy (that uses a different route).
That's an interesting theory, but it's worked for years, and my isp hasn't changed anything (cox.net). :? Besides, anonsvn works fine, and they are the same IP address- at least that's what it seems to be. :? :roll:
Berniyh wrote:
Quote:
But websvn is not anonsvn, anonsvn has the IP 78.46.32.117.
If so, how come ping reports 138.246.255.177, but can't connect to the server? It's a mystery to me. :roll:
When I use the 78.46.32.117 numeric address in a browser, it goes to a blank white page, with only this on it. 8O
Quote:
It works!

Are they trying to play with my mind? :wink:

When I added /KDE/ to the numeric address (,http://78.46.32.117/KDE/), I get this:
Quote:
Not Found

The requested URL /KDE/ was not found on this server.
Apache/2.2.4 (Ubuntu) PHP/5.2.3-1ubuntu6.3 Server at 78.46.32.117 Port 80
Is this 78.46.32.117 address supposed to be a unbuntu server? :o
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Sat May 10, 2008 5:17 pm    Post subject: Reply with quote

wrc1944 wrote:
beso_1717 wrote:
Quote:
then maybe your isp uses a route to that ip address that is full of traffic. from time to time i experience the same problems with some sites, that aren't reachable from one ip but are reachable from an external free proxy (that uses a different route).
That's an interesting theory, but it's worked for years, and my isp hasn't changed anything (cox.net). :? Besides, anonsvn works fine, and they are the same IP address- at least that's what it seems to be. :? :roll:


that doesn't matter. the routes aren't changed instantly when traffic rises. if there is a node that has too much traffic in it it will pass some time (could be also months) before the isp changes its route to another node when the congestioned one doesn't work how it is supposed. an example is the following:
you need to go from point a to point b and to do so you can go through node c and then to node b or you can use another route that goes through node d and e and then finally arrives at node b. usually the second route is not convenient so the isp would use the first node. but if node b gets too much traffic then packets would be dropped and node b would be unreachable from node a. usually in these situations isps change the route. but they don't handle this manually but with protocols that do the routing tables like rip. rip is one of the oldest but also one of the worst protocols, because it is quite latent when the network is congestioned or when a node or link fails but is very easy to mantain and quite fast in generating the routing tables and also it isn't server centric. also isps can reroute just some types of traffic (based on tcp port for example) or filter the traffic when the network is full (like dropping packets to the specific node b on the git tcp port).

Quote:

Berniyh wrote:
Quote:
But websvn is not anonsvn, anonsvn has the IP 78.46.32.117.
If so, how come ping reports 138.246.255.177, but can't connect to the server? It's a mystery to me. :roll:
When I use the 78.46.32.117 numeric address in a browser, it goes to a blank white page, with only this on it. 8O
It works! Are they trying to play with my mind? :wink:

When I added /KDE/ to the numeric address (,http://78.46.32.117/KDE/), I get this:
Quote:
Not Found

The requested URL /KDE/ was not found on this server.
Apache/2.2.4 (Ubuntu) PHP/5.2.3-1ubuntu6.3 Server at 78.46.32.117 Port 80
Is this 78.46.32.117 address supposed to be a unbuntu server? :o


this is normal. if you try to use the git ip address (anonsvn) in a web browser you'd get an apache2 error. the same would go with git when trying to connect to gitweb without the proper http protocol. the stuff you've seen it tells you the following:

Quote:
our server, apache 2.2.4, running on ubuntu manchine, with enabled php 5.2.3-1 on ubuntu server 6.3 cannot connect to the requested url 78.46.32.117 on the port 80

it seems that kde anongit is on a ubuntu server with apache 2.2.4 and php 5.2.3-1 installed on.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat May 10, 2008 6:39 pm    Post subject: Reply with quote

beso_1717,
Thanks for the info- I really appreciate you taking the time to clarify this stuff for me. :) Networking is probably one of my weakest areas of knowledge- I really need to learn more about it. Sorry if I cluttered up the thread with some quasi-off-topic stuff.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Sat May 10, 2008 6:40 pm    Post subject: Reply with quote

I have an ebuild request:

gtk-engines-qt from svn - works with Qt/KDE4.

The package itself is designed to be installed alongside the Qt3 version [0.8] in portage, so it oughto be slotted :)
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
fldc2
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2006
Posts: 112
Location: Motala, Sweden

PostPosted: Sat May 10, 2008 8:27 pm    Post subject: Reply with quote

Cephalon wrote:
Hello, after paludis+kde4 update i have much more problems, first of all and most serious is that after i logged in, i don't know what happen and few minutes later my keyboard stop responding and i have to restart the x. My second problem is tha if i am logged in first time after a reboot everything works but if i logout and try to login again the splash screen appears and crash there on splash screen no message just the splash screen. i need your help. Sorry for my english.

This was fixed some days ago, update kdelibs again.
Back to top
View user's profile Send private message
Pic0
n00b
n00b


Joined: 09 Feb 2006
Posts: 55

PostPosted: Sat May 10, 2008 9:01 pm    Post subject: Reply with quote

Hi,

Thanks for these ebuilds :)

Is there any plan for a live kde-l10n kdebuild ? This could be very convenient for KDE translators, considering that a lot of work will have to be done to update all messages to KDE4.1 after the message freeze, which will happen soon (may 20th).

Regards,
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sat May 10, 2008 10:24 pm    Post subject: Reply with quote

Pic0 wrote:
Hi,

Thanks for these ebuilds :)

Is there any plan for a live kde-l10n kdebuild ? This could be very convenient for KDE translators, considering that a lot of work will have to be done to update all messages to KDE4.1 after the message freeze, which will happen soon (may 20th).

Regards,

Yes, there are plans, but I can't tell you when it will happen.
Back to top
View user's profile Send private message
Cephalon
n00b
n00b


Joined: 04 Nov 2007
Posts: 23

PostPosted: Sun May 11, 2008 10:54 am    Post subject: Reply with quote

fldc2 wrote:
Cephalon wrote:
Hello, after paludis+kde4 update i have much more problems, first of all and most serious is that after i logged in, i don't know what happen and few minutes later my keyboard stop responding and i have to restart the x. My second problem is tha if i am logged in first time after a reboot everything works but if i logout and try to login again the splash screen appears and crash there on splash screen no message just the splash screen. i need your help. Sorry for my english.

This was fixed some days ago, update kdelibs again.


thanx fldc2 it works good now, my problem now is that the plasmaoids dont save the size, i change it and after logout and login the plasmoids size go back to default.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sun May 11, 2008 3:59 pm    Post subject: Reply with quote

I'm trying a rebuild with
Code:
paludis -i kde-scm --dl-reinstall-targets always
It first updated about 8-9 other packages, and then kdelibs, however, kdepimlibs just failed. :cry: I forgot that before when this happened I had to rebuild akonadi first.

Shouldn't akonadi (and maybe a few other deps) be added to /etc/paludis/sets/kdebase-scm.conf BEFORE kdepimlibs is (attempted to be) rebuilt, in order to avoid this problem? Having to rebuild kdelibs again is a PITA. :wink:

Would adding it on a line right before kdepimlibs work, or is the order of building these packages NOT determined by the line sequence?
Quote:
# These files don't belong to kdebase, but they should be reinstalled,
# if kdebase is reinstalled:
? =dev-libs/soprano-scm
* kde-base/kdelibs:kde-svn
* kde-base/kdepimlibs:kde-svn

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sun May 11, 2008 4:22 pm    Post subject: Reply with quote

wrc1944 wrote:
I'm trying a rebuild with
Code:
paludis -i kde-scm --dl-reinstall-targets always
It first updated about 8-9 other packages, and then kdelibs, however, kdepimlibs just failed. :cry: I forgot that before when this happened I had to rebuild akonadi first.

Shouldn't akonadi (and maybe a few other deps) be added to /etc/paludis/sets/kdebase-scm.conf BEFORE kdepimlibs is (attempted to be) rebuilt, in order to avoid this problem? Having to rebuild kdelibs again is a PITA. :wink:

Would adding it on a line right before kdepimlibs work, or is the order of building these packages NOT determined by the line sequence?
Quote:
# These files don't belong to kdebase, but they should be reinstalled,
# if kdebase is reinstalled:
? =dev-libs/soprano-scm
* kde-base/kdelibs:kde-svn
* kde-base/kdepimlibs:kde-svn

Obviously you have an old version of the set. The current kdebase-scm set starts like this:
Code:
# This file contains everything in kdebase

# Include the dependencies
* kde-deps-scm

# This is kdebase
?: kde-base/dolphin:kde-svn
...

While kde-dep-scm looks like this:
Code:
# This file contains basic dependencies for KDE4

* =app-office/akonadi-scm
? =dev-libs/soprano-scm
* =kde-base/automoc-scm
* kde-base/kdelibs:kde-svn
* kde-base/kdepimlibs:kde-svn


BTW, the order of the packages in the set doesn't matter, that's why they are normally sorted alphabetically.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sun May 11, 2008 4:28 pm    Post subject: Reply with quote

Berniyh wrote:
Quote:
Obviously you have an old version of the set. The current kdebase-scm set starts like this:
Hmmm.- I just sync'd everything about 3 hours ago- shouldn't that have updated /etc/paludis too? I'm at 70% on kdelibs (3rd time today. :roll: I have no kde-dep-scm file in /etc/paludis. Should I stop and update those config files or am I OK this time?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Sun May 11, 2008 5:54 pm    Post subject: Reply with quote

creidiki wrote:
I have an ebuild request:

gtk-engines-qt from svn - works with Qt/KDE4.

The package itself is designed to be installed alongside the Qt3 version [0.8] in portage, so it oughto be slotted :)


i'm trying to adapt the gtk-kde4 ebuild from the arcon overlay to the kdebuild-1 system, but i've just started to work on it since i've just found out that it exists. the only problem is testing it, since to me kde4 still doesn't work.
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Sun May 11, 2008 5:58 pm    Post subject: Reply with quote

That one look interesting too. They're different packages however.
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
Pic0
n00b
n00b


Joined: 09 Feb 2006
Posts: 55

PostPosted: Sun May 11, 2008 6:01 pm    Post subject: Reply with quote

Berniyh wrote:
Yes, there are plans, but I can't tell you when it will happen.


OK thanks you. In the meantime I'm using an old ebuild found earlier on this forum.

BTW could you please also add an ebuild for lokalize ? (this is the replacement for kbabel, a tool for translating .po files)
I created a working one very simply (just had to copy a simple kdebuild as a template, and add "kde-base/kdesk kde-base/lokalize" in KDE_DERIVATION_MAP in eclass/kde4-functions.eclass )
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sun May 11, 2008 6:26 pm    Post subject: Reply with quote

wrc1944 wrote:
Berniyh wrote:
Quote:
Obviously you have an old version of the set. The current kdebase-scm set starts like this:
Hmmm.- I just sync'd everything about 3 hours ago- shouldn't that have updated /etc/paludis too? I'm at 70% on kdelibs (3rd time today. :roll: I have no kde-dep-scm file in /etc/paludis. Should I stop and update those config files or am I OK this time?

Err... no. /etc/paludis won't be touched by anything but the user. If you copied the set there, it will take the old one.
The overlay sets are in $location/sets and it will take those if no set with the name exists in /etc/paludis already.
The sets don't need to be copied or link to be usable. You can override them, like you just did, but if you don't want to update them manually, you shouldn't.
Pic0 wrote:
Berniyh wrote:
Yes, there are plans, but I can't tell you when it will happen.


OK thanks you. In the meantime I'm using an old ebuild found earlier on this forum.

BTW could you please also add an ebuild for lokalize ? (this is the replacement for kbabel, a tool for translating .po files)
I created a working one very simply (just had to copy a simple kdebuild as a template, and add "kde-base/kdesk kde-base/lokalize" in KDE_DERIVATION_MAP in eclass/kde4-functions.eclass )

kdesdk is on the TODO list. It's just, that someone has to take the time to do it.
In ~2 weeks, I might do at least parts of kdesdk. Currently we are finishing kdepim and kdeadmin first.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sun May 11, 2008 7:18 pm    Post subject: Reply with quote

Berniyh wrote:
Quote:
Err... no. /etc/paludis won't be touched by anything but the user. If you copied the set there, it will take the old one.
The overlay sets are in $location/sets and it will take those if no set with the name exists in /etc/paludis already.
The sets don't need to be copied or link to be usable. You can override them, like you just did, but if you don't want to update them manually, you shouldn't.
Thanks Berniyh,
If I understand correctly, all the files in /etc/paludis/sets are NOT actually required, unless I want/need to over-ride/change the default settings. The default .conf files are in the overlay, and if they change, the new revisions will be used, but ONLY if there is nothing in /etc/paludis/sets over-riding them.

Where I got into trouble with the akonadi/kdepimlibs problem was because I had copied the default files to /etc/paludis/sets when I originally installed paludis, and even though I had just sync'd the overlay, the old original /etc/paludis/sets/kdebase-scm.conf was over-riding the newer version I just got today in the overlay.

So for the average end-user, it's probably better not to have anything in /etc/paludis/sets, and just rely on the overlay defaults, until you really know what you're doing.

Have I got it right, or am I still missing something? :wink:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sun May 11, 2008 8:52 pm    Post subject: Reply with quote

wrc1944 wrote:
So for the average end-user, it's probably better not to have anything in /etc/paludis/sets, and just rely on the overlay defaults, until you really know what you're doing.

Yes, I would recommend that. Normally, if you have to change something, it's a bug in the set and should be fixed in the overlay.
Of course you can create own sets, they are useful for a lot of stuff, you just should pay attention, that they don't override something that they shouldn't override.
Back to top
View user's profile Send private message
Pic0
n00b
n00b


Joined: 09 Feb 2006
Posts: 55

PostPosted: Mon May 12, 2008 9:03 am    Post subject: Reply with quote

Berniyh wrote:
kdesdk is on the TODO list. It's just, that someone has to take the time to do it.
In ~2 weeks, I might do at least parts of kdesdk. Currently we are finishing kdepim and kdeadmin first.


I understand. That's totally OK for me (I use kdepim a lot more than kdesdk ;) )

Keep up the good work ! :D
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 157

PostPosted: Mon May 12, 2008 9:51 am    Post subject: Reply with quote

Am I the only one for whom kmail and konqueror don't use custom shortcuts? They seem to be correctly stored in the configuration files, (.kdesvn/share/apps/kmail/kmmainwin.rc for kmail and .kdesvn/share/apps/konqueror/konqueror.rc for konqueror), but aren't read on startup. If I set them after the application has started using the configuration dialog, they work, until I close the program.

By the way, my issue with the keyboard stopping to work when installing something related to kde4 seems to have vanished by itself.
_________________
Stefano
Back to top
View user's profile Send private message
Cephalon
n00b
n00b


Joined: 04 Nov 2007
Posts: 23

PostPosted: Mon May 12, 2008 1:42 pm    Post subject: Reply with quote

Hello again, i try to install digikam witha paludis and when the media-libs/libkipi-scm package try to configure fail with the following code.

Code:
>>> Starting src_compile                                                                 
-- The C compiler identification is GNU                                                   
-- The CXX compiler identification is GNU                                                 
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc                         
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works               
-- Detecting C compiler ABI info                                                         
-- Detecting C compiler ABI info - done                                                   
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++                       
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works             
-- Detecting CXX compiler ABI info                                                       
-- Detecting CXX compiler ABI info - done                                                 
-- Looking for Q_WS_X11                                                                   
-- Looking for Q_WS_X11 - found                                                           
-- Looking for Q_WS_WIN                                                                   
-- Looking for Q_WS_WIN - not found.                                                     
-- Looking for Q_WS_QWS                                                                   
-- Looking for Q_WS_QWS - not found.                                                     
-- Looking for Q_WS_MAC                                                                   
-- Looking for Q_WS_MAC - not found.                                                     
-- Found Qt-Version 4.4.0-rc1 (using /usr/bin/qmake)                                     
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname                                                                                                                                           
-- Looking for gethostbyname - found                                                                                                                                   
-- Looking for connect                                                                                                                                                 
-- Looking for connect - found                                                                                                                                         
-- Looking for remove                                                                                                                                                 
-- Looking for remove - found                                                                                                                                         
-- Looking for shmat                                                                                                                                                   
-- Looking for shmat - found                                                                                                                                           
-- Looking for IceConnectionNumber in ICE                                                                                                                             
-- Looking for IceConnectionNumber in ICE - found                                                                                                                     
-- Found X11: /usr/lib64/libX11.so                                                                                                                                     
-- Looking for include files CMAKE_HAVE_PTHREAD_H                                                                                                                     
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found                                                                                                             
-- Looking for pthread_create in pthreads                                                                                                                             
-- Looking for pthread_create in pthreads - not found                                                                                                                 
-- Looking for pthread_create in pthread                                                                                                                               
-- Looking for pthread_create in pthread - found                                                                                                                       
-- Found Automoc4: /usr/bin/automoc4                                                                                                                                   
-- Found Perl: /usr/bin/perl                                                                                                                                           
-- Performing Test HAVE_FPIE_SUPPORT                                                                                                                                   
-- Performing Test HAVE_FPIE_SUPPORT - Success                                                                                                                         
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL                                                                                                                     
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success                                                                                                           
-- Performing Test __KDE_HAVE_GCC_VISIBILITY                                                                                                                           
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success                                                                                                                 
-- Found KDE 4.1 include dir: /usr/kde/svn/include                                                                                                                     
-- Found KDE 4.1 library dir: /usr/kde/svn/lib64                                                                                                                       
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/svn/bin/kconfig_compiler                                                                                         
-- Found KDE4 automoc: /usr/bin/automoc4                                                                                                                               
-- Found Sane: /usr/include                                                                                                                                           
-- Check Kdcraw library in local sub-folder...                                                                                                                         
-- Check Kdcraw library using pkg-config...                                                                                                                           
-- KDE CMake PKGCONFIG macro indicates that libkdcraw is not installed on your computer.                                                                               
-- Install the package which contains libkdcraw.pc if you want to support this feature.                                                                               
CMake Error at /usr/kde/svn/share/apps/cmake/modules/FindKdcraw.cmake:92 (message):                                                                                   
  Could NOT find libkdcraw header files                                                                                                                               
Call Stack (most recent call first):                                                                                                                                   
  libkipi/CMakeLists.txt:49 (FIND_PACKAGE)                                                                                                                             


-- Configuring done

!!! ERROR in media-libs/libkipi-scm:
!!! In cmake-utils_src_configureout at line 1083
!!! Cmake failed                               

!!! Call stack:
!!!    * cmake-utils_src_configureout (/var/tmp/paludis/media-libs-libkipi-scm/temp/loadsaveenv:1083)
!!!    * kde4-base_src_configure (/var/tmp/paludis/media-libs-libkipi-scm/temp/loadsaveenv:3086)     
!!!    * kde4-meta_src_configure (/var/tmp/paludis/media-libs-libkipi-scm/temp/loadsaveenv:3333)     
!!!    * kde4-meta_src_compile (/var/tmp/paludis/media-libs-libkipi-scm/temp/loadsaveenv:3327)       
!!!    * src_compile (/var/tmp/paludis/media-libs-libkipi-scm/temp/loadsaveenv:4228)
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 24853 exit with error
die trap: exiting with error.

Install error:
  * In program paludis -i digikam:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'media-libs/libkipi-scm:kde-svn::kde4-experimental':
  * Install error: Install failed for 'media-libs/libkipi-scm:kde-svn::kde4-experimental'


but the libkdcraw just emerge it (paludis it!!)

Code:
sudo paludis -ip libkdcraw
Building target list... paludis@1210610446: [QA version_spec.too_long] In program paludis -ip libkdcraw:
  ... When performing install action from command line:                                                 
  ... When adding install target 'libkdcraw':                                                           
  ... When disambiguating package name 'libkdcraw':                                                     
  ... When finding category names containing package 'libkdcraw':                                       
  ... When loading names for virtuals repository:                                                       
  ... When finding provided packages for 'installed':                                                   
  ... When checking for package 'media-libs/libquicktime' in installed:                                 
  ... When loading package names from '/var/db/pkg' in category 'media-libs':                           
  ... When parsing package dep spec '=media-libs/capseo-0.3.0_pre200712251-r1':                         
  ... When parsing version spec '0.3.0_pre200712251-r1':                                               
  ... Number part '200712251' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)
paludis@1210610446: [QA version_spec.too_long] In program paludis -ip libkdcraw:                                                                                         
  ... When performing install action from command line:
  ... When adding install target 'libkdcraw':
  ... When disambiguating package name 'libkdcraw':
  ... When finding category names containing package 'libkdcraw':
  ... When loading names for virtuals repository:
  ... When finding provided packages for 'installed':
  ... When checking for package 'media-libs/libquicktime' in installed:
  ... When loading package names from '/var/db/pkg' in category 'media-libs':
  ... When parsing package dep spec '=media-libs/libcaptury-0.3.0_pre200712251':
  ... When parsing version spec '0.3.0_pre200712251':
  ... Number part '200712251' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)
paludis@1210610446: [WARNING e.vdb.provides.no_package] In program paludis -ip libkdcraw:
  ... When performing install action from command line:
  ... When adding install target 'libkdcraw':
  ... When disambiguating package name 'libkdcraw':
  ... When finding category names containing package 'libkdcraw':
  ... When loading names for virtuals repository:
  ... When finding provided packages for 'installed':
  ... No package available for 'sys-apps/man 1.6f'
paludis@1210610446: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-apps/paludis 0.26.0'
paludis@1210610446: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-boot/grub 0.97-r4'
paludis@1210610446: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-fs/udev 115-r1'

Building dependency list...

These packages will be installed:

* media-libs/libkdcraw::kde4-experimental :kde-svn [R scm] <target>

Total: 1 package (1 rebuild)
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Mon May 12, 2008 2:50 pm    Post subject: Reply with quote

I just tried it again and it works here.
Please make sure you sync before you test it. ;)
And to be sure reinstall the media libs and kipi-plugins.
Back to top
View user's profile Send private message
Pic0
n00b
n00b


Joined: 09 Feb 2006
Posts: 55

PostPosted: Mon May 12, 2008 9:25 pm    Post subject: Reply with quote

Berniyh wrote:
I just tried it again and it works here.
Please make sure you sync before you test it. ;)
And to be sure reinstall the media libs and kipi-plugins.


I have the exact same error (everything is synced and all KDE kdebuild are freshly repaluded).
Actually I always had this error every time I tried compiling libkipi-scm, as far as I remember. :(

What information do you need ?
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Mon May 12, 2008 11:55 pm    Post subject: Reply with quote

Pic0 wrote:
Berniyh wrote:
I just tried it again and it works here.
Please make sure you sync before you test it. ;)
And to be sure reinstall the media libs and kipi-plugins.


I have the exact same error (everything is synced and all KDE kdebuild are freshly repaluded).
Actually I always had this error every time I tried compiling libkipi-scm, as far as I remember. :(

What information do you need ?

build.log files would be a start. For libkdcraw and libkipi.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6 ... 26, 27, 28  Next
Page 5 of 28

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum