Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 Overlay (Part 6)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 26, 27, 28  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Thu May 15, 2008 4:41 pm    Post subject: Reply with quote

What does it mean if akonady fails tests?

Quote:
* >>> Test phase [test]: app-office/akonadi-scm
make -j1 -j1 test
Running tests...
Start processing tests
Test project /var/tmp/paludis/app-office-akonadi-scm/work/akonadi_build
1/ 5 Testing akonadidb-xmllint Passed
2/ 5 Testing akonadidbupdate-xmllint Passed
3/ 5 Testing akonadi-interpretertest ***Failed
4/ 5 Testing akonadi-querybuildertest ***Failed
5/ 5 Testing akonadi-handlertest ***Failed

40% tests passed, 3 tests failed out of 5

The following tests FAILED:
3 - akonadi-interpretertest (Failed)
4 - akonadi-querybuildertest (Failed)
5 - akonadi-handlertest (Failed)
Errors while running CTest
make: *** [test] Error 8
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Thu May 15, 2008 6:32 pm    Post subject: Reply with quote

cerebro84 wrote:
What does it mean if akonady fails tests?

Quote:
* >>> Test phase [test]: app-office/akonadi-scm
make -j1 -j1 test
Running tests...
Start processing tests
Test project /var/tmp/paludis/app-office-akonadi-scm/work/akonadi_build
1/ 5 Testing akonadidb-xmllint Passed
2/ 5 Testing akonadidbupdate-xmllint Passed
3/ 5 Testing akonadi-interpretertest ***Failed
4/ 5 Testing akonadi-querybuildertest ***Failed
5/ 5 Testing akonadi-handlertest ***Failed

40% tests passed, 3 tests failed out of 5

The following tests FAILED:
3 - akonadi-interpretertest (Failed)
4 - akonadi-querybuildertest (Failed)
5 - akonadi-handlertest (Failed)
Errors while running CTest
make: *** [test] Error 8


1. bothersome stuff: akonadi fails to install
2. not bothersome stuff: just disable tests for this package (or for entire system) and it will install and you could use it. i've found out that the test phase isn't very useful and is just a waste of time for what i use the system.

is there a version of kde-l18n for scm builds or will it be one someday?!
Back to top
View user's profile Send private message
PurpleGecko
n00b
n00b


Joined: 16 Sep 2007
Posts: 14
Location: Germany

PostPosted: Sat May 17, 2008 2:15 pm    Post subject: Kmail / Kontact Problems... and also something with db Reply with quote

It looks like there were a few changes made that affect the ebuild for KMail, Kontact, kaddressbook, korganizer, knotes...etc... pretty much anything in kdepim could possibly be affects.

kontact/interfaces has now been renamed to kontactinterfaces and therefor causes some problems. As I'm not really sure how the ebuilds here work I haven't tried to fix them myself, just wanted to pass on the information.
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Sat May 17, 2008 2:15 pm    Post subject: Reply with quote

I guys... I've compiled kde-svn with paludis and all works quite well, less desktop effect........ I'm able to see desktop effect only if I use Xrender with smooth scaling option enable... but refresh rate it's terrible and it is unusable...
Open-gl doesn't work ( I'm able to check them but I don't see any effect) , even if ati-drivers are installed properly (opengl version 2.1.7415), my xorg.conf is:

http://rafb.net/p/GOydj235.html

I think that I don't need any other option enable........ suggestion? thank you...
Back to top
View user's profile Send private message
PurpleGecko
n00b
n00b


Joined: 16 Sep 2007
Posts: 14
Location: Germany

PostPosted: Sat May 17, 2008 2:39 pm    Post subject: Reply with quote

ficofico wrote:
I guys... I've compiled kde-svn with paludis and all works quite well, less desktop effect........ I'm able to see desktop effect only if I use Xrender with smooth scaling option enable... but refresh rate it's terrible and it is unusable...
Open-gl doesn't work ( I'm able to check them but I don't see any effect) , even if ati-drivers are installed properly (opengl version 2.1.7415), my xorg.conf is:

http://rafb.net/p/GOydj235.html

I think that I don't need any other option enable........ suggestion? thank you...


Not sure if this will help, however I have had this happen to me before. If you've installed a new kernel recently if might be that the fglrx driver module isn't being loaded. X runs for me even if the fglrx module isn't loaded, however anything to do with composite and such doesn't work or is so slow that I have to kill it.
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Sat May 17, 2008 3:21 pm    Post subject: Reply with quote

i'm very frustrated.. my plasma desktop crashes a fraking lot.

i can't compile my "old" plasmoids from kde-look.org

any idea?

here is quicklauncer error output:
Code:

[ 25%] Generating ui_quicklauncherAdd.h
Generating quicklauncher.moc
[ 50%] Generating ui_quicklauncherConfig.h
Scanning dependencies of target plasma_applet_quicklauncher
[ 75%] Building CXX object CMakeFiles/plasma_applet_quicklauncher.dir/plasma_applet_quicklauncher_automoc.o
[100%] Building CXX object CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o
En el fichero incluído de /plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:22:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:43:39: error: plasma/layouts/vboxlayout.h: No existe el fichero o el directorio
In file included from /plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:22:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:113: error: expected class-name before ‘{’ token
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:115: error: expected `)' before ‘*’ token
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h: In member function ‘QRectF InnerLayout::geometry() const’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:123: error: ‘count’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:124: error: ‘itemAt’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:127: error: ‘count’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In constructor ‘QuickLauncher::QuickLauncher(QObject*, const QVariantList&)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:42: error: ‘setDrawStandardBackground’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘virtual void QuickLauncher::init()’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: ‘HBoxLayout’ no es un miembro de ‘Plasma’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: ‘outerLayout’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: expected type-specifier
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: expected `;'
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:63: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:67: error: se trata la lista de expresiones new initializer como una expresión compuesta
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:67: aviso: left-hand operand of comma no tiene efecto
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:67: error: no se encontró una función coincidente para la llamada a ‘InnerLayout::InnerLayout(int&)’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:113: nota: los candidatos son: InnerLayout::InnerLayout()
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:113: nota:                     InnerLayout::InnerLayout(const InnerLayout&)
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:68: error: ‘class InnerLayout’ no tiene un miembro llamado ‘setMultiRow’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:69: error: ‘class InnerLayout’ no tiene un miembro llamado ‘setMargin’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:70: error: ‘class InnerLayout’ no tiene un miembro llamado ‘setSpacing’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:71: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:78: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::createLayout()’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:100: error: ‘class InnerLayout’ no tiene un miembro llamado ‘takeAt’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:104: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:112: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::fillWidget()’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:123: error: ‘class InnerLayout’ no tiene un miembro llamado ‘addItem’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘QSizeF QuickLauncher::contentSizeHint() const’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:130: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::constraintsUpdated(Plasma::Constraints)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:152: error: ‘setDrawStandardBackground’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:158: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘virtual void QuickLauncher::dropEvent(QGraphicsSceneDragDropEvent*)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:228: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::readDesktopFile(int, QString)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:386: error: ‘contentSize’ no se declaró en este ámbito
make[2]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o] Error 1
make[1]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/all] Error 2
make: *** [all] Error 2
[ 25%] Building CXX object CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o
En el fichero incluído de /plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:22:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:43:39: error: plasma/layouts/vboxlayout.h: No existe el fichero o el directorio
In file included from /plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:22:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:113: error: expected class-name before ‘{’ token
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:115: error: expected `)' before ‘*’ token
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h: In member function ‘QRectF InnerLayout::geometry() const’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:123: error: ‘count’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:124: error: ‘itemAt’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:127: error: ‘count’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In constructor ‘QuickLauncher::QuickLauncher(QObject*, const QVariantList&)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:42: error: ‘setDrawStandardBackground’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘virtual void QuickLauncher::init()’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: ‘HBoxLayout’ no es un miembro de ‘Plasma’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: ‘outerLayout’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: expected type-specifier
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:60: error: expected `;'
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:63: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:67: error: se trata la lista de expresiones new initializer como una expresión compuesta
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:67: aviso: left-hand operand of comma no tiene efecto
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:67: error: no se encontró una función coincidente para la llamada a ‘InnerLayout::InnerLayout(int&)’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:113: nota: los candidatos son: InnerLayout::InnerLayout()
/plasma-applet-quicklauncher-0.3/src/quicklauncher.h:113: nota:                     InnerLayout::InnerLayout(const InnerLayout&)
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:68: error: ‘class InnerLayout’ no tiene un miembro llamado ‘setMultiRow’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:69: error: ‘class InnerLayout’ no tiene un miembro llamado ‘setMargin’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:70: error: ‘class InnerLayout’ no tiene un miembro llamado ‘setSpacing’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:71: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:78: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::createLayout()’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:100: error: ‘class InnerLayout’ no tiene un miembro llamado ‘takeAt’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:104: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:112: error: invalid use of incomplete type ‘struct QGraphicsLayout’
/usr/include/qt4/QtGui/qgraphicswidget.h:60: error: forward declaration of ‘struct QGraphicsLayout’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::fillWidget()’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:123: error: ‘class InnerLayout’ no tiene un miembro llamado ‘addItem’
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘QSizeF QuickLauncher::contentSizeHint() const’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:130: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::constraintsUpdated(Plasma::Constraints)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:152: error: ‘setDrawStandardBackground’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:158: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘virtual void QuickLauncher::dropEvent(QGraphicsSceneDragDropEvent*)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:228: error: ‘contentSize’ no se declaró en este ámbito
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp: In member function ‘void QuickLauncher::readDesktopFile(int, QString)’:
/plasma-applet-quicklauncher-0.3/src/quicklauncher.cpp:386: error: ‘contentSize’ no se declaró en este ámbito
make[2]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o] Error 1
make[1]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/all] Error 2
make: *** [all] Error 2


coremoid:
Code:

[ 25%] Generating ui_coremoidConfig.h
Generating coremoidapplet.moc
Scanning dependencies of target plasma_applet_coremoid
[ 50%] Building CXX object CMakeFiles/plasma_applet_coremoid.dir/plasma_applet_coremoid_automoc.o
[ 75%] Building CXX object CMakeFiles/plasma_applet_coremoid.dir/coremoidapplet.o
/coremoid-0.3.1/coremoidapplet.cpp: In member function ‘virtual void CoreMoidApplet::init()’:
/coremoid-0.3.1/coremoidapplet.cpp:106: error: ‘self’ no es un miembro de ‘Plasma::Theme’
/coremoid-0.3.1/coremoidapplet.cpp:107: error: ‘self’ no es un miembro de ‘Plasma::Theme’
make[2]: *** [CMakeFiles/plasma_applet_coremoid.dir/coremoidapplet.o] Error 1
make[1]: *** [CMakeFiles/plasma_applet_coremoid.dir/all] Error 2
make: *** [all] Error 2


toggle-compositing:
Code:
Generating ktimerdialog.moc
Generating confirmation_dialog.moc
Generating toggle_compositing.moc
Scanning dependencies of target plasma_applet_toggle_compositing
[ 25%] Building CXX object CMakeFiles/plasma_applet_toggle_compositing.dir/plasma_applet_toggle_compositing_automoc.o
[ 50%] Building CXX object CMakeFiles/plasma_applet_toggle_compositing.dir/toggle_compositing.o
/toggle-compositing/toggle_compositing.cpp: In constructor ‘ToggleCompositing::ToggleCompositing(QObject*, const QVariantList&)’:
/toggle-compositing/toggle_compositing.cpp:49: error: ‘setContentSize’ no se declaró en este ámbito
/toggle-compositing/toggle_compositing.cpp:51: error: no se encontró una función coincidente para la llamada a ‘Plasma::Svg::Svg(const char [21])’
/usr/kde/svn/include/plasma/svg.h:70: nota: los candidatos son: Plasma::Svg::Svg(QObject*)
/usr/kde/svn/include/plasma/svg.h:48: nota:                     Plasma::Svg::Svg(const Plasma::Svg&)
/toggle-compositing/toggle_compositing.cpp: In member function ‘QSizeF ToggleCompositing::contentSizeHint() const’:
/toggle-compositing/toggle_compositing.cpp:83: error: ‘contentSize’ no se declaró en este ámbito
/toggle-compositing/toggle_compositing.cpp: In member function ‘virtual void ToggleCompositing::mousePressEvent(QGraphicsSceneMouseEvent*)’:
/toggle-compositing/toggle_compositing.cpp:169: error: ‘contentRect’ no se declaró en este ámbito
/toggle-compositing/toggle_compositing.cpp: In member function ‘virtual void ToggleCompositing::paintInterface(QPainter*, const QStyleOptionGraphicsItem*, const QRect&)’:
/toggle-compositing/toggle_compositing.cpp:186: error: ‘contentSize’ no se declaró en este ámbito
make[2]: *** [CMakeFiles/plasma_applet_toggle_compositing.dir/toggle_compositing.o] Error 1
make[1]: *** [CMakeFiles/plasma_applet_toggle_compositing.dir/all] Error 2
make: *** [all] Error 2


thanks in advance..
_________________
Mens sana in corpore sano... Gentoo laetificat cor hominis
Back to top
View user's profile Send private message
PurpleGecko
n00b
n00b


Joined: 16 Sep 2007
Posts: 14
Location: Germany

PostPosted: Sat May 17, 2008 4:17 pm    Post subject: Reply with quote

enzobelmont wrote:
i'm very frustrated.. my plasma desktop crashes a fraking lot.

i can't compile my "old" plasmoids from kde-look.org

any idea?

<snip>


There were a number of major changes to Plasma after the move to Qt 4.4, and at this point the older plasmoids need to be updated before they will be able to compile now. We'll just have to wait patiently until a nice programmer updates them and brings out a newer version.
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Sat May 17, 2008 4:32 pm    Post subject: Reply with quote

PurpleGecko wrote:
ficofico wrote:
I guys... I've compiled kde-svn with paludis and all works quite well, less desktop effect........ I'm able to see desktop effect only if I use Xrender with smooth scaling option enable... but refresh rate it's terrible and it is unusable...
Open-gl doesn't work ( I'm able to check them but I don't see any effect) , even if ati-drivers are installed properly (opengl version 2.1.7415), my xorg.conf is:

http://rafb.net/p/GOydj235.html

I think that I don't need any other option enable........ suggestion? thank you...


Not sure if this will help, however I have had this happen to me before. If you've installed a new kernel recently if might be that the fglrx driver module isn't being loaded. X runs for me even if the fglrx module isn't loaded, however anything to do with composite and such doesn't work or is so slow that I have to kill it.
Google earth works well, module should be loaded well
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sat May 17, 2008 4:38 pm    Post subject: Re: Kmail / Kontact Problems... and also something with db Reply with quote

PurpleGecko wrote:
It looks like there were a few changes made that affect the ebuild for KMail, Kontact, kaddressbook, korganizer, knotes...etc... pretty much anything in kdepim could possibly be affects.

kontact/interfaces has now been renamed to kontactinterfaces and therefor causes some problems. As I'm not really sure how the ebuilds here work I haven't tried to fix them myself, just wanted to pass on the information.

Thanks for reporting that, someone will have a look at it.
(Not me though, busy unfortunately.)

enzobelmont wrote:
i'm very frustrated.. my plasma desktop crashes a fraking lot.

i can't compile my "old" plasmoids from kde-look.org

any idea?

here is quicklauncer error output:
--snip--

thanks in advance..

I know about these problems (I'm maintaining the overlay where you got that ebuild).
First, the some of the ebuilds in the overlay currently don't work, because they are affected by the Plasma api changes. There have to be new releases for these.
Second, I'm a bit busy atm, so that's why I haven't been able to bump everything (busy on the kde4 overlay, too), but I'll update those plasmoids, that have been updated on kde-look.org next week, hopefully.
Third, I don't have access to the server that hosts the overlay, but that hopefully will change next week, too.
Sorry for the mess it currently is. ;)
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Sat May 17, 2008 9:57 pm    Post subject: Reply with quote

Quote:
I guys... I've compiled kde-svn with paludis and all works quite well, less desktop effect........ I'm able to see desktop effect only if I use Xrender with smooth scaling option enable... but refresh rate it's terrible and it is unusable...
Open-gl doesn't work ( I'm able to check them but I don't see any effect) , even if ati-drivers are installed properly (opengl version 2.1.7415), my xorg.conf is:

http://rafb.net/p/GOydj235.html

I think that I don't need any other option enable........ suggestion? thank you...
I've solved, now I'm able to see desktop effect......... the mistake was to compile with a xorg.conf not setting well, after finish to compile I've change my xorg.conf but obviovsly it was to late......... I've recompile kde-svn again with xorg.conf with all setting and now plugins works well....
Back to top
View user's profile Send private message
Dagger
Retired Dev
Retired Dev


Joined: 11 Jun 2003
Posts: 765
Location: UK

PostPosted: Sun May 18, 2008 4:20 am    Post subject: Reply with quote

Quote:

# solid/CMakeLists.txt has an add_subdirectory statement that depends on
# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
# for now.

http://websvn.kde.org/trunk/KDE/kdebase/workspace/solid/networkmanager-0.7/

NM 0.7 is present now. Compiling now to see if it works.
_________________
95% of all computer errors occur between chair and keyboard (TM)
Join the FSF as an Associate Member!
Post under CC license.
Back to top
View user's profile Send private message
Dagger
Retired Dev
Retired Dev


Joined: 11 Jun 2003
Posts: 765
Location: UK

PostPosted: Sun May 18, 2008 3:11 pm    Post subject: Reply with quote

it works. Not all the features are implemented yet, but compiles fine.
_________________
95% of all computer errors occur between chair and keyboard (TM)
Join the FSF as an Associate Member!
Post under CC license.
Back to top
View user's profile Send private message
Dagger
Retired Dev
Retired Dev


Joined: 11 Jun 2003
Posts: 765
Location: UK

PostPosted: Mon May 19, 2008 10:43 am    Post subject: Reply with quote

anyone got the same problem?

Code:


cat /var/tmp/paludis/kde-base-libplasma-scm/temp//libplasma-install-headers.patch-31917.out
***** libplasma-install-headers.patch *****

===========================================

PATCH COMMAND:    patch -p0 -g0 -E --no-backup-if-mismatch < /var/paludis/repositories/kde4-experimental/kde-base/libplasma/files/libplasma-install-headers.patch

===========================================
can't find file to patch at input line 14
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|From 46eedfd9f5bb9d8b0f0d9addd2cf663dfbe299d4 Mon Sep 17 00:00:00 2001
|From: Bernd Steinhauser <gentoo@bernd-steinhauser.de>
|Date: Wed, 14 May 2008 23:39:22 +0200
|Subject: [PATCH] Add more headers to install routine.
|
|---
| workspace/libs/plasma/CMakeLists.txt |    1 +
| 1 files changed, 1 insertions(+), 0 deletions(-)
|
|diff --git a/workspace/libs/plasma/CMakeLists.txt b/workspace/libs/plasma/CMakeLists.txt
|index a723d84..c46f04a 100644
|--- a/workspace/libs/plasma/CMakeLists.txt
|+++ b/workspace/libs/plasma/CMakeLists.txt
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
===========================================

PATCH COMMAND:    patch -p1 -g0 -E --no-backup-if-mismatch < /var/paludis/repositories/kde4-experimental/kde-base/libplasma/files/libplasma-install-headers.patch


_________________
95% of all computer errors occur between chair and keyboard (TM)
Join the FSF as an Associate Member!
Post under CC license.
Back to top
View user's profile Send private message
PurpleGecko
n00b
n00b


Joined: 16 Sep 2007
Posts: 14
Location: Germany

PostPosted: Mon May 19, 2008 11:31 am    Post subject: Re: Kmail / Kontact Problems... and also something with db Reply with quote

Berniyh wrote:
PurpleGecko wrote:
It looks like there were a few changes made that affect the ebuild for KMail, Kontact, kaddressbook, korganizer, knotes...etc... pretty much anything in kdepim could possibly be affects.

kontact/interfaces has now been renamed to kontactinterfaces and therefor causes some problems. As I'm not really sure how the ebuilds here work I haven't tried to fix them myself, just wanted to pass on the information.

Thanks for reporting that, someone will have a look at it.
(Not me though, busy unfortunately.)


It appears that a simple change in the kde4-meta.eclass should fix the problem. On line 237 is the following:
Code:
KMEXTRACTONLY="${KMEXTRACTONLY} kontact/interfaces/"

Changing that to:
Code:
KMEXTRACTONLY="${KMEXTRACTONLY} kontactinterfaces/"

allows me to compile without any problems. Thus it appears to only affect people with the kontact use flag (if I'm reading that correctly.)
Back to top
View user's profile Send private message
Dagger
Retired Dev
Retired Dev


Joined: 11 Jun 2003
Posts: 765
Location: UK

PostPosted: Mon May 19, 2008 1:46 pm    Post subject: Reply with quote

is there any reason why kde-base/step/step-scm.kdebuild-1 has
Code:

=sci-libs/cln-1.1.13

and not
Code:

>=sci-libs/cln-1.1.13


?
_________________
95% of all computer errors occur between chair and keyboard (TM)
Join the FSF as an Associate Member!
Post under CC license.
Back to top
View user's profile Send private message
PurpleGecko
n00b
n00b


Joined: 16 Sep 2007
Posts: 14
Location: Germany

PostPosted: Mon May 19, 2008 2:31 pm    Post subject: Re: Kmail / Kontact Problems Reply with quote

One other quick change that I had to make was to add:
Code:
kontactinterfaces/

to the kontact-scm.kdebuild-1 file, otherwise it will also have problems building. Not sure if this belongs here or in the eclass...I can compile it at least with it there :)

Hope that helps a little ...

==edit==

Ok... it looks like I spoke too soon :) ... kontactinterfaces library is not being compiled as it doesn't seem to be a part of any ebuild at the moment, and this is now also stopping the kdepim programs from compiling.

==edit2==

I made myself a quick kontactinterfaces ebuild for now and everything compiled fine except kmail (works when I do a 'make clean' and then compile it per hand. Most likely a problem on my side somewhere...)
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 157

PostPosted: Mon May 19, 2008 5:03 pm    Post subject: Reply with quote

Am I the only one who, since yesterday, can't cleanly logout from kde4, since pressing the logout (or shutdown or reboot) button in the K menu, or pressing the associated shortcut immediately causes a crash of all of kde4, sending me back to the login window?

Edit: this issue only happens when the confirmation dialog needs to be displayed. If I use the shortcut for 'logout without confirmation', or disable the 'confirm logout' and 'offer shutdown options' in SystemSettings/Advanced/SessionManager', everything works correctly. This suggests the problem lies in the dialog.
_________________
Stefano
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Mon May 19, 2008 5:47 pm    Post subject: Reply with quote

Am I the only one who, since yesterday, have black text in desktop icons and taskbar?
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Mon May 19, 2008 6:20 pm    Post subject: Reply with quote

Dagger wrote:
is there any reason why kde-base/step/step-scm.kdebuild-1 has
Code:

=sci-libs/cln-1.1.13

and not
Code:

>=sci-libs/cln-1.1.13


?

It fails with 1.1.13, or at least it failed a few weeks ago. Maybe that has changed, I didn't test it yet.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon May 19, 2008 7:48 pm    Post subject: Reply with quote

dolphin fails here with
Code:
[ 66%] Building CXX object apps/dolphin/src/CMakeFiles/dolphin.dir/dolphincontextmenu.o
[ 67%] /var/tmp/paludis/kde-base-dolphin-scm/work/dolphin/apps/dolphin/src/dolphincontextmenu.cpp:44:39: error: konq_popupmenuinformation.h: No such file or directory

That file is found in SVN:
Code:
/usr/portage/distfiles/svn-src/KDE/kdebase/kdebase/apps/lib/konq/konq_popupmenuinformation.h


Not sure if this is a bug in SVN, or if it has to do with split ebuild & header things. At least it doesn't get installed with konqueror.
If I copy it over to include dir, then it works.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Mon May 19, 2008 9:39 pm    Post subject: Reply with quote

gimpel wrote:
dolphin fails here with
Code:
[ 66%] Building CXX object apps/dolphin/src/CMakeFiles/dolphin.dir/dolphincontextmenu.o
[ 67%] /var/tmp/paludis/kde-base-dolphin-scm/work/dolphin/apps/dolphin/src/dolphincontextmenu.cpp:44:39: error: konq_popupmenuinformation.h: No such file or directory

That file is found in SVN:
Code:
/usr/portage/distfiles/svn-src/KDE/kdebase/kdebase/apps/lib/konq/konq_popupmenuinformation.h


Not sure if this is a bug in SVN, or if it has to do with split ebuild & header things. At least it doesn't get installed with konqueror.
If I copy it over to include dir, then it works.

Once again they don't bother to install all necessary headers.
I'll fix that tomorrow or so.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu May 22, 2008 1:00 am    Post subject: Reply with quote

Invested a bit of time.
kdesdk, kdeadmin and kdeaccessibility are now there.
kdepim should be fixed, too.
Converted kepas, kmplayer and kblogger (I don't use those, but they seem run fine).

Please report problems with these, preferably over irc. ;)
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Thu May 22, 2008 7:40 am    Post subject: Reply with quote

is krunner working fine???
(as in seigo's screencast?)

i miss the metapackages (kdebase, kdemultimedia, kdegraphics, kdeutils, etc.)

is there a way to get them back??
_________________
Mens sana in corpore sano... Gentoo laetificat cor hominis
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu May 22, 2008 12:16 pm    Post subject: Reply with quote

enzobelmont wrote:
is krunner working fine???
(as in seigo's screencast?)

afaics, yes.

Quote:
i miss the metapackages (kdebase, kdemultimedia, kdegraphics, kdeutils, etc.)

is there a way to get them back??

No, we decided to drop the meta packages in favour of the sets, which are just better.
To install everything in kdebase:
Code:
paludis -i1 kdebase-scm*


To keep everything in kdebase installed:
Code:
paludis -i kdebase-scm

I don't suggest, that you add a setname* set to the world file, unless you are sure, that you always want to have every package from that set installed.

What is the difference between the foo and the foo* set?
The foo is the "real" set, it contains a list of packages, that are optional, which means, that they are only part of the set, if they are installed.
So "paludis -i1 kdebase-scm" would not install any package, but "paludis -i1 --dl-reinstall-targets always kdebase-scm" would reinstall every package in kdebase-scm, that is installed.
So it wouldn't pull unnecessary stuff in, that you didn't install in the first place.
The foo* set is not a real set, it's a variation of the foo set (so for every set, there exists a * set). It contains the same list of packages, but they are not optional, instead they are always part of the set.
So "paludis -i1 kdebase-scm*" would install every package in kdebase-scm, "paludis -i1 --dl-reinstall-targets always kdebase-scm*" would reinstall all packages that are part of kdebase-scm and installed and install every package in there, that is not installed.

So what do you use which one of the too?
foo:
- Add to world file, to keep installed packages
- Reinstall packages (with --dl-reinstall-targets or --dl-reinstall-scm)

foo*:
- Install packages
- Unmask/Keyword packages (for example kdebase-scm* in package_unmask.conf will unmask every package in kdebase-scm, while kdebase-scm in package_unmask.conf would only unmask the packages that are installed


Hope you understood, why the sets are just better than the meta stuff. ;)
BTW, to use the sets, you don't have to copy them, since they are in the sets/ dir in the repo and paludis uses them automatically.
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Thu May 22, 2008 4:29 pm    Post subject: Reply with quote

thanks man...
everything is running fine here (bugs included)...
_________________
Mens sana in corpore sano... Gentoo laetificat cor hominis
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 26, 27, 28  Next
Page 7 of 28

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum